Bug 837129

Summary: [jboss-as-5] Shutdown operation is not performed if server availability can not be determined
Product: [Other] RHQ Project Reporter: Larry O'Leary <loleary>
Component: OperationsAssignee: RHQ Project Maintainer <rhq-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Mike Foley <mfoley>
Severity: high Docs Contact:
Priority: high    
Version: 4.4CC: hrupp, jshaughn
Target Milestone: ---   
Target Release: RHQ 4.5.0   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 837126 Environment:
Last Closed: 2013-09-12 11:12:43 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 837126, 846269    

Description Larry O'Leary 2012-07-02 17:38:42 EDT
+++ This bug was initially created as a clone of JON product Bug #837126 +++

Description of problem:
If JBoss EAP server has become unstable due to OutOfMemoryError condition or other problem that prevents the JBoss AS 5 plug-in from obtaining a connection to the server/service, it is reported as DOWN and the shutdown operation invocation does not occur even when a script is used as the shutdown method.

The result is that an unstable or runaway EAP server can not be shutdown from the JON management UI.

Version-Release number of selected component (if applicable):
3.1.0

How reproducible:
Always

 
Actual results:
If EAP resource is shown with availability of UNKNOWN or DOWN, the shutdown operation is not performed and the operation result is: The server is already shut down.

Expected results:
The shutdown operation should still be invoked regardless of the availability of the EAP resource.

Additional info:
This is due to theo rg.rhq.plugins.jbossas5.ApplicationServerOperationsDelegate.shutDown() first retrieving the availability of the resource and if DOWN is returned, the method is aborted[1]. This prevent a custom shutdown script from performing a forced shutdown in the event the EAP server has become unresponsive (kill -2/kill -9).



[1]: http://git.fedorahosted.org/git?p=rhq/rhq.git;a=blob;f=modules/plugins/jboss-as-5/src/main/java/org/rhq/plugins/jbossas5/ApplicationServerOperationsDelegate.java;h=5ac0413999c735cbd4e688d19c4089bc3b484c6c;hb=refs/heads/release/jon3.1.x#l306
Comment 2 Jay Shaughnessy 2013-09-12 11:12:43 EDT
This has been fixed. See Bug #837126.  Closing...