Bug 837126 - [jboss-as-5] Shutdown operation is not performed if server availability can not be determined
[jboss-as-5] Shutdown operation is not performed if server availability can n...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Operations (Show other bugs)
JON 3.1.0
All All
high Severity high
: ---
: JON 3.1.1
Assigned To: Lukas Krejci
Mike Foley
:
Depends On: 837129
Blocks: 846269
  Show dependency treegraph
 
Reported: 2012-07-02 17:35 EDT by Larry O'Leary
Modified: 2013-09-11 07:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 837129 846269 (view as bug list)
Environment:
Last Closed: 2013-09-11 07:01:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 148693 None None None 2012-07-02 18:02:05 EDT

  None (edit)
Description Larry O'Leary 2012-07-02 17:35:26 EDT
Description of problem:
If JBoss EAP server has become unstable due to OutOfMemoryError condition or other problem that prevents the JBoss AS 5 plug-in from obtaining a connection to the server/service, it is reported as DOWN and the shutdown operation invocation does not occur even when a script is used as the shutdown method.

The result is that an unstable or runaway EAP server can not be shutdown from the JON management UI.

Version-Release number of selected component (if applicable):
3.1.0

How reproducible:
Always

 
Actual results:
If EAP resource is shown with availability of UNKNOWN or DOWN, the shutdown operation is not performed and the operation result is: The server is already shut down.

Expected results:
The shutdown operation should still be invoked regardless of the availability of the EAP resource.

Additional info:
This is due to theo rg.rhq.plugins.jbossas5.ApplicationServerOperationsDelegate.shutDown() first retrieving the availability of the resource and if DOWN is returned, the method is aborted[1]. This prevent a custom shutdown script from performing a forced shutdown in the event the EAP server has become unresponsive (kill -2/kill -9).



[1]: http://git.fedorahosted.org/git?p=rhq/rhq.git;a=blob;f=modules/plugins/jboss-as-5/src/main/java/org/rhq/plugins/jbossas5/ApplicationServerOperationsDelegate.java;h=5ac0413999c735cbd4e688d19c4089bc3b484c6c;hb=refs/heads/release/jon3.1.x#l306
Comment 1 Larry O'Leary 2012-07-02 18:05:21 EDT
This issue prevents an alert definition from performing a resource restart in the event that something bad happens in the resource. For example, if a user wants to auto-restart a production JBoss EAP server in the event that a resource limit is reached (OOME), this issue prevents the restart from being successful.
Comment 2 Charles Crouch 2012-08-02 22:00:05 EDT
We should take a look at this and see if there are any repercussions from removing the avail check.
Comment 3 Lukas Krejci 2012-08-07 10:55:31 EDT
release/jon3.1.x http://git.fedorahosted.org/cgit/rhq/rhq.git/diff/?id=b519248ec59f0e4a403a5722f23872c96316508c
Author: Lukas Krejci <lkrejci@redhat.com>
Date:   Tue Aug 7 15:54:18 2012 +0200

    [BZ 846269] - AS5's shutdown operation doesn't require availability to be up.
    (cherry picked from commit 153be59c5228bfe4e63657da405d30b5bdb6b423)
Comment 4 John Sanda 2012-08-13 22:16:54 EDT
Moving to ON_QA since JON 3.1.1 ER2 build is availble - https://brewweb.devel.redhat.com/buildinfo?buildID=228250
Comment 5 Filip Brychta 2012-09-14 07:57:12 EDT
Verified that shutdown.sh is called even when eap availability is down. Verified on 3.1.1.CR2

Note You need to log in before you can comment on or make changes to this bug.