Bug 837691

Summary: Data loss when writing to qcow2-format disk files
Product: Red Hat Enterprise Linux 6 Reporter: Richard W.M. Jones <rjones>
Component: libguestfsAssignee: Richard W.M. Jones <rjones>
Status: CLOSED ERRATA QA Contact: Virtualization Bugs <virt-bugs>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.4CC: dyasny, juzhang, knoel, leiwang, mbooth, moli, qguan
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: libguestfs-1.16.30-2.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 836710
: 837941 (view as bug list) Environment:
Last Closed: 2013-02-21 03:38:30 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On: 836710    
Bug Blocks:    

Description Richard W.M. Jones 2012-07-04 15:47:00 EDT
+++ This bug was initially created as a clone of Bug #836710 +++

For a full description of the bug, read this:

https://www.redhat.com/archives/libguestfs/2012-July/msg00020.html

Note that we are very lucky: the bug does NOT affect RHEL 6.3
as far as I can tell from my testing.  However I think it'd
be a very good idea to backport the required fixes into
RHEL 6.4, and even consider a 6.3 z-stream fix.
Comment 1 RHEL Product and Program Management 2012-07-10 04:07:39 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:48:56 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 5 Richard W.M. Jones 2012-11-02 04:15:14 EDT
(In reply to comment #4)
> Rich,
> 
> for the qemu version, in your env, the qemu version is
> qemu-system-x86-1.0-17.fc18.x86_64, but in RHEL6.x, qemu-kvm is from
> upstream version qemu-0.12, so i need an upstream version of qemu to
> reproduce this bug, so far, i didn't see how to reproduce and verify this
> bug in rhel6.x? any suggestion for this?

There isn't any version of qemu-kvm in RHEL 6 which exhibits
the crashing bug (luckily!).  You could try an upstream version,
but probably a better idea is to modify upstream qemu so it
crashes deliberately on shutdown.

I just had a quick look at the source, and *maybe* adding
a call to abort() in vl.c: qemu_kill_report() ?

I can have a look into this in more detail later.
Comment 10 errata-xmlrpc 2013-02-21 03:38:30 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0324.html