Bug 837941 - Data loss when writing to qcow2-format disk files
Data loss when writing to qcow2-format disk files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On: 836710
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 17:18 EDT by Richard W.M. Jones
Modified: 2013-07-18 12:03 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 837691
Environment:
Last Closed: 2013-07-18 12:01:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2012-07-05 17:18:51 EDT
+++ This bug was initially created as a clone of Bug #836710 +++

For a full description of the bug, read this:

https://www.redhat.com/archives/libguestfs/2012-July/msg00020.html
Comment 2 bfan 2013-07-05 04:34:46 EDT
Hello,
I tried your script and do more than 500 runs, it has no error output.
https://bugzilla.redhat.com/show_bug.cgi?id=836710#c5

Is there need other steps to repoduce?
Comment 3 Richard W.M. Jones 2013-07-05 05:17:33 EDT
(In reply to bfan from comment #2)
> Hello,
> I tried your script and do more than 500 runs, it has no error output.
> https://bugzilla.redhat.com/show_bug.cgi?id=836710#c5
> 
> Is there need other steps to repoduce?

This was actually a bug in qemu.  The problem was that
qemu's qcow2 code used to crash, and libguestfs didn't
detect the crash (so instead you would just get occasional
lost data writes).  Since then:

 - qemu was fixed so the qcow2 code no longer crashes

 - the kernel was fixed so it issues a write barrier for sync

 - libguestfs has been modified to add a guestfs_shutdown
   call to detect these crashes and report the error
   instead of ignoring it.

Since this was all fixed a long time ago, it's unlikely
that you will be able to reproduce the bug.  You would
have to go back to some quite old versions of qemu, kernel
and libguestfs.

My suggestion is that we close this bug.  Even if the
qemu bug reappears, libguestfs will now detect and report
it.
Comment 4 Richard W.M. Jones 2013-07-18 12:01:08 EDT
I am closing this, based on my previous comment.

Note You need to log in before you can comment on or make changes to this bug.