Bug 840826

Summary: Add git-review in EPEL6
Product: [Fedora] Fedora Reporter: Trond H. Amundsen <t.h.amundsen>
Component: git-reviewAssignee: Pete Zaitcev <zaitcev>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: tomspur, zaitcev
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-21 14:39:23 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Trond H. Amundsen 2012-07-17 06:20:22 EDT
I've been playing with git-review. It's a very useful tool, and I would love to see it in EPEL6. I have done a scratch-build and verified that it builds, and the resulting RPM works just fine on RHEL6:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=4238216

I've noticed one thing that should be addressed in the EPEL6 branch. Git-review requires argparse.py, which is part of python-libs in F17 but is in a separate package 'python-argparse' for RHEL6. For the EPEL6 branch there should probably be an explicit Requires for python-argparse, as this dependency wasn't discovered automatically during build.
Comment 1 Pete Zaitcev 2012-08-01 21:57:48 EDT
This is weird, I threw it into Koji and it worked without any changes
to Require: python-argparse.
 http://koji.fedoraproject.org/koji/buildinfo?buildID=345369
Comment 2 Thomas Spura 2012-08-02 05:10:31 EDT
Requires are evaluated on installing the package.
So when installing [1], python-argparse won't be installed and when it's not installed "by accident" git-review will fail, when it tries to import it.

[1] http://koji.fedoraproject.org/koji/rpminfo?rpmID=3277506
Comment 3 Trond H. Amundsen 2012-08-02 05:26:39 EDT
An interesting question is why Koji doesn't automatically detect the argparse requirement. Perhaps it's because 'import argparse' is inside main().
Comment 4 Thomas Spura 2012-08-02 06:20:00 EDT
I don't know the current state of this, but someone wanted to work on this:
http://lists.fedoraproject.org/pipermail/python-devel/2010-March/000230.html

AFAIK, there are still no automatic provides/requires yet.
Comment 5 Pete Zaitcev 2012-08-02 12:47:42 EDT
I see. The result is a package that builds and installs but fails with
"ImportError: No module named argparse".
Comment 6 Pete Zaitcev 2012-08-02 15:59:01 EDT
Hopefuly git-review-1.17-2.el6 works better.
 https://koji.fedoraproject.org/koji/buildinfo?buildID=345641

(looks like I build 1.17-2.el6 which is not at all the same as 1.17-2.fc17)
Comment 7 Trond H. Amundsen 2012-08-02 17:00:39 EDT
Thanks Pete. Tested git-review-1.17-2.el6 and confirmed that it works. Also, python-argparse was correctly pulled in as dependency.
Comment 8 Fedora Update System 2012-08-02 18:42:44 EDT
git-review-1.17-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/git-review-1.17-2.el6
Comment 9 Fedora Update System 2012-08-05 02:39:03 EDT
git-review-1.17-2.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 10 Fedora Update System 2012-08-21 14:39:23 EDT
git-review-1.17-2.el6 has been pushed to the Fedora EPEL 6 stable repository.