Bug 840826 - Add git-review in EPEL6
Summary: Add git-review in EPEL6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: git-review
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-07-17 10:20 UTC by Trond H. Amundsen
Modified: 2012-08-21 18:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-21 18:39:23 UTC


Attachments (Terms of Use)

Description Trond H. Amundsen 2012-07-17 10:20:22 UTC
I've been playing with git-review. It's a very useful tool, and I would love to see it in EPEL6. I have done a scratch-build and verified that it builds, and the resulting RPM works just fine on RHEL6:

  http://koji.fedoraproject.org/koji/taskinfo?taskID=4238216

I've noticed one thing that should be addressed in the EPEL6 branch. Git-review requires argparse.py, which is part of python-libs in F17 but is in a separate package 'python-argparse' for RHEL6. For the EPEL6 branch there should probably be an explicit Requires for python-argparse, as this dependency wasn't discovered automatically during build.

Comment 1 Pete Zaitcev 2012-08-02 01:57:48 UTC
This is weird, I threw it into Koji and it worked without any changes
to Require: python-argparse.
 http://koji.fedoraproject.org/koji/buildinfo?buildID=345369

Comment 2 Thomas Spura 2012-08-02 09:10:31 UTC
Requires are evaluated on installing the package.
So when installing [1], python-argparse won't be installed and when it's not installed "by accident" git-review will fail, when it tries to import it.

[1] http://koji.fedoraproject.org/koji/rpminfo?rpmID=3277506

Comment 3 Trond H. Amundsen 2012-08-02 09:26:39 UTC
An interesting question is why Koji doesn't automatically detect the argparse requirement. Perhaps it's because 'import argparse' is inside main().

Comment 4 Thomas Spura 2012-08-02 10:20:00 UTC
I don't know the current state of this, but someone wanted to work on this:
http://lists.fedoraproject.org/pipermail/python-devel/2010-March/000230.html

AFAIK, there are still no automatic provides/requires yet.

Comment 5 Pete Zaitcev 2012-08-02 16:47:42 UTC
I see. The result is a package that builds and installs but fails with
"ImportError: No module named argparse".

Comment 6 Pete Zaitcev 2012-08-02 19:59:01 UTC
Hopefuly git-review-1.17-2.el6 works better.
 https://koji.fedoraproject.org/koji/buildinfo?buildID=345641

(looks like I build 1.17-2.el6 which is not at all the same as 1.17-2.fc17)

Comment 7 Trond H. Amundsen 2012-08-02 21:00:39 UTC
Thanks Pete. Tested git-review-1.17-2.el6 and confirmed that it works. Also, python-argparse was correctly pulled in as dependency.

Comment 8 Fedora Update System 2012-08-02 22:42:44 UTC
git-review-1.17-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/git-review-1.17-2.el6

Comment 9 Fedora Update System 2012-08-05 06:39:03 UTC
git-review-1.17-2.el6 has been pushed to the Fedora EPEL 6 testing repository.

Comment 10 Fedora Update System 2012-08-21 18:39:23 UTC
git-review-1.17-2.el6 has been pushed to the Fedora EPEL 6 stable repository.


Note You need to log in before you can comment on or make changes to this bug.