This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours

Bug 842068

Summary: libvirt completely non-functional in Rawhide: no connection driver available for No connection for URI (null)
Product: [Fedora] Fedora Reporter: Richard W.M. Jones <rjones>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: abokovoy, acathrow, berrange, clalancette, dougsland, fredericg_99, itamar, jforbes, jyang, laine, libvirt-maint, stefw, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-15 08:25:53 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Output from LIBVIRT_DEBUG=1 none

Description Richard W.M. Jones 2012-07-21 12:00:43 EDT
Created attachment 599536 [details]
Output from LIBVIRT_DEBUG=1

Description of problem:

$ sudo virsh capabilities
error: Failed to reconnect to the hypervisor
error: no valid connection
error: no connection driver available for No connection for URI (null)
error: Failed to reconnect to the hypervisor

$ sudo virsh list --all
error: Failed to reconnect to the hypervisor
error: no valid connection
error: no connection driver available for No connection for URI (null)
error: Failed to reconnect to the hypervisor

Version-Release number of selected component (if applicable):

qemu-kvm-1.1.0-8.fc18.x86_64
libvirt-0.9.13-1.fc18.x86_64
libvirt-daemon-0.9.13-1.fc18.x86_64
Linux trick.home.annexia.org 3.5.0-0.rc5.git3.1.fc18.x86_64 #1 SMP Fri Jul 6 15:48:02 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:

100%

Steps to Reproduce:
1. Install libvirt, qemu from Rawhide or virt-preview.

Actual results:

Nothing works.

Similar problem with extra log messages reported here:
http://permalink.gmane.org/gmane.linux.redhat.fedora.virtualization/1843
(I don't see anything untoward in /var/log/messages)

Also attached is the output when LIBVIRT_DEBUG=1.
Comment 1 Richard W.M. Jones 2012-07-21 12:03:34 EDT
Setting SELinux to Permissive did NOT make a difference.
Comment 2 Richard W.M. Jones 2012-07-21 12:05:51 EDT
Also:

$ sudo virsh -c qemu:///system capabilities
error: no connection driver available for No connection for URI qemu:///system
error: failed to connect to the hypervisor

$ sudo virsh -c qemu+ssh://localhost/system capabilities
root@localhost's password: 
error: no connection driver available for No connection for URI qemu:///system
error: failed to connect to the hypervisor
Comment 3 Richard W.M. Jones 2012-07-21 12:07:22 EDT
In case it makes a difference, I'm still running the old 'nc':
$ rpm -qf /bin/nc
nc-1.107.20120403-1.fc17.x86_64
Comment 4 Richard W.M. Jones 2012-07-21 15:31:24 EDT
Thanks to laine for pointing out that this fixes it:

sudo yum install libvirt-daemon-kvm
sudo service libvirtd restart
Comment 5 Frederic Grelot 2012-07-22 10:39:35 EDT
Problem solved for me as well with comment #4
Comment 6 Daniel Berrange 2012-07-23 06:00:29 EDT
Yes, this is an RPM packaging bug, fixed upstream with


https://www.redhat.com/archives/libvir-list/2012-July/msg00766.html
Comment 7 Richard W.M. Jones 2012-08-11 04:19:48 EDT
I'm still getting this problem (or maybe a different one?)
and even the workaround in comment 4 doesn't work.

$ sudo yum install libvirt-daemon-kvm libvirt-daemon-qemu
Loaded plugins: langpacks, presto, refresh-packagekit
Package libvirt-daemon-kvm-0.10.0-0rc0.fc18.x86_64 already installed and latest version
Package libvirt-daemon-qemu-0.10.0-0rc0.fc18.x86_64 already installed and latest version
Nothing to do

$ sudo service libvirtd restart
Restarting libvirtd (via systemctl):                       [  OK  ]

$ sudo virsh -c qemu:///system capabilities
error: no connection driver available for No connection for URI qemu:///system
error: failed to connect to the hypervisor

$ virsh -c qemu:///system capabilities
error: authentication failed: Authorization requires authentication but no agent is available.

error: failed to connect to the hypervisor

$ rpm -qa | grep libvirt | sort
libvirt-0.10.0-0rc0.fc18.x86_64
libvirt-client-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-config-network-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-config-nwfilter-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-interface-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-libxl-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-lxc-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-network-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-nodedev-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-nwfilter-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-qemu-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-secret-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-storage-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-uml-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-driver-xen-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-kvm-0.10.0-0rc0.fc18.x86_64
libvirt-daemon-qemu-0.10.0-0rc0.fc18.x86_64
libvirt-debuginfo-0.10.0-0rc0.fc18.x86_64
libvirt-devel-0.10.0-0rc0.fc18.x86_64
libvirt-docs-0.10.0-0rc0.fc18.x86_64
libvirt-python-0.10.0-0rc0.fc18.x86_64
ocaml-libvirt-0.6.1.2-2.fc18.x86_64
ocaml-libvirt-devel-0.6.1.2-2.fc18.x86_64
Comment 8 Stef Walter 2012-08-14 07:58:02 EDT
*** Bug 847747 has been marked as a duplicate of this bug. ***
Comment 9 Stef Walter 2012-08-14 07:58:45 EDT
This may be why it's broken:

[root@stef-rawhide ~]# libvirtd
2012-08-14 11:57:01.061+0000: 29393: info : libvirt version: 0.10.0, package: 0rc0.fc19 (Fedora Project, 2012-08-08-14:54:24, )
2012-08-14 11:57:01.061+0000: 29393: error : virDriverLoadModule:78 : failed to load module /usr/lib64/libvirt/connection-driver/libvirt_driver_qemu.so /usr/lib64/libvirt/connection-driver/libvirt_driver_qemu.so: undefined symbol: virSecurityManagerGetModel
2012-08-14 11:57:01.062+0000: 29393: error : virDriverLoadModule:78 : failed to load module /usr/lib64/libvirt/connection-driver/libvirt_driver_lxc.so /usr/lib64/libvirt/connection-driver/libvirt_driver_lxc.so: undefined symbol: virSecurityManagerGetModel
Comment 10 Alexander Bokovoy 2012-08-15 08:21:07 EDT
DV has produced another build that tried to fix it -- http://koji.fedoraproject.org/koji/taskinfo?taskID=4388416 -- but this build still lacks virSecurityManagerGetModel (and all of other VirSecurityManager methods).

According to build logs, the patch to get security manager methods linked to libvirtd is applied, with no result.
Comment 11 Daniel Berrange 2012-08-15 08:25:53 EDT
That build was incorrect, since it applied the wrong upstream patch. I did a further build yesterday which resolves this libvirt-0.10.0-0rc0.2.fc18, and I've had confirmation that this one actually works
Comment 12 Alexander Bokovoy 2012-08-15 08:44:50 EDT
0rc0.2.fc18 works for me too. Thanks!
Comment 13 Zeeshan Ali 2012-08-20 09:46:09 EDT
*** Bug 848440 has been marked as a duplicate of this bug. ***
Comment 14 Richard W.M. Jones 2012-08-20 09:53:13 EDT
libvirt-0.10.0-0rc0.2.fc18.x86_64 fixes this for me.