Bug 847747 - no connection driver available for No connection for URI qemu:///system
no connection driver available for No connection for URI qemu:///system
Status: CLOSED DUPLICATE of bug 842068
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-13 08:25 EDT by Stef Walter
Modified: 2012-08-14 07:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-14 07:58:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stef Walter 2012-08-13 08:25:24 EDT
Description of problem:

After a yum upgrade, get the following message when trying to use virt-manager:

Unable to connect to libvirt.

no connection driver available for No connection for URI qemu:///system

Libvirt URI is: qemu:///system

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/connection.py", line 1027, in _open_thread
    self.vmm = self._try_open()
  File "/usr/share/virt-manager/virtManager/connection.py", line 1009, in _try_open
    flags)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 102, in openAuth
    if ret is None:raise libvirtError('virConnectOpenAuth() failed')
libvirtError: no connection driver available for No connection for URI qemu:///system

It seems that libvirt is not installed? Why isn't libvirt a dependency of virt-manager?

Version-Release number of selected component (if applicable):

Installed Packages
Name        : virt-manager
Arch        : noarch
Version     : 0.9.4
Release     : 1.fc18.1

How reproducible:

Every time.

Steps to Reproduce:
1. virt-manager
  
Actual results:

Error message.

Expected results:

Should show virtual machines.
Comment 1 Stef Walter 2012-08-13 09:00:40 EDT
Installed Packages
Name        : libvirt
Arch        : x86_64
Version     : 0.10.0
Release     : 0rc0.fc19
Size        : 0.0  

Seems like qemu is not installed or got uninstalled during an upgrade. But after installing it I still get the same error.

Installed Packages
Name        : qemu-system-x86
Arch        : x86_64
Epoch       : 2
Version     : 1.2
Release     : 0.1.20120806git3e430569.fc18
Comment 2 Stef Walter 2012-08-14 07:58:02 EDT

*** This bug has been marked as a duplicate of bug 842068 ***

Note You need to log in before you can comment on or make changes to this bug.