This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 842850

Summary: Remove dep on salt
Product: [Fedora] Fedora Reporter: Toshio Ernie Kuratomi <a.badger>
Component: saltAssignee: Clint Savage <herlo1>
Status: CLOSED NEXTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: herlo1, thatch45
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-08-21 12:34:33 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 843176    

Description Toshio Ernie Kuratomi 2012-07-24 14:01:44 EDT
Description of problem:

We're trying to get rid of PyXML in Fedora 18 due to not being maintained upstream, having outstanding bugs, and having the dubious behaviour of overriding the python stdlib's xml module when it is installed.

I've taken a look at salt's Requirement on PyXML and I think we can get rid of it.  salt is using xml.dom.minidom which is available in the stdlib's xml module.  No need for PyXML.  (We can probably remove the Requires: python26-PyXML as well).
Comment 1 Clint Savage 2012-07-24 14:07:50 EDT
Let me have a conversation with the upstream maintainer and see what we can do, but I think you are probably right.
Comment 2 Thomas S Hatch 2012-07-24 18:34:51 EDT
Salt does not have a dep on PyXML. It is only used if someone wants the test suite and output the data to XML. This was added only to integrate the test suite with Jenkins. Removal of the PyXML dep would have no negative bearing on the operation of Salt and no other distro packages require PyXML.

- Thomas S Hatch
Comment 3 Clint Savage 2012-07-29 17:57:22 EDT
Since 0.10.2 is coming out shortly, I'll apply the fix to the spec file there.
Comment 4 Toshio Ernie Kuratomi 2012-08-21 12:34:33 EDT
Looks fixed.  I'll close this bug.  Thanks herlo!