Bug 843551

Summary: [iwl3945]: WARNING: _il_grab_nic_access
Product: [Fedora] Fedora Reporter: winnen209
Component: kernelAssignee: Stanislaw Gruszka <sgruszka>
Status: CLOSED WORKSFORME QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: bugs, gansalmon, itamar, jonathan, kernel-maint, madhu.chinakonda, winnen209
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard: abrt_hash:3a1599ce18283860da3b7299860e831504444a09
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-14 09:06:05 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description winnen209 2012-07-26 11:12:18 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/vmlinuz-3.4.2-1.fc16.i686 root=/dev/mapper/vg_ceryx-lv_root ro rd.lvm.lv=vg_ceryx/lv_swap rd.md=0 rd.dm=0 KEYTABLE=us quiet rd.lvm.lv=vg_ceryx/lv_root rhgb rd.luks=0 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8

backtrace:
:WARNING: at drivers/net/wireless/iwlegacy/common.c:117 _il_grab_nic_access+0x96/0xa0 [iwlegacy]()
:Hardware name: Gateway M290                    
:Timeout waiting for ucode processor access (CSR_GP_CNTRL 0xffffffff)
:Modules linked in: fcoe 8021q libfcoe libfc scsi_transport_fc garp stp scsi_tgt llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack fuse arc4 snd_hda_codec_idt snd_hda_intel snd_hda_codec iwl3945 iwlegacy snd_hwdep snd_seq snd_seq_device e1000e mac80211 snd_pcm cfg80211 snd_timer snd soundcore coretemp tifm_7xx1 tifm_core i2c_i801 joydev iTCO_wdt iTCO_vendor_support microcode snd_page_alloc rfkill serio_raw uinput firewire_ohci firewire_core crc_itu_t sdhci_pci sdhci mmc_core yenta_socket wmi video radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core [last unloaded: scsi_wait_scan]
:Pid: 920, comm: NetworkManager Not tainted 3.4.2-1.fc16.i686 #1
:Call Trace:
: [<c0437822>] warn_slowpath_common+0x72/0xa0
: [<f7ee5506>] ? _il_grab_nic_access+0x96/0xa0 [iwlegacy]
: [<f7ee5506>] ? _il_grab_nic_access+0x96/0xa0 [iwlegacy]
: [<c04378f3>] warn_slowpath_fmt+0x33/0x40
: [<f7ee5506>] _il_grab_nic_access+0x96/0xa0 [iwlegacy]
: [<f7ee57a2>] il_wr_prph+0x32/0x90 [iwlegacy]
: [<f7ee59b9>] il_apm_init+0x1b9/0x360 [iwlegacy]
: [<c08d3f64>] ? inet6_fill_ifla6_attrs+0x244/0x260
: [<f81ca535>] il3945_apm_init+0x15/0x130 [iwl3945]
: [<f81cbe77>] il3945_hw_nic_init+0x27/0x9f0 [iwl3945]
: [<c0850c48>] ? rtnl_fill_ifinfo+0xa58/0xd30
: [<f81c4662>] __il3945_up+0xb2/0x300 [iwl3945]
: [<f81864eb>] ? cfg80211_can_change_interface+0x1b/0x210 [cfg80211]
: [<f81c4dff>] il3945_mac_start+0x54f/0xea0 [iwl3945]
: [<f818364c>] ? cfg80211_netdev_notifier_call+0xac/0x520 [cfg80211]
: [<f90d1555>] ? cnic_from_netdev+0x15/0x60 [cnic]
: [<f90d3b2b>] ? cnic_netdev_event+0x24b/0x2a0 [cnic]
: [<f86544a9>] ieee80211_do_open+0x2a9/0x9e0 [mac80211]
: [<f86526a5>] ? ieee80211_check_concurrent_iface+0x25/0x180 [mac80211]
: [<c045a901>] ? __raw_notifier_call_chain+0x1/0x30
: [<f8654c3c>] ieee80211_open+0x5c/0x60 [mac80211]
: [<c084504b>] __dev_open+0x8b/0xe0
: [<c0933593>] ? _raw_spin_unlock_bh+0x13/0x20
: [<c0844fae>] ? dev_set_rx_mode+0x2e/0x40
: [<c08452c2>] __dev_change_flags+0x82/0x150
: [<c083745e>] ? __alloc_skb+0x2e/0x200
: [<c0845431>] dev_change_flags+0x21/0x60
: [<c084f8d9>] do_setlink+0x249/0x8b0
: [<c0850030>] ? rtnetlink_put_metrics+0xf0/0xf0
: [<c066961f>] ? nla_parse+0x1f/0xa0
: [<c0850030>] ? rtnetlink_put_metrics+0xf0/0xf0
: [<c08500e7>] rtnl_setlink+0xb7/0x110
: [<c0441100>] ? sys_sysctl+0x120/0x1a0
: [<c08513de>] rtnetlink_rcv_msg+0x13e/0x280
: [<c08512a0>] ? __rtnl_unlock+0x20/0x20
: [<c08660be>] netlink_rcv_skb+0x8e/0xb0
: [<c084f42c>] rtnetlink_rcv+0x1c/0x30
: [<c0865b25>] netlink_unicast+0x175/0x1c0
: [<c0865d58>] netlink_sendmsg+0x1e8/0x310
: [<c082f56f>] sock_sendmsg+0xff/0x120
: [<c082f56f>] ? sock_sendmsg+0xff/0x120
: [<c065b622>] ? _copy_from_user+0x42/0x60
: [<c083abf4>] ? verify_iovec+0x44/0xb0
: [<c08307ea>] __sys_sendmsg+0x24a/0x260
: [<c0601844>] ? security_file_permission+0x24/0xb0
: [<c065b622>] ? _copy_from_user+0x42/0x60
: [<c05352de>] ? do_readv_writev+0x13e/0x190
: [<c08317db>] sys_sendmsg+0x3b/0x60
: [<c0831e83>] sys_socketcall+0x283/0x2e0
: [<c093a79f>] sysenter_do_call+0x12/0x28
Comment 1 Stanislaw Gruszka 2012-07-27 05:58:54 EDT
What you do when this warning happen (suspend from resume, boot machine or something else)? It is reproducible or happen accidentally and never repeat again?
Comment 2 winnen209 2012-07-27 11:15:59 EDT
(In reply to comment #1)
> What you do when this warning happen (suspend from resume, boot machine or
> something else)? It is reproducible or happen accidentally and never repeat
> again?

The bug is highly reproducible, and has been going on for some time. It occurs about 50% of the time from the following steps.

The warning is generated as follows:
1. Boot system*, load Desktop Environment (Gnome 3 is the current case, it has happened in others as well)
2. Check that wireless is connecting and internet works, confirm it does.
3. Suspend system from the DE menu. (Any method of suspending should generate the same warning/error)
4. Resume system. <----- This is when the warning is issued.
5. Check wireless status, see that it is not detecting the wireless card.

Upon the warning being issued, the system no longer recognizes the wireless card, and no action short of rebooting seems to redetect the card.  I have tried modprobe, restarting NetworkManager, turning the hardware switch off and then on again,  and several other potential solutions without results.

*NOTE: Even upon booting, the system occasionally will not load the wireless card drivers, but this happens much less often than suspend/resume.  

When the error occurs, the system does not recognize wireless at all. Gnome's NetworkManager plugin will list wireless as an option upon resume, but will not list a card or any networks.

I believe the issue is a kernel/driver issue, rather than a NetworkManager issue, but I admit I do not know enough to confirm that.
Comment 3 Stanislaw Gruszka 2012-07-31 04:55:36 EDT
So issue happens after resume from suspend to RAM. 

"CSR_GP_CNTRL 0xffffffff" mean that we can not talk to with device through PCIe bus, iow this is PCI driver or hardware bug.

We have few similar issues reported:

http://marc.info/?t=133148795500004&r=1&w=2
https://bugzilla.kernel.org/show_bug.cgi?id=42658
http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2143

Are you using compiz or similar? If so does disabling it help. If not, does workaround from http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2143#c44
help?
Comment 4 Stanislaw Gruszka 2012-09-19 04:00:53 EDT
*** Bug 857536 has been marked as a duplicate of this bug. ***
Comment 5 Stanislaw Gruszka 2012-09-19 04:01:58 EDT
Are you using compiz or similar? If so does disabling it help. If not, does workaround from http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2143#c44
help?
Comment 6 winnen209 2012-09-19 17:26:54 EDT
For (In reply to comment #5)
> Are you using compiz or similar? If so does disabling it help. If not, does
> workaround from
> http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2143#c44
> help?

I am not using Compiz with the system's Gnome 3.

This workaround works for me. I made a small script to run any time the issue comes up and it fixes it every time.  Thank you.  Still, it is troublesome that it is necessary to do so.
Comment 7 Stanislaw Gruszka 2012-10-08 05:44:29 EDT
Can you still reproduce it on 3.5 ? F-16 did not update to 3.5 but you might try to download below F-17 kernel and try to boot it and test if issue is still present.

http://koji.fedoraproject.org/koji/buildinfo?buildID=357945
Comment 8 Dave Jones 2012-10-23 11:33:07 EDT
# Mass update to all open bugs.

Kernel 3.6.2-1.fc16 has just been pushed to updates.
This update is a significant rebase from the previous version.

Please retest with this kernel, and let us know if your problem has been fixed.

In the event that you have upgraded to a newer release and the bug you reported
is still present, please change the version field to the newest release you have
encountered the issue with.  Before doing so, please ensure you are testing the
latest kernel update in that release and attach any new and relevant information
you may have gathered.

If you are not the original bug reporter and you still experience this bug,
please file a new report, as it is possible that you may be seeing a
different problem. 
(Please don't clone this bug, a fresh bug referencing this bug in the comment is sufficient).
Comment 9 winnen209 2012-11-14 11:01:21 EST
This PCI bug appears to have been resolved with the new kernel.  I cannot replicate it on kernel 3.6.2-1.fc16.