Bug 854367

Summary: VMWare 9 causes networking crash.
Product: [Fedora] Fedora Reporter: Isaac Fischer <xwaver>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: collura, djfoxymaui, gansalmon, itamar, jforbes, jonathan, kernel-maint, kvolny, madhu.chinakonda, mjs, pahan, pavel1r, sn_, xwaver
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
See Also: https://bugzilla.redhat.com/show_bug.cgi?id=854422
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-10 11:30:32 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Isaac Fischer 2012-09-04 14:47:37 EDT
Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        BOOT_IMAGE=/vmlinuz-3.5.3-1.fc17.x86_64 root=/dev/mapper/vg_ikon-RootVolume ro rd.md=0 rd.dm=0 KEYTABLE=us SYSFONT=latarcyrheb-sun16 rd.luks=0 rd.lvm.lv=vg_ikon/RootVolume rd.lvm.lv=vg_ikon/SwapVolume LANG=en_US.UTF-8 rhgb quiet
kernel:         3.5.3-1.fc17.x86_64

backtrace:
:WARNING: at net/ipv4/tcp.c:1303 tcp_cleanup_rbuf+0x54/0x120()
:Hardware name: GA-MA785GM-US2H
:cleanup rbuf bug: copied A48FD80 seq A48FD80 rcvnxt A48FD80
:Modules linked in: fuse ebtable_nat ebtables ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 lockd ip6table_filter sunrpc ip6_tables iptable_nat nf_nat rfcomm iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 bnep xt_conntrack nf_conntrack binfmt_misc btusb bluetooth snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel joydev r8712u(C) snd_hda_codec rfkill snd_hwdep shpchp sp5100_tco r8169 mii serio_raw snd_pcm snd_page_alloc snd_timer snd soundcore i2c_piix4 edac_core edac_mce_amd ppdev parport_pc parport microcode k10temp vhost_net tun macvtap macvlan kvm_amd kvm uinput ata_generic pata_acpi firewire_ohci firewire_core crc_itu_t pata_atiixp wmi usb_storage radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 2241, comm: Chrome_IOThread Tainted: G         C   3.5.3-1.fc17.x86_64 #1
:Call Trace:
: [<ffffffff810584bf>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff810585b6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff815443c4>] tcp_cleanup_rbuf+0x54/0x120
: [<ffffffff8154564c>] tcp_recvmsg+0x76c/0xd30
: [<ffffffff81569c1b>] inet_recvmsg+0x6b/0x80
: [<ffffffff814e7612>] sock_aio_read.part.9+0x142/0x170
: [<ffffffff814e7665>] sock_aio_read+0x25/0x40
: [<ffffffff81187a06>] do_sync_read+0xe6/0x120
: [<ffffffff8127948a>] ? inode_has_perm.isra.31.constprop.61+0x2a/0x30
: [<ffffffff812764d2>] ? security_file_permission+0x92/0xb0
: [<ffffffff81187ea1>] ? rw_verify_area+0x61/0xf0
: [<ffffffff811883ed>] vfs_read+0x15d/0x180
: [<ffffffff8118845a>] sys_read+0x4a/0x90
: [<ffffffff81614ae9>] system_call_fastpath+0x16/0x1b
Comment 1 Allan Poulsen 2012-09-04 15:57:25 EDT
Tried to resume after suspend

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Marcos Martins da Silva 2012-09-04 16:10:42 EDT
Just launched Evolution. And it is working normally.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 Isaias Lourenco 2012-09-04 17:15:07 EDT
ran "yum update"

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 4 Dave Jones 2012-09-04 17:19:39 EDT
please mention which network driver you're using.
I'm curious if you're all using the same staging driver as Isaac.
Comment 5 Isaac Fischer 2012-09-04 17:40:46 EDT
(In reply to comment #4)
> please mention which network driver you're using.
> I'm curious if you're all using the same staging driver as Isaac.

r8712u

By the way, it may be related to sp5100_tco. It shows up as unassignable, I blacklisted it, and networking fails altogether. I unblacklist it with no problems. By the way, this oops only gets thrown in the 3.5 series, never in 3.4.
Comment 6 Greg Sieranski 2012-09-04 18:50:27 EDT
Started up OS.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Greg Sieranski 2012-09-04 18:50:54 EDT
Started Fedora 17.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 Mark Harfouche 2012-09-04 20:17:01 EDT
I have no idea

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 mariolinux 2012-09-04 20:55:42 EDT
I was resuming the notebook after the hibernate state due to a low critical battery level.
At any attempt to resume the notebook I logged in and after a few seconds the notebook was back into hibernation. The result was the same ​​with or without battery.
At the last attempt, just logged in I turned off the notebook to exit Hibernation.


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 John Reiser 2012-09-04 23:45:41 EDT
I don't know what caused the problem.  I've been plugging and unplugging USB2.0 flash memory devices (always unmounted first), and running livecd-iso-to-disk.  Then I noticed that the ABRT icon was ON in my XFCE desktop.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 Karel Volný 2012-09-05 03:22:23 EDT
I was just running something in dosbox and suddenly I was thrown into text console staring at the kernel crash ... but I think that dosbox is completely irrelevant in this case.
Note that I was not connected to a network.


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Karel Volný 2012-09-05 03:25:19 EDT
(In reply to comment #4)
> please mention which network driver you're using.
> I'm curious if you're all using the same staging driver as Isaac.

e1000e for wired and iwlwifi for wireless
Comment 13 Ching Yaw Hao 2012-09-05 08:21:58 EDT
I am using compaq CQ40 with AMD Turion X2
Currently using VMware to run Fedora 64bits


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 leandro 2012-09-05 10:47:23 EDT
i just booted the machine

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 VikFed 2012-09-05 14:16:18 EDT
Install a driver for ath9k_htc because the kernel build cause kernel panic

I follow this tutorial:
http://dwiel.net/blog/tp-link-tl-wn722n-on-ubuntu-10-04/


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 16 collura 2012-09-05 14:55:50 EDT
unknown was running updater gui

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Pete 2012-09-05 21:48:01 EDT
But i can't really say but for one, i try to start VMware Player .

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 18 Pete 2012-09-06 00:32:58 EDT
It happened when i try to open ISO file with VMware Player .

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 19 Greg Sieranski 2012-09-06 09:41:18 EDT
Using Firefox.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 20 Raj Upadhyaya 2012-09-06 10:26:46 EDT
I was deleting a message in evolution.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 22 Herman M. Hofman 2012-09-06 10:55:01 EDT
Shows this error every boot, right after login. 

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 23 Gary Case 2012-09-06 14:24:22 EDT
I'm sending/receiving email, am connected through VPN to my office, streaming di.fm through xmms, using an IRC client and working in Bugzilla and on other web pages.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 24 kychang 2012-09-06 21:46:28 EDT
This crash happened after connected iPhone_3GS(iOS 5.1) with my NB(Fedora 17).
And I must manually perform ideviceinfo by myself to enable the iPhoen eth sharing.


Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 25 Leandro 2012-09-06 23:28:02 EDT
I had to execute "modprobe -r ums_realtek" to be able to use the console. There was a message between 3 minutes that interrupted what I was doing. Now I wanted to use the usb and at the time I intended to unplug it this error appeared.

Thanks!


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 26 Dag Bjerkeli 2012-09-07 03:03:52 EDT
I suspect this error occured when I upgraded vmware workstation from 8.some to 9.0.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 27 Dag Bjerkeli 2012-09-07 03:46:50 EDT
Upgraded vmware workstation to 9. Did a reboot of system and problem occured.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 28 Dag Bjerkeli 2012-09-07 04:35:16 EDT
Re: comment 26 and 27. This issue is solved by patching vmware workstation. Found the article on 
http://virtuallyhyper.com/2012/09/vmware-workstation-9-on-fedora-17-cause-kernel-panic-with-eip-is-at-hostif_saferdmsr0x110x20-vmmon/
that reffered to discussion in vmware community:
http://communities.vmware.com/message/2103048

The patch reffered there solved the issue on my computer after a reboot.
Comment 29 Frank 2012-09-07 09:02:44 EDT
booted the computer and logged in

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 30 i4irsh 2012-09-07 09:10:09 EDT
When playing supertuxcart

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 31 dinyar.rabady+spam 2012-09-07 10:26:32 EDT
I deactivated and then activated my WIFI NIC via the hardware switch.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 32 Taylor Smock 2012-09-07 14:22:11 EDT
1. Suspend
2. Take out of suspend
3. Wireless asks for passcode. The one filled in works (sometimes).
4. Use switch to cut off wireless.
5. See error appear
6. Use switch to turn on wireless


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 33 David Love 2012-09-07 15:25:06 EDT
Power on of a Virtual Machine after sucessful installation of VMWare Workstation 9.0

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 34 Justin M. Forbes 2012-09-07 16:23:51 EDT
Is there anyone who has hit this and does not have VMWare installed at all?
Comment 35 Vilhjálmur Magnússon 2012-09-07 21:13:07 EDT
Just updated my computer.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 36 Mike Qin 2012-09-07 21:16:49 EDT
wireless disconnected. This kernel warning shows up. I have to reset my wireless NIC.

This error will also crash my wireless router as well, after this error happen, SSID of my wireless router is lost. Even though I restart my NIC several times and rescan again and again.

mike@mike-laptop% uname -a
Linux mike-laptop 3.5.3-1.fc17.x86_64 #1 SMP Wed Aug 29 18:46:34 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
mike@mike-laptop% lspci               
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:03.0 Communication controller: Intel Corporation Mobile 4 Series Chipset MEI Controller (rev 07)
00:03.2 IDE interface: Intel Corporation Mobile 4 Series Chipset PT IDER Controller (rev 07)
00:03.3 Serial controller: Intel Corporation Mobile 4 Series Chipset AMT SOL Redirection (rev 07)
00:19.0 Ethernet controller: Intel Corporation 82567LM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 37 Rick Swanson 2012-09-07 21:25:56 EDT
post install issue?

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 38 Neil 2012-09-08 01:21:37 EDT
Fucking Annoying those reports per session

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 39 Derek 2012-09-08 02:05:16 EDT
this problem seems to happen when i suspend. i wake up the computer and the wireless doesn't work until i remove the wireless pcmcia card and plug it back in.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 40 sn_ 2012-09-08 04:06:52 EDT
Assosciating with a wireless network using WPA/WPA2 Enterprise with Tunneld TSL authentication and PAP as inner authentication. I tried to connect to a wirless network which is part of the "eduroam" project. I am on a Thinkpad X201

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 41 sn_ 2012-09-08 04:09:23 EDT
(In reply to comment #40)
> Assosciating with a wireless network using WPA/WPA2 Enterprise with Tunneld
> TSL authentication and PAP as inner authentication. I tried to connect to a
> wirless network which is part of the "eduroam" project. I am on a Thinkpad
> X201
> 
> Package: kernel
> OS Release: Fedora release 17 (Beefy Miracle)

Also I had a phone connected to it at the same time and the computer was in suspend before.
Comment 42 Stuart W 2012-09-08 12:47:37 EDT
Installed fedora 17 from livecd
performed package update using gui


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 43 Stuart W 2012-09-08 12:48:53 EDT
Installed fedora 17
performed gui update


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 44 benoit.morel 2012-09-09 02:36:00 EDT
Problem at the start of fedora.
Sometime Grub Messages doesn't show up at the start so I have to get off the battery (it is a laptop) and the alimentation cable. So after that the quick message "welcome to Grub" appear finally and the choice for the "kernels" (right?) appears.
Then another problem just after that : it is also blocked after choosing one, if the fedora logo doesn't show, it is a black screen and I have to reboot  : sometime it work with Ctrl+Alt+Suppr or sometime It need a hard reboot... 
I alway succed finally, but It happen that I have to do it several times.
The sign for me is when the logo show up, it is good.
Bye,
Benbo


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 45 Sjoerd Mullender 2012-09-09 08:55:56 EDT
Basically just turning the thing on does this.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 46 vafr 2012-09-09 10:07:18 EDT
Start Ubuntu from VmPlayer

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 47 anon.leipzig 2012-09-09 11:53:14 EDT
This problem appears every time starting my pc.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 48 collura 2012-09-09 12:35:24 EDT
booted and ran yum gui and firefox

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 49 Daniel Bartkovic 2012-09-09 15:59:37 EDT
The error occured during system startup.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 50 Jaroslav 2012-09-09 17:28:45 EDT
no idea, just happened

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 51 tano 2012-09-09 19:39:00 EDT
help

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 52 Luis Villa 2012-09-09 19:56:13 EDT
Happened on initial boot after F16->F17 upgrade. No idea if reproduceable; will report if it happens on every boot.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 53 John Reiser 2012-09-09 23:40:50 EDT
The last unusual activity was running livecd-iso-to-disk onto a 8GB USB2.0 flash memory device with vfat filesystem.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 54 searcher 2012-09-10 00:58:14 EDT
system hungs and then you see this error after reboot.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 55 David Strauss 2012-09-10 01:38:56 EDT
Entered password to connect to Wi-Fi.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 56 Dave Jones 2012-09-10 11:30:32 EDT
Closing this as per comment #28.

If anyone is seeing this that ISN'T using vmware, please file a separate bug.
Comment 57 Pavel Alexeev 2012-09-11 11:28:01 EDT
Abrt refer me there as duplicate, and I do not use vmware.
Should I clone this bug?
Comment 58 Dave Jones 2012-09-11 12:03:57 EDT
no, open a new one, not clone.
Comment 59 Matthew Saltzman 2012-09-13 22:48:05 EDT
abrt processor insists on finding this one as a dup, even though I'm not using VMware.  Any suggestion how to force it to create a new bug or find another dup instead if it's already been filed?
Comment 60 Pavel Alexeev 2012-09-14 02:27:01 EDT
(In reply to comment #58)
> no, open a new one, not clone.

Ok https://bugzilla.redhat.com/show_bug.cgi?id=857324
Comment 61 Pavel Rosenboim 2012-09-20 11:23:55 EDT
I have same problem as Matthew reported, abrt directs me to this bug, but I'm not using VMware.