Bug 857324 - bz#854367 without vmware
bz#854367 without vmware
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 02:26 EDT by Pavel Alexeev
Modified: 2012-10-10 11:08 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-10 11:08:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to restrict warning case in tcp_rbuf_cleanup (556 bytes, patch)
2012-09-14 07:10 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Pavel Alexeev 2012-09-14 02:26:41 EDT
Abrt report continuously duplicate to https://bugzilla.redhat.com/show_bug.cgi?id=854367 crash, but by https://bugzilla.redhat.com/show_bug.cgi?id=854367#c58 I create this new bug.
Comment 1 Neil Horman 2012-09-14 07:06:33 EDT
I think its a bug in the test to issue the warning in that routine.  It looks like we want to warn if we're acking data in an skb that we haven't yet copied to a user space buffer.  However, if we've copied all the data in the socket (i.e. if copied_seq == TCP_SKB_CB(skb)->end_seq, then we should be fine. Can you try with the patch I'm about to attach?
Comment 2 Neil Horman 2012-09-14 07:10:45 EDT
Created attachment 612819 [details]
patch to restrict warning case in tcp_rbuf_cleanup
Comment 3 Christian Mehlis 2012-09-16 18:25:38 EDT
have this too, with my intel wifi:
https://bugzilla.kernel.org/show_bug.cgi?id=47511
Comment 4 Kevin R. Page 2012-09-17 11:38:34 EDT
Yes, also without vmware (also note abrt detects the now closed bug #854367 as the duplicate)
Comment 5 Markus Albe 2012-09-19 19:57:59 EDT
No VMware here either, and I'm getting this on a bluetooth adapter (saw most people got the error related to wi-fi, which in my case works flawlessly)

Error seems to be related to bad bluetoothd teardown at the moment of going into sleep mode. Everything runs fine at boot time, then I close the lid or send the system to sleep, and the bug happens when I wake up the OS.  Bluetooth stack comes up, but the bluetooth mouse no longer works (thought it communicates OK and can be detected).

Here's the error I see at sleep time:

Sep 19 20:12:15 eulogia bluetoothd[662]: Endpoint unregistered: sender=:1.37 path=/MediaEndpoint/HFPAG
Sep 19 20:12:15 eulogia dbus[772]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.37" (uid=1000 pid=1104 comm="/usr/bin/pulseaudio --start --
log-target=syslog ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.0" (uid=0 pid=662 co
mm="/usr/sbin/bluetoothd -n ")
Sep 19 20:12:15 eulogia dbus[772]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.37" (uid=1000 pid=1104 comm="/usr/bin/pulseaudio --start --
log-target=syslog ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.0" (uid=0 pid=662 co
mm="/usr/sbin/bluetoothd -n ")
Sep 19 20:12:15 eulogia dbus-daemon[772]: dbus[772]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.37" (uid=1000 pid=1104 comm="/usr/bin/pul
seaudio --start --log-target=syslog ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.0"
 (uid=0 pid=662 comm="/usr/sbin/bluetoothd -n ")
Sep 19 20:12:15 eulogia dbus-daemon[772]: dbus[772]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.37" (uid=1000 pid=1104 comm="/usr/bin/pul
seaudio --start --log-target=syslog ") interface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownMethod" requested_reply="0" destination=":1.0"
 (uid=0 pid=662 comm="/usr/sbin/bluetoothd -n ")
Sep 19 20:12:15 eulogia dbus-daemon[772]: dbus[772]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.18" (uid=1000 pid=941 comm="kded4 ") inte
rface="(unset)" member="(unset)" error name="org.freedesktop.DBus.Error.UnknownObject" requested_reply="0" destination=":1.0" (uid=0 pid=662 comm="/usr/sbin/bluetoothd 
-n ")
Sep 19 20:12:15 eulogia dbus[772]: [system] Rejected send message, 3 matched rules; type="error", sender=":1.18" (uid=1000 pid=941 comm="kded4 ") interface="(unset)" me
mber="(unset)" error name="org.freedesktop.DBus.Error.UnknownObject" requested_reply="0" destination=":1.0" (uid=0 pid=662 comm="/usr/sbin/bluetoothd -n ")


And when it resumes we get the attached trace.,  Can't guarantee is related, but seems quite likely based on the following string:
sysfs: cannot create duplicate filename '/class/bluetooth/hci0:11'

Sep 19 20:25:06 eulogia kernel: [  933.298762] ------------[ cut here ]------------
Sep 19 20:25:06 eulogia kernel: [  933.298776] WARNING: at fs/sysfs/dir.c:529 sysfs_add_one+0xca/0x100()
Sep 19 20:25:06 eulogia kernel: [  933.298779] Hardware name: 4286CTO
Sep 19 20:25:06 eulogia kernel: [  933.298781] sysfs: cannot create duplicate filename '/class/bluetooth/hci0:11'
Sep 19 20:25:06 eulogia kernel: [  933.298783] Modules linked in: hidp lockd sunrpc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_conexant arc4 coretemp kvm_intel kvm qcserial usb_wwan qmi_wwan cdc_wdm usbnet mii microcode i2c_i801 lpc_ich mfd_core iwlwifi mac80211 uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev cfg80211 media snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_timer btusb bluetooth e1000e mei thinkpad_acpi snd soundcore rfkill uinput xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
Sep 19 20:25:06 eulogia kernel: [  933.298861] Pid: 1923, comm: kworker/u:64 Not tainted 3.5.3-1.fc17.x86_64 #1
Sep 19 20:25:06 eulogia kernel: [  933.298863] Call Trace:
Sep 19 20:25:06 eulogia kernel: [  933.298875]  [<ffffffff810584bf>] warn_slowpath_common+0x7f/0xc0
Sep 19 20:25:06 eulogia kernel: [  933.298882]  [<ffffffff810585b6>] warn_slowpath_fmt+0x46/0x50
Sep 19 20:25:06 eulogia kernel: [  933.298887]  [<ffffffff811f8e5a>] sysfs_add_one+0xca/0x100
Sep 19 20:25:06 eulogia kernel: [  933.298892]  [<ffffffff811f9b95>] sysfs_do_create_link+0x125/0x200
Sep 19 20:25:06 eulogia kernel: [  933.298897]  [<ffffffff811f9c83>] sysfs_create_link+0x13/0x20
Sep 19 20:25:06 eulogia kernel: [  933.298904]  [<ffffffff813b27d4>] device_add+0x354/0x6e0
Sep 19 20:25:06 eulogia kernel: [  933.298910]  [<ffffffff813b0d41>] ? dev_set_name+0x41/0x50
Sep 19 20:25:06 eulogia kernel: [  933.298933]  [<ffffffffa0202984>] hci_conn_add_sysfs+0x54/0xc0 [bluetooth]
Sep 19 20:25:06 eulogia kernel: [  933.298951]  [<ffffffffa01f4890>] hci_conn_complete_evt.isra.46+0xe0/0x380 [bluetooth]
Sep 19 20:25:06 eulogia kernel: [  933.298967]  [<ffffffffa01f7418>] hci_event_packet+0xee8/0x2680 [bluetooth]
Sep 19 20:25:06 eulogia kernel: [  933.298983]  [<ffffffffa020189f>] ? hci_send_to_sock+0xff/0x1e0 [bluetooth]
Sep 19 20:25:06 eulogia kernel: [  933.298990]  [<ffffffff814f1017>] ? __kfree_skb+0x47/0xa0
Sep 19 20:25:06 eulogia kernel: [  933.298995]  [<ffffffff814f10a6>] ? kfree_skb+0x36/0xa0
Sep 19 20:25:06 eulogia kernel: [  933.299010]  [<ffffffffa020189f>] ? hci_send_to_sock+0xff/0x1e0 [bluetooth]
Sep 19 20:25:06 eulogia kernel: [  933.299025]  [<ffffffffa01e9b48>] hci_rx_work+0x1e8/0x430 [bluetooth]
Sep 19 20:25:06 eulogia kernel: [  933.299031]  [<ffffffff81074429>] process_one_work+0x129/0x400
Sep 19 20:25:06 eulogia kernel: [  933.299045]  [<ffffffffa01e9960>] ? hci_send_frame+0xc0/0xc0 [bluetooth]
Sep 19 20:25:06 eulogia kernel: [  933.299051]  [<ffffffff81075f66>] worker_thread+0x126/0x2e0
Sep 19 20:25:06 eulogia kernel: [  933.299055]  [<ffffffff81075e40>] ? manage_workers.isra.26+0x1f0/0x1f0
Sep 19 20:25:06 eulogia kernel: [  933.299061]  [<ffffffff8107b4e3>] kthread+0x93/0xa0
Sep 19 20:25:06 eulogia kernel: [  933.299069]  [<ffffffff81615de4>] kernel_thread_helper+0x4/0x10
Sep 19 20:25:06 eulogia kernel: [  933.299075]  [<ffffffff8107b450>] ? flush_kthread_worker+0x80/0x80
Sep 19 20:25:06 eulogia kernel: [  933.299080]  [<ffffffff81615de0>] ? gs_change+0x13/0x13
Sep 19 20:25:06 eulogia kernel: [  933.299083] ---[ end trace adeecb0fa2c51c24 ]---

hope it helps! let me know if I can provide anything else, more than glad to do so (unfortunately abrt marked as dupe
Comment 6 Fedora Update System 2012-10-02 21:36:50 EDT
kernel-3.5.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.5-1.fc17
Comment 7 Fedora Update System 2012-10-03 19:56:10 EDT
Package kernel-3.5.5-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.5.5-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15323/kernel-3.5.5-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-10-08 07:45:13 EDT
kernel-3.5.6-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.6-1.fc17
Comment 9 Josh Boyer 2012-10-10 11:08:42 EDT
(In reply to comment #8)
> kernel-3.5.6-1.fc17 has been submitted as an update for Fedora 17.
> https://admin.fedoraproject.org/updates/kernel-3.5.6-1.fc17

This is in the stable repo.  Not sure why bodhi didn't close the bug.

Note You need to log in before you can comment on or make changes to this bug.