Bug 856601

Summary: radvd process started twice
Product: [Fedora] Fedora Reporter: Gene Czarcinski <gczarcinski>
Component: libvirtAssignee: Laine Stump <laine>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 18CC: berrange, clalancette, itamar, jforbes, jyang, laine, libvirt-maint, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-09-23 10:20:42 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Gene Czarcinski 2012-09-12 07:55:07 EDT
Description of problem:
Two instances of the radvd process is started when a virtual IPv6 network is started.  The two processes have identical command line parameters.

Version-Release number of selected component (if applicable):
libvirt-0.10.0

How reproducible:
every time

Steps to Reproduce:
1.define a virtual network device with an IPv6 definition.
2.start the device
3.ps ax | grep radvd
  
Actual results:
two instances of radvd

Expected results:
only one instance

Additional info:
I am not sure if this is doing harm or not.  Note that if two IPv6 networks are started there are now 4 radvd processes.

I believe that this started with 0.10.0 but I first noticed it running 0.10.1.
Comment 1 Gene Czarcinski 2012-09-23 10:20:42 EDT
This is not a bug but must be a radvd feature.  When you start the radvd.service you get two copied=s too.