Bug 859196

Summary: [abrt]: WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7968 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
Product: [Fedora] Fedora Reporter: Neil <ledufff>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: alessio.locallo, david.hannequin, edo.bustos69, fedora, gansalmon, hugh, itamar, jch, jonathan, jones, kentobias, kernel-maint, m1cr0s3rf, madhu.chinakonda, mads, melanphos, mikko.tiihonen, mipas1, moerbius, ollmtm, pal666, phyrefyter, quinterosp.juan, req1348, sgruszka, sir.ade, winkarthikeyan
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-05 08:20:52 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Neil 2012-09-20 15:17:05 EDT
Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        BOOT_IMAGE=/vmlinuz-3.5.3-1.fc17.x86_64 root=/dev/mapper/vg_pilarpc-lv_root ro rd.md=0 rd.dm=0 SYSFONT=True rd.lvm.lv=vg_pilarpc/lv_swap rd.lvm.lv=vg_pilarpc/lv_root rd.luks=0 KEYTABLE=la-latin1 LANG=en_US.UTF-8 rhgb quiet
kernel:         3.5.3-1.fc17.x86_64

backtrace:
:WARNING: at drivers/net/wireless/brcm80211/brcmsmac/main.c:7968 brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]()
:Hardware name: HP Pavilion g4 Notebook PC      
:Modules linked in: fuse bnep bluetooth ip6t_REJECT nf_conntrack_ipv4 nf_conntrack_ipv6 nf_defrag_ipv6 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_idt uvcvideo coretemp arc4 brcmsmac kvm_intel videobuf2_vmalloc videobuf2_memops videobuf2_core cordic brcmutil mac80211 videodev media snd_hda_intel snd_hda_codec cfg80211 kvm i2c_i801 snd_hwdep snd_pcm snd_page_alloc snd_timer snd hp_wmi sparse_keymap rfkill soundcore mei lpc_ich r8169 mii microcode bcma mfd_core uinput crc32c_intel ghash_clmulni_intel wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
:Pid: 56, comm: kworker/u:5 Not tainted 3.5.3-1.fc17.x86_64 #1
:Call Trace:
: [<ffffffff810584bf>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff8105851a>] warn_slowpath_null+0x1a/0x20
: [<ffffffffa03ec129>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
: [<ffffffffa03de69b>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
: [<ffffffffa027682d>] ieee80211_scan_work+0x34d/0x5e0 [mac80211]
: [<ffffffff81074429>] process_one_work+0x129/0x400
: [<ffffffffa02764e0>] ? ieee80211_run_deferred_scan+0x80/0x80 [mac80211]
: [<ffffffff81075f66>] worker_thread+0x126/0x2e0
: [<ffffffff81075e40>] ? manage_workers.isra.26+0x1f0/0x1f0
: [<ffffffff8107b4e3>] kthread+0x93/0xa0
: [<ffffffff81615de4>] kernel_thread_helper+0x4/0x10
: [<ffffffff8107b450>] ? flush_kthread_worker+0x80/0x80
: [<ffffffff81615de0>] ? gs_change+0x13/0x13
Comment 1 Adam Stein 2012-09-20 17:25:54 EDT
Ran the following when it occurred:

> sudo umount /media/some_directory
> sudo mount -t vboxsf -o uid=33823,gid=550 Projects /media/some_directory
> sudo systemctl restart httpd.service

System is running under VirtualBox v4.2


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Ivan Vlk 2012-09-21 04:55:17 EDT
occured during the boot

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 dos 2012-09-21 05:02:09 EDT
i'll trying to unmount flesh-drive via nautilus

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 4 Duncan Starkey 2012-09-21 05:43:22 EDT
Occured 9 times in 7 minutes 
N.B. running 3 KVM VMs ( 2 x 64bit Fedora 17 & 1 x 32bit WinXP) and was trying to assign a 1-wire USB dingle to the WinXP instance


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Steevithak 2012-09-21 09:46:57 EDT
Crash warning box appeared on screen reporting that a "kernel problem" had occured. At the same time, the wireless connection indicator vanished at the top of screen and the network connection dropped. Wireless connection could not be reestablished. I had to connect via the ethernet port to get online. 

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 bibliotecaiutll 2012-09-21 12:33:27 EDT
I'm getting a problem with the kernel.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 7 Peter H. Jones 2012-09-21 14:13:04 EDT
Abort light appeared in panel. Had been running some simple ls and mv commands to clean up a disk.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 8 maxedwar 2012-09-21 17:55:55 EDT
starting the computer from the suspend mode

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 9 sentinelatsentinel 2012-09-21 21:12:15 EDT
Greeted with error message upon login

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 10 Malar Kannan 2012-09-22 07:03:01 EDT
inter wifi drivers are causing problems too often..

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 Thomas Canter 2012-09-22 09:32:13 EDT
I installed the gnome remote desktop viewer. then I opened and connected to another computer with VNC protocol. I had firefox open at the time and was also surfing the web

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Serge Pavlovsky 2012-09-22 09:45:06 EDT
may be powering off bluetooth keyboard

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 13 Michael Spasov 2012-09-22 13:49:51 EDT
#

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 miloud.malagouen 2012-09-22 21:03:01 EDT
sorting photos in a directory.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 Michal Nowak 2012-09-23 05:15:48 EDT
Returned from hibernation.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 16 Ed 2012-09-23 07:12:23 EDT
Attempting to insert an openoffice draw object to canvas

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Alfred Sabitzer 2012-09-23 07:41:43 EDT
Deinstallation of amd catalyst for fc17 and reboot.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 18 Steven Stern 2012-09-23 11:13:24 EDT
unmounting external USB drive
Comment 19 Steven Stern 2012-09-23 11:15:26 EDT
unmounted external USB drive; system locked up.  ABRT popped up on reboot.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 20 Michael 2012-09-23 13:02:26 EDT
i make yum updates - on a fresh install 

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 21 Michael 2012-09-23 13:03:32 EDT
a second crash by update via yum ?! 

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 22 emazv 2012-09-23 13:28:44 EDT
Could not run latest Vmware player 5. VM Is Windows 7 64.
VM works fine on same hw, but running ubuntu 12.04


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 23 uozabaci 2012-09-23 14:59:02 EDT
when i open a webpage with Opera...

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 24 Gilles J. Seguin 2012-09-23 18:11:44 EDT
occured when starting firefox

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 25 Zach Tuttle 2012-09-23 22:00:07 EDT
using virtualbox, with Mac OS X as the host, i mounted my iPhone into MAC OS X, and caused a kernel panic, but i can only reproduce the bug, when going from full screen mode in virtualbox to seamless mode.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 26 Michael 2012-09-24 03:18:43 EDT
i boot my laptop ?! 

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 27 Peter Robinson 2012-09-24 04:38:33 EDT
Resume from suspend. Not sure why it's reporting as tainted as it's a vanilla Fedora kernel on a Lenovo x220 with no extra modules installed

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 28 Torste Aikio 2012-09-24 07:48:56 EDT
Running as a guest OS for Virtualbox, with guest additions installed. Host OS is Windows 7 64bit.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 29 Andrey V. Henneberg 2012-09-24 08:05:06 EDT
The issue is appeared on system wake up from hibernation.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 30 Steevithak 2012-09-24 09:13:28 EDT
Lost wifi connection and ABRT error box appeared

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 31 Raj Upadhyaya 2012-09-24 10:21:52 EDT
Just rebooted for the first time with this kernel.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 32 Aydin Demirel 2012-09-24 11:09:20 EDT
I have been installing a package with yum and copying some files from the disk.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 33 Bill 2012-09-24 12:04:42 EDT
1) booted linux
2) changed cpupower to performance
3) mounted window share volumes
4) started thunderbird


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 34 Alexander Lipatov 2012-09-24 15:08:08 EDT
I am booted from hibernate and this error happens

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 35 Justin Phelps 2012-09-24 15:13:40 EDT
Attempting to enable my thinkpad volume buttons on this thinkpad x60 laptop. Fedora Forum post suggested echo enable,0xffffff > /proc/acpi/ibm/hotkey

Problem generated at that exact moment.


Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 36 lso 2012-09-25 01:09:32 EDT
Unknown.  First boot with newly installed kernel.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 37 Eric Harney 2012-09-25 10:36:10 EDT
Resuming from hibernation on ThinkPad T530.  No odd behavior noticed other than the BUG messages.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 38 Torbjørn Lindahl 2012-09-25 10:39:38 EDT
this happens regularly for no apparent reason

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 39 Sean Murphy 2012-09-25 11:50:58 EDT
Logged into the computer...

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 40 Georg Sauthoff 2012-09-25 12:05:09 EDT
I browsed a web-page while my Feedreader checked some feed-urls.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 41 Georg Sauthoff 2012-09-25 12:11:41 EDT
(In reply to comment #40)
> I browsed a web-page while my Feedreader checked some feed-urls.
> 
> Package: kernel
> OS Release: Fedora release 17 (Beefy Miracle)

I did that after a suspend-to-ram. System is a Thinkpad x220. Call Trace:

WARNING: at drivers/net/wireless/iwlwifi/iwl-trans.h:565 iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]()
Hardware name: 4296CTO
iwl_trans_wait_tx_queue_empty bad state = 0
Modules linked in: vfat fat usb_storage fuse sha256_generic dm_crypt lockd sunrpc rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_conexant btusb bluetooth arc4 coretemp kvm_intel kvm microcode cdc_ncm wacom usbnet mii cdc_acm cdc_wdm iwlwifi synaptics_usb snd_hda_intel mac80211 snd_hda_codec lpc_ich snd_hwdep i2c_i801 snd_pcm snd_page_alloc snd_timer thinkpad_acpi mfd_core e1000e cfg80211 mei snd soundcore rfkill uinput crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
Pid: 29826, comm: kworker/u:71 Not tainted 3.5.4-1.fc17.x86_64 #1
Call Trace:
 [<ffffffff8105867f>] warn_slowpath_common+0x7f/0xc0
 [<ffffffff81058776>] warn_slowpath_fmt+0x46/0x50
 [<ffffffffa0336c03>] iwlagn_mac_flush+0x1a3/0x1b0 [iwlwifi]
 [<ffffffffa02b6c0d>] ieee80211_mgd_probe_ap_send+0x12d/0x1f0 [mac80211]
 [<ffffffff8107432f>] ? cwq_activate_first_delayed+0x4f/0xc0
 [<ffffffffa02b72cf>] ieee80211_mgd_probe_ap.part.23+0x10f/0x130 [mac80211]
 [<ffffffffa02b746e>] ieee80211_sta_monitor_work+0x2e/0x30 [mac80211]
 [<ffffffff810745e9>] process_one_work+0x129/0x400
 [<ffffffffa02b7440>] ? ieee80211_beacon_connection_loss_work+0x150/0x150 [mac80211]
 [<ffffffff81076126>] worker_thread+0x126/0x2e0
 [<ffffffff81076000>] ? manage_workers.isra.26+0x1f0/0x1f0
 [<ffffffff8107b6a3>] kthread+0x93/0xa0
 [<ffffffff81616124>] kernel_thread_helper+0x4/0x10
 [<ffffffff8107b610>] ? flush_kthread_worker+0x80/0x80
 [<ffffffff81616120>] ? gs_change+0x13/0x13
Comment 42 JW Hall 2012-09-25 17:21:44 EDT
I was booting into Windows and the computer restarted. I then tried to get into Fedora, but after the initial boot splash (OS selection), it hung on a blank screen and would go no further. I rebooted into Fedora, but strace didn't seem to reveal anything, at least not that I could tell.

[root@hp-dv2000 buzz]# strace -s 1024 -o log /usr/bin/hddtemp -n -q /dev/sda
31
[root@hp-dv2000 buzz]# 


Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 43 A S Alam 2012-09-25 22:55:14 EDT
after resume from suspend, it happened

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 44 firdaus4us 2012-09-26 01:41:22 EDT
I don't just know exactly what went wrong

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 45 Steven Bakker 2012-09-26 04:17:19 EDT
Using the network (WiFi) in combination with a VPN over IPsec/L2TP. Lost WiFi connection.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 46 Sebastian Sajaroff 2012-09-26 04:24:35 EDT
Always happens right after turning on the computer and logging to my X session.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 47 Martin Bengtsson 2012-09-26 05:09:25 EDT
Happens now and then when connected to wifi. Somehow the wifi recover fine, but strangely the sound seems to drop out.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 48 Alessio Arceri 2012-09-26 08:51:04 EDT
after start, i switch on my wifi interface from network manager and then the system has been frezeed

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 49 Brent R Brian 2012-09-26 09:54:20 EDT
was there after boot

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 50 Dave P 2012-09-26 12:17:38 EDT
Chrome browser. Followed a link to a PDF document. Saved it to disk.
Using document reader, had read a PDF document. Minimised it. Used the Chrome browser page (same page as first link) back to google.... crashed. 


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 51 G De Moro 2012-09-26 16:10:13 EDT
I was using firefox...

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 52 pasqual milvaques 2012-09-26 16:55:07 EDT
starting the system with an hdmi tv plugged

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 53 zbechir 2012-09-27 04:35:47 EDT
Opening VmWare Player!!!!

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 54 Nikolai Maziashvili 2012-09-27 06:08:54 EDT
Tryed to run virtual machine in VMware player. This doesn't happend with previous verisons of kernel, 3.3.4-5 for instance. 

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 55 GIuseppe A. 2012-09-27 12:31:33 EDT
While working on a Windows Share, Connection lost and Authentication required again. After deactivating WiFi and reactivating everything was OK again. 

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 56 Jens Knutson 2012-09-27 15:21:59 EDT
I have no actual idea why this happened, but that's not going to stop me from blaming Broadcom.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 57 Jason Bartz 2012-09-27 19:01:52 EDT
processed upgrades

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 58 avkaplmkt 2012-09-27 19:19:26 EDT
I was opening a folder in the XFCE file manager.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 59 Justin 2012-09-27 21:24:05 EDT
Brand new install using the Network Install CD. No idea what's wrong, or why it matters.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 60 Rohit Sarpotdar 2012-09-28 04:36:04 EDT
With this chipset and LED monitor configuration, if I just keep machine ON, the graphic driver crashes.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 61 vafr 2012-09-28 04:42:34 EDT
starting vmx virtualmachine from vmplayer

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 62 Joshua Kordani 2012-09-28 09:06:25 EDT
hibernate gets hung, force restart.

Package: kernel
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 63 Andrei 2012-09-28 12:26:38 EDT
I just installed vmware player and was about to install voyager linux on it. I started to edit the virtual machine proprieties , to add more ram and a second cpu to the virtual appliance when it all when black with an error screen.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 64 y-miles 2012-09-28 14:26:54 EDT
I was connected to my home wireless network, and maybe the signal was weak (the router is about 4 meters away from the laptop) and I couldn't get any connection. So I rebooted the router and re-connected to the network and it went fine, but this error report came all of the sudden. So apart from the unexpected crash the re-connection went smooth.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 65 Peter H. Jones 2012-09-28 17:04:30 EDT
Found this bug after terminal froze in all its windows. Was able to start lxterminal, but did not see terminal when I tried a "ps -lu <user>"

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 66 Steevithak 2012-09-29 10:15:31 EDT
ABRT crash box appeared when I opened laptop. WiFi was not working. Had to use an ethernet cable to get online

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 67 Tobias Mueller 2012-09-29 11:02:44 EDT
I watched Tears of Steel while browing some local pictures with eog.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 68 ettoretommasomarchetti 2012-09-30 02:32:30 EDT
I installed Fedora 17 KDE from a live CD
The first couple times it booted regularly
After that, the normal boot failed regularly and got stuck with some errors
One way to boot the system is to boot it in recovery mode, then do 'exit'
This does not work all the time and in any case during boot I get the error message above "BUG:soft lockup ...."
also, at the boot start I get an error msg that a file font True is not found

Note that 
this is a laptop ACER Aspire 8930G
1. Opensuse 11.4, on another partition, boots without problems - so does Win 7
2. Opensuse 12.2 boots with several problems
3. I tried several other recent distributions (Ubuntu, Minty, Knoppix, Mageia), and they all fail to boot, 


Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 69 Steve 2012-09-30 03:04:39 EDT
Just rebooted...

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 70 Mikko Tiihonen 2012-09-30 08:55:37 EDT
After suspend the mounting of SD card no longer worked.

0d:00.0 System peripheral: Ricoh Co Ltd PCIe SDXC/MMC Host Controller (rev 08)
0d:00.0 0880: 1180:e823 (rev 08)

After reboot the SD card could be mounted normally.


Package: kernel
OS Release: Fedora release 18 (Spherical Cow)
Comment 71 Mads Kiilerich 2012-10-01 09:58:13 EDT
It seems like completely unrelated crashes are reborted as duplicates by abrt - removing abrt_hash:da39a3ee5e6b4b0d3255bfef95601890afd80709 to get another report.
Comment 72 Mads Kiilerich 2012-10-01 10:01:38 EDT
-> Bug 861985
Comment 73 Stanislaw Gruszka 2012-10-05 08:20:52 EDT

*** This bug has been marked as a duplicate of bug 861022 ***