Bug 860525

Summary: dracut-pre-pivot[272]: mount: wrong fs type, bad option, bad superblock on /var/lib/nfs/rpc_pipefs,
Product: [Fedora] Fedora Reporter: xset1980
Component: dracutAssignee: dracut-maint
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: awilliam, dcharlespyle, dracut-maint, harald, jonathan, robatino, tflink, tomek, xset1980
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-20 00:37:13 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752661    
Attachments:
Description Flags
dracut-pre-pivot none

Description xset1980 2012-09-26 00:31:02 EDT
Created attachment 617382 [details]
dracut-pre-pivot

Description of problem:

After initrd load and start the systemd load dracut show:

dracut-pre-pivot[272]: mount: wrong fs type, bad option, bad superblock on /var/lib/nfs/rpc_pipefs,
dracut-pre-pivot[272]: missing codepage or helper program, or other error
dracut-pre-pivot[272]: In some cases useful info is found in syslog - try
dracut-pre-pivot[272]: dmesg | tail or so


Version-Release number of selected component (if applicable):

Fedora 18 Alpha KDE spin up to date
dracut-023-39.git20120910.fc18.i686
systemd-188-3-fc18.i686
kernel-3.6.0-0.rc6.git0.2.fc18.i686
grub2-2.00-5.fc18.i686
util-linux-2.22-1.fc18.i686

How reproducible:
Always on every boot.

Steps to Reproduce:
1.Install F18 Alpha KDE spin
2.yum update -y
3.reboot
  
Actual results:


Expected results:


Additional info:

attach screenshot
Comment 1 D. Charles Pyle 2012-11-11 02:57:07 EST
I get these same and similar errors with complete install of Fedora 18-Alpha that is not a spin. Even with the latest updates from updates-testing I still get the errors.
Comment 2 D. Charles Pyle 2012-11-11 03:10:53 EST
Here are the versions of the above components listed in the initial post that I am running:

$ rpm -qa dracut systemd kernel grub2 util-linux
grub2-2.00-12.fc18.x86_64
util-linux-2.22.1-2.1.fc18.x86_64
dracut-024-5.git20121019.fc18.x86_64
kernel-3.6.5-2.fc18.x86_64
kernel-3.6.3-3.fc18.x86_64
systemd-195-6.fc18.x86_64
kernel-3.6.6-3.fc18.x86_64
Comment 3 D. Charles Pyle 2012-11-11 03:32:02 EST
The part of the boot screen that I see gives an added error to the above, as follows, in the exact order in which it displays on my screen on every boot.

dracut-cmdline[66]: /etc/locale.conf: line 1: locale.LANG=en_US.UTF-8: command n
[  OK  ] Started Show Plymouth Boot Screen
[  OK  ] Reached target Basic System
dracut-pre-pivot[331]: mount: wrong fs type, bad option, bad superblock on /var/lib/nfs/rpc_pipefs,
dracut-pre-pivot[331]: missing codepage or helper program, or other error
dracut-pre-pivot[331]: In some cases useful info is found in syslog - try
dracut-pre-pivot[331]: dmesg | tail or so

I noticed that there is no file locale.conf in /etc also.
Comment 4 D. Charles Pyle 2012-11-11 03:35:43 EST
Never mind the line in my above comment about a missing locale.conf file. The latest updates I just did put one there. However, the other errors remain, as does the very first line I gave in comment 3.

I am not sure what is causing this.
Comment 5 D. Charles Pyle 2012-11-11 04:39:59 EST
The error:

dracut-cmdline[66]: /etc/locale.conf: line 1: locale.LANG=en_US.UTF-8: command n

No longer appears after I removed the "LANG=..." variable from the kernel line in /etc/default/grub and rebuilt the grub2 menu without it, after reading discussion here:

https://bugzilla.redhat.com/show_bug.cgi?id=870632

The dracut-pre-pivot error still occurs as above in comment 3.
Comment 6 D. Charles Pyle 2012-11-11 04:41:03 EST
The error:

dracut-cmdline[66]: /etc/locale.conf: line 1: locale.LANG=en_US.UTF-8: command n

No longer appears after I removed the "LANG=..." variable from the kernel line in /etc/default/grub and rebuilt the grub2 menu without it, after reading discussion here:

https://bugzilla.redhat.com/show_bug.cgi?id=870632

The dracut-pre-pivot error still occurs as above in comment 3.
Comment 7 D. Charles Pyle 2012-11-11 04:41:33 EST
The error:

dracut-cmdline[66]: /etc/locale.conf: line 1: locale.LANG=en_US.UTF-8: command n

No longer appears after I removed the "LANG=..." variable from the kernel line in /etc/default/grub and rebuilt the grub2 menu without it, after reading discussion here:

https://bugzilla.redhat.com/show_bug.cgi?id=870632

The dracut-pre-pivot error still occurs as above in comment 3.
Comment 8 D. Charles Pyle 2012-11-29 22:02:20 EST
The error still is occurring in Fedora 18-Beta.
Comment 9 xset1980 2012-11-29 23:32:18 EST
(In reply to comment #8)
> The error still is occurring in Fedora 18-Beta.

Confirm that Charles, still on F18 Beta rc1.
Comment 10 Tim Flink 2012-11-30 13:16:57 EST
I'm not sure that I understand the effects of this bug or how it qualifies as a release blocker.

My current understanding is that this is some extra error messages in kmsg on startup and might be related to #870632.

Is this causing errors in the boot process or preventing boot post-install?
Comment 11 Harald Hoyer 2012-12-03 07:25:17 EST
somehow current kernels do not like:

     mount --move /var/lib/nfs/rpc_pipefs $NEWROOT/$rpcpipefspath

but

        mount --bind /var/lib/nfs/rpc_pipefs $NEWROOT/$rpcpipefspath
        umount /var/lib/nfs/rpc_pipefs

seems to work fine.

This would prevent possible NFS install errors.
Comment 12 Adam Williamson 2012-12-03 13:45:00 EST
Discussed at 2012-12-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-12-03/f18final-blocker-review-1.2.2012-12-03-17.25.log.txt . There was much confusion about the extent and impact of this bug, we really don't understand it at all. We postponed decision on its status until the nature of the bug is clearer.
Comment 13 D. Charles Pyle 2012-12-04 15:58:40 EST
What in dracut is causing the above error? Is it some configuration file somewhere? It slows down booting slightly but so far as I am aware it isn't really breaking anything else that I use at the moment.
Comment 14 Harald Hoyer 2012-12-05 07:52:11 EST
(In reply to comment #13)
> What in dracut is causing the above error? Is it some configuration file
> somewhere? It slows down booting slightly but so far as I am aware it isn't
> really breaking anything else that I use at the moment.

see comment #11
Comment 15 D. Charles Pyle 2012-12-05 12:02:38 EST
OK, but in what file is this offending text in comment 11 to be found?
Comment 16 Tim Flink 2012-12-07 11:58:07 EST
I still don't quite understand the extent and impact of this bug. Has it been a problem for NFS installs? If so, how common is it? How fatal is it to the install? Are there workarounds? Could it be fixed with an update?
Comment 17 D. Charles Pyle 2012-12-07 14:23:06 EST
I do not use NFS, so far as I am aware. I do not even understand why I see such an error or what it might be doing on my system. I just want to know where the offending line of code occurs in what configuration file.

I ran multiple searches on the content of various files and groups of files and still have turned up nothing. I do not even know what causes the error, or what it does or how it affects the system other than the slight delay in booting that it causes.

But, if anyone knows where or in what configuration file(s) this is occurring so I can at least employ a workaround in the interim, I would appreciate it very much.
Comment 18 Harald Hoyer 2012-12-14 04:34:39 EST
(In reply to comment #17)
> I do not use NFS, so far as I am aware. I do not even understand why I see
> such an error or what it might be doing on my system. I just want to know
> where the offending line of code occurs in what configuration file.
> 
> I ran multiple searches on the content of various files and groups of files
> and still have turned up nothing. I do not even know what causes the error,
> or what it does or how it affects the system other than the slight delay in
> booting that it causes.
> 
> But, if anyone knows where or in what configuration file(s) this is
> occurring so I can at least employ a workaround in the interim, I would
> appreciate it very much.

If you don't have root or /usr on network, just:

# yum remove dracut-network
# dracut -f

And the error should be gone.
Comment 19 Fedora Update System 2012-12-18 10:57:16 EST
dracut-024-15.git20121218.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dracut-024-15.git20121218.fc18
Comment 20 Fedora Update System 2012-12-18 16:27:37 EST
Package dracut-024-15.git20121218.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-024-15.git20121218.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20580/dracut-024-15.git20121218.fc18
then log in and leave karma (feedback).
Comment 21 Adam Williamson 2012-12-19 13:12:27 EST
Discussed at 2012-12-19 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-19/f18final-blocker-review-6.2012-12-19-17.02.log.txt . Agreed we're still not clear on the actual impact of this - whether it was breaking anything, or just cosmetic - so we still can't make a decision. Harald has not answered that question. But the fix is likely to come in anyway, with the other dracut blocker, so this might go away soon.
Comment 22 D. Charles Pyle 2012-12-19 17:02:48 EST
The update stopped the error in its tracks. I have not seen the error since applying the update linked above in comment 20.
Comment 23 Fedora Update System 2012-12-20 00:37:16 EST
dracut-024-15.git20121218.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.