Bug 861828

Summary: On reboot "/var/run/openvswitch/db.sock connection failed" errors lasted for ~5 minutes as openvswitch.init was run ~5 minutes later than "ovs-vsctl add-br".
Product: [Fedora] Fedora Reporter: Jean-Tsung Hsiao <jhsiao>
Component: openvswitchAssignee: Thomas Graf <tgraf>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 17CC: chrisw, edube, jhsiao, markmc, mzywusko, rkhan, tgraf
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-09 11:06:41 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Jean-Tsung Hsiao 2012-09-30 21:05:31 EDT
Description of problem:
 
Saw the following repeated errors for about five minutes. The messages log indicated that "ovs-vsctl" was run about five minutes ahead of openvswitch.init.

network[798]: 2012-10-01T00:42:38Z|00048|stream_unix|ERR|/var/run/openvswitch/db.sock: connection failed (No such file or directory)
network[798]: 2012-10-01T00:42:38Z|00049|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)
network[798]: 2012-10-01T00:42:46Z|00050|stream_unix|ERR|/var/run/openvswitch/db.sock: connection failed (No such file or directory)
network[798]: 2012-10-01T00:42:46Z|00051|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)
network[798]: 2012-10-01T00:42:54Z|00052|stream_unix|ERR|/var/run/openvswitch/db.sock: connection failed (No such file or directory)
network[798]: 2012-10-01T00:42:54Z|00053|reconnect|WARN|unix:/var/run/openvswitch/db.sock: connection attempt failed (No such file or directory)

Version-Release number of selected component (if applicable):
openvswitch: 1.17.1

How reproducible: very reproducible


Steps to Reproduce:
1.Install openvswitch.
2.Configured an openvswitch.
3.Ran "systemctl enable openvswitch.service".
4. Reboot system
  
Actual results:
openvswitch.init ran ~5 minutes later than "ovs-vsctl add-br". This resulted in the connection failure errors lasting for ~5 minutes.

Expected results:

openvswitch.init should run before "ovs-vsctl add-br". This will eliminate the connetion failure errors.
Additional info:
Comment 1 Thomas Graf 2012-10-09 11:06:41 EDT

*** This bug has been marked as a duplicate of bug 858722 ***