Bug 858722 - ifup hangs if openvswitch service is not running
ifup hangs if openvswitch service is not running
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openvswitch (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Thomas Graf
Fedora Extras Quality Assurance
:
: 861828 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 09:53 EDT by Thomas Graf
Modified: 2014-06-18 04:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:33:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Graf 2012-09-19 09:53:43 EDT
Description of problem:
If an Open vSwitch bridge is brought up that has been configured in /etc/sysconfig/network-scripts/ it hangs indefinitely trying to connect o the daemon if the openvswitch service is not running.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Configure OVS bridge
2. Stop openvswitch service
3. ifup OVS bridge
  
Actual results:

Hang

Expected results:

Timeout

Additional info:
Comment 2 Thomas Graf 2012-10-09 11:06:41 EDT
*** Bug 861828 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-10-09 11:45:52 EDT
openvswitch-1.7.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openvswitch-1.7.1-2.fc18
Comment 4 Fedora Update System 2012-10-09 13:19:02 EDT
Package openvswitch-1.7.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openvswitch-1.7.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15694/openvswitch-1.7.1-2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-10-10 06:38:56 EDT
openvswitch-1.4.2-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openvswitch-1.4.2-3.fc17
Comment 6 Fedora Update System 2012-10-16 04:08:02 EDT
openvswitch-1.7.1-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openvswitch-1.7.1-3.fc18
Comment 7 Fedora Update System 2012-12-20 10:33:02 EST
openvswitch-1.7.1-2.fc18 has been pushed to the Fedora 18 obsolete repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.