Bug 862238

Summary: impossible to adjust user settings after installation has finished
Product: [Fedora] Fedora Reporter: Kamil Páral <kparal>
Component: anacondaAssignee: Martin Sivák <msivak>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: g.kaviyarasu, jonathan, robatino, stephent98, vanmeeuwen+fedora
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: anaconda-18.15-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-10-23 10:20:19 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752661    

Description Kamil Páral 2012-10-02 07:56:34 EDT
Description of problem:
Anaconda now presents a new "User Settings" form displayed during the installation. Currently you can set root password there (maybe displayed just for minimal installations, I don't know). The problem is that you can use that only _during_ installation, but not after the installation has finished.

This was my use case:
1. hit Begin to start the installation
2. go for coffee
3. return back, see the installation has finished
4. try to use "user settings" form to set root password -> impossible, the option is disabled

Version-Release number of selected component (if applicable):
anaconda 18.8

How reproducible:
seems always
Comment 1 Kamil Páral 2012-10-02 07:58:33 EDT
Proposing as Final blocker. I don't know which options will end up on User Settings screen (currently just root password), but the user simply can't use them if he/she is not fast enough and do it during the installation. Which is often not the case, see the coffee break example.
Comment 2 Martin Sivák 2012-10-17 08:09:35 EDT
This is simply not a bug. "Start installation" is not a fire and forget button. You can immediatelly start configuring stuff and then go for coffee break.

Moreover, anaconda will wait if any mandatory configuration was not finished. The rest you can finish in firstboot.

To prevent this, we marked root password spoke as mandatory again for the F18. But we count on the new firstboot to make this bug totally void for F19.
Comment 3 Kamil Páral 2012-10-17 08:39:57 EDT
> Moreover, anaconda will wait if any mandatory configuration was not finished.

This is what I asked for. So, FIXED instead of NOTABUG.

Care to share the anaconda version in which this was fixed?
Comment 4 Martin Sivák 2012-10-17 08:46:11 EDT
*** Bug 863744 has been marked as a duplicate of this bug. ***
Comment 5 Martin Sivák 2012-10-17 08:47:56 EDT
>> Moreover, anaconda will wait if any mandatory configuration was not finished.

> This is what I asked for. So, FIXED instead of NOTABUG.
> Care to share the anaconda version in which this was fixed?

This behaviour has been there since the progress hub functionality was introduced.

The only change is making the Root password mandatory again. Without it anaconda saw no unfinished mandatory spoke and continued with writing the configuration.
Comment 6 Kamil Páral 2012-10-18 04:31:49 EDT
Perfect, verified for anaconda 18.16, Beta TC4.
Comment 7 Kamil Páral 2012-10-23 10:20:19 EDT
Verified and stable, closing.