Bug 863744 - cannot set root password from configuration hub after install is complete
cannot set root password from configuration hub after install is complete
Status: CLOSED DUPLICATE of bug 862238
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Sivák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-07 00:46 EDT by Steve Tyler
Modified: 2012-10-17 08:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-17 08:04:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screenshot showing configuration hub after install is complete (45.19 KB, image/png)
2012-10-07 00:46 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-10-07 00:46:59 EDT
Created attachment 622903 [details]
screenshot showing configuration hub after install is complete

Description of problem:
If a root password is not set before the install completes, it cannot be set at all. After the install is complete, clicking on "Root Password" has no effect.

The pointer changes from an arrow to a finger when it is moved over the root password spoke.

Version-Release number of selected component (if applicable):
anaconda 18.13
Fedora-18-Beta-TC2-x86_64-Live-Desktop.iso

How reproducible:
Always.

Steps to Reproduce:
1. Install from a Live CD.
2. Do not set a root password.
3. Wait for the install to complete, but do not click the reboot button.
  
Actual results:
Cannot set root password.

Expected results:
Can set root password.

Additional info:
Comment 1 Steve Tyler 2012-10-07 01:05:41 EDT
Additional info:
The user account created during firstboot was automatically given administrator privileges.
Comment 2 Martin Sivák 2012-10-08 07:40:48 EDT
This is not possible, you can only set root password while packages are copied over. The next step writes configuration to disk and obviously no changes after that will be reflected in the system after reboot.

We are changing anaconda to require root password again, so it will wait for you to set it before dumping it to harddisk.

If you install LXDE, firstboot should fire up on the first boot and let you create admin user.

The hand cursor over insensitive spoke is probably a small UI bug.
Comment 3 Steve Tyler 2012-10-08 12:53:01 EDT
If a root password is going to be required during installation, this is probably moot ...

My problem description was unclear:
"If a root password is not set before the install completes, it cannot be set at all [during installation]."

However, the administrative user created during firstboot can set the root password from a terminal or console after installation with:

$ sudo su
# passwd

Tested with an F18 Gnome desktop install in a VM.
Comment 4 Daniel Belton 2012-10-08 18:05:06 EDT
I had an issue with TC2 where no root user password was set in anaconda, then firstboot didn't run at all, so no admin user was set up, and I was left without a way to get into the system at all.
Comment 5 Steve Tyler 2012-10-08 18:35:29 EDT
(In reply to comment #4)
> I had an issue with TC2 where no root user password was set in anaconda,
> then firstboot didn't run at all, so no admin user was set up, and I was
> left without a way to get into the system at all.

You might be able to recover by booting in rescue mode[1] from an installer disc, doing a "chroot /mnt/sysimage", and running "passwd" from there.

Tested with Fedora-18-Beta-TC2-x86_64-netinst.iso.

[1] Under "Troubleshooting" in the menu.
Comment 6 Martin Sivák 2012-10-17 08:04:28 EDT
We changed anaconda to require the root password to be set.
Comment 7 Steve Tyler 2012-10-17 08:39:04 EDT
CLOSED/ERRATA then ...
Comment 8 Martin Sivák 2012-10-17 08:46:11 EDT
Well anyways DUP anyways..

*** This bug has been marked as a duplicate of bug 862238 ***

Note You need to log in before you can comment on or make changes to this bug.