Bug 869264

Summary: Cannot specify number of RAID members in GUI
Product: [Fedora] Fedora Reporter: Jan Stodola <jstodola>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: medium    
Version: 18CC: g.kaviyarasu, jonathan, mbanas, robatino, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-11-05 12:45:17 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752661    
Attachments:
Description Flags
anaconda.log
none
anaconda.program.log
none
anaconda.storage.log
none
syslog none

Description Jan Stodola 2012-10-23 08:38:19 EDT
Description of problem:
When creating RAID partitioning, there is no option to specify how many RAID members should be created. Anaconda creates one RAID member on each drive. If there are 8 drives in the machine, there will be 8 RAID members.

Version-Release number of selected component (if applicable):
anaconda-18.19-1.fc18

How reproducible:
always

Steps to Reproduce:
1. start graphical installation on a system with 3 or more drives
2. proceed to custom partitioning, select all available drives
3. remove all existing partitions
4. create / mount point, customize it and select Device Type: RAID
5. check "Redundancy (mirror)", uncheck "Optimized performance (stripe)"
6. create /boot and swap partitions and finish the install
  
Actual results:
RAID members are created on all drives

Expected results:
anaconda allows to specify the number of RAID members
Comment 1 Jan Stodola 2012-10-23 08:41:35 EDT
Created attachment 632067 [details]
anaconda.log
Comment 2 Jan Stodola 2012-10-23 08:41:38 EDT
Created attachment 632068 [details]
anaconda.program.log
Comment 3 Jan Stodola 2012-10-23 08:41:41 EDT
Created attachment 632069 [details]
anaconda.storage.log
Comment 4 Jan Stodola 2012-10-23 08:41:45 EDT
Created attachment 632070 [details]
syslog
Comment 5 Martin Banas 2012-10-25 07:14:23 EDT
Since there's no way in UI to specify how many disks to use for RAID device, and this is basic functionality, I would like to propose it as Beta blocker.

11.  The installer must be able to create and install to software, hardware or BIOS RAID-0, RAID-1 or RAID-5 partitions for anything except /boot
Comment 6 Chris Lumens 2012-10-25 10:50:42 EDT
I disagree.  The various checkboxes in the customize section for a mountpoint defines how you can create the various RAID levels, so those are all still creatable.
Comment 7 Martin Banas 2012-10-25 11:16:24 EDT
Yes, they are creatable, but not in a way user wants them... I would rather define where I want it (or at least how much) before anaconda spread it on all available drives, as it's written in description of the bug...
Comment 8 Chris Lumens 2012-10-30 11:02:48 EDT
Not in a way *the* user wants them, or not in the way *you* want them?  We are trying to do a much different UI design here for partitioning layout, and the existing checkbox design is what we talked about extensively in public.

Going back to the original report here, the reason it put a RAID member on every disk is because you picked every disk to be a part of the installation.  If you hadn't done that, we should have only put a RAID member on the disks you specify.  I don't see that there is anything to fix in this bug, and suggest it be closed following the blocker meeting.
Comment 9 Jan Stodola 2012-10-30 13:12:22 EDT
Chris, imagine that someone would like to create following partitioning on a system with 3 drives:

/boot on sda1
swap on sda2
/ on RAID1 device, members are sdb1 and sdc1

Is it possible to do it without kickstart?
Comment 10 David Lehman 2012-10-30 16:10:07 EDT
(In reply to comment #9)
> Chris, imagine that someone would like to create following partitioning on a
> system with 3 drives:
> 
> /boot on sda1
> swap on sda2
> / on RAID1 device, members are sdb1 and sdc1
> 
> Is it possible to do it without kickstart?

There is a patch coming soon to f18 to provide a way to select which disks are candidates for a given device. Once this is in place, what you describe above will be as easy to achieve in the GUI as it is in kickstart.

To be clear, what we are going to provide is a way to say "make this device use these disks". For an md array, it means "make the array use all of these disks", while for a partition it means "the partition can end up on any of these disks". In the example above you would select sda and sdb for the md array. Similarly, you could constrain /boot and swap to sda. You can't control the partition numbers, but it will end up as you describe if these are the only devices on the disks.
Comment 11 David Lehman 2012-10-30 16:19:45 EDT
See bug 870569
Comment 12 David Lehman 2012-11-05 12:45:17 EST

*** This bug has been marked as a duplicate of bug 870569 ***