Bug 870569 - Custom partitioning should allow the user to specify which disk a partition should wind up on
Custom partitioning should allow the user to specify which disk a partition s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedNTH
:
: 869264 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-26 17:52 EDT by Adam Williamson
Modified: 2013-03-12 10:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:38:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-10-26 17:52:45 EDT
The partition pokemons who are going to be using the custom partitioning screen are going to want to be able to specify which disk a given partition ends up on. This has been 'known' for a while but there doesn't appear to be a bug report for it, so here's one.

Proposing as NTH for Beta because it makes sense to have this thing available in Beta for testing; it wouldn't be great to put it in between Beta and Final so it only gets tested during Final validation if at all. It shouldn't affect our more sensitive testing paths as it's custom partitioning only.
Comment 1 David Lehman 2012-10-29 09:51:21 EDT
I am testing a patch for this now.
Comment 2 Adam Williamson 2012-10-31 14:12:49 EDT
Discussed at 2012-10-31 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-31/f18beta-blocker-review-6.2012-10-31-16.00.log.txt . Accepted as NTH on the basis that this is commonly-requested functionality and it is an obvious benefit to have it included and testable in the Beta.
Comment 3 Fedora Update System 2012-11-02 00:04:08 EDT
anaconda-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.23-1.fc18
Comment 4 Fedora Update System 2012-11-02 14:38:33 EDT
Package anaconda-18.23-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.23-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17509/anaconda-18.23-1.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2012-11-02 21:03:30 EDT
anaconda-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.24-1.fc18
Comment 6 Fedora Update System 2012-11-03 15:28:06 EDT
Package anaconda-18.24-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.24-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17543/anaconda-18.24-1.fc18
then log in and leave karma (feedback).
Comment 7 David Lehman 2012-11-05 12:45:17 EST
*** Bug 869264 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2012-11-05 20:38:41 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 9 Fedora Update System 2012-11-06 21:10:38 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 10 Adam Williamson 2012-11-08 04:38:00 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.