Bug 869584

Summary: ibus menu in kde panel does not work, disappears immediately
Product: [Fedora] Fedora Reporter: Mike FABIAN <mfabian>
Component: ibusAssignee: fujiwara <tfujiwar>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: aalam, awilliam, ccecchi, i18n-bugs, jgrulich, jreznik, kevin, kparal, ltinkl, mbriza, mclasen, mfabian, pnemade, rdieter, rnovacek, robatino, shawn.p.huang, tagoh, tflink, tfujiwar, than
Target Milestone: ---Keywords: i18n, Reopened
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-17 03:42:24 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752661    

Description Mike FABIAN 2012-10-24 06:35:51 EDT
I tested this on Fedora-18-Beta-TC6-x86_64-netinst.iso

- default install of Fedora-18-Beta-TC6-x86_64-netinst.iso in Japanese in qemu
- log in into gnome shell
- Install KDE with:
  sudo yum install "@KDE Plasma Workspaces"
- quit gnome session (e.g. execute "gnome-session-quit")
- in gdm select KDE and log in again
- Look at the panel, there is the ibus icon showing a keyboard and a globe
- click on the ibus icon
  
Actual results:

Usually nothing happens. When one tries often the ibus menu pops up
sometimes but disappears again immediately. The user has no chance
to select anything in the ibus menu.

Sometimes, if I click on the ibus icon and keep the mouse pressed, the
ibus menu pops up and stays as long as I neither release the mouse
button nor move the mouse. But even then it is not possible to select
anything in the menu because trying to move the mouse from the ibus
item to the menu makes the menu disappear again.

Other icons in the panel, for example the icon showing scissors
(klipper) pop up menus just fine and these menus are usable.

Only the ibus icon seems to have this problem.

Expected results:

ibus menu should pop up and one should be able to select something there.
Comment 1 Mike FABIAN 2012-10-24 06:41:10 EDT

*** This bug has been marked as a duplicate of bug 867484 ***
Comment 2 A S Alam 2012-12-03 07:38:56 EST
as Fedora 18 is yet not release, so keep this bug open. 

ibus is not working at all in KDE as far comment https://bugzilla.redhat.com/show_bug.cgi?id=867484#c1

this need to move
Comment 3 Kevin Kofler 2012-12-03 13:12:10 EST
I don't see why this would be a kde-workspace issue. The faulty applet is a gtk3 applet, all the KDE ones are working.
Comment 4 Akira TAGOH 2012-12-06 00:30:49 EST
Hmm, I'm not sure if all of gtk3 applets is affected. at least the status icon from empathy works on KDE.
Comment 5 Jens Petersen 2012-12-06 05:19:27 EST
Easily reproduced in F18 Beta.

Proposing as an F18 Blocker, based on:

http://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria#Final_Release_Requirements

  18. All elements of the default panel (or equivalent) configuration in all  release-blocking desktops must function correctly in common use

ibus applet appears by default in DVD install of KDE for Asian languages.
Comment 6 Jaroslav Reznik 2012-12-06 09:24:30 EST
(In reply to comment #5)
> Easily reproduced in F18 Beta.
> 
> Proposing as an F18 Blocker, based on:
> 
> http://fedoraproject.org/wiki/
> Fedora_18_Final_Release_Criteria#Final_Release_Requirements
> 
>   18. All elements of the default panel (or equivalent) configuration in all
> release-blocking desktops must function correctly in common use

I'm not sure why leftover from previous session/different desktop should be considered as default panel element.

-1 blocker
Comment 7 Tim Flink 2012-12-06 10:39:51 EST
I'm not quite sure I understand the issue here. Is ibus supposed to show up in KDE or is this just an issue with gtk components from the gnome install not working quite right with KDE? Does the issue show up with an install of just KDE w/o GNOME?
Comment 8 Parag Nemade 2012-12-06 11:17:28 EST
guess we need blocker for the theme bug actually.
Comment 9 Jens Petersen 2012-12-06 23:37:11 EST
(In reply to comment #6)
> I'm not sure why leftover from previous session/different desktop should be
> considered as default panel element.

?

It is not a leftover - ibus is the default input method system for all desktops.

(In reply to comment #7)
> Is ibus supposed to show up in KDE

Yes for all Asian users.

> or is this just an issue with gtk components from the gnome install
> not working quite right with KDE?

No

> Does the issue show up with an install of just KDE w/o GNOME?

Yes

| ibus applet appears by default in DVD install of KDE for Asian languages.

Sorry my comment too terse, I see.
Comment 10 fujiwara 2012-12-06 23:50:07 EST
It seems calling gkbd_configuration_get() causes an error that cannot close /usr/lib64/gio/modules/libgsettingsgconfbackend.so .

libgnomekbd was implemented not to crash it on GNOME 3.4 but now it's not used in GNOME 3.6.
Now the feature needs to be disabled.
Comment 11 fujiwara 2012-12-06 23:54:47 EST
Here is the suggested fix.

diff --git a/ibus.spec b/ibus.spec
index 3585ca7..9d00bb5 100644
--- a/ibus.spec
+++ b/ibus.spec
@@ -272,7 +272,6 @@ autoreconf -f -i
 %endif
 %if %with_xkbfile
     --with-xkb-command=ibus-xkb \
-    --enable-libgnomekbd \
 %endif
     --enable-dconf \
     --disable-gconf \
Comment 12 Kevin Kofler 2012-12-07 18:24:03 EST
> > Is ibus supposed to show up in KDE
>
> Yes for all Asian users.

Well, I think we should really be defaulting to kimpanel rather than ibus-gtk3 in KDE Plasma sessions! It really sucks that we still don't have that set up out of the box. But of course that doesn't mean that ibus-gtk3 shouldn't work.
Comment 13 Fedora Update System 2012-12-10 04:31:28 EST
ibus-1.4.99.20121109-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ibus-1.4.99.20121109-8.fc18
Comment 14 Fedora Update System 2012-12-10 04:31:54 EST
ibus-1.4.99.20121109-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-1.4.99.20121109-8.fc17
Comment 15 Adam Williamson 2012-12-10 14:14:50 EST
Discussed at 2012-12-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-10/f18final-blocker-review-3.2012-12-10-17.13.log.txt . As we understand it, this bug breaks default CJK input for a KDE install from DVD, as ibus-gtk3 is the default at present. Accepted as a blocker on that basis, per criterion "All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in common use" in the case of a CJK install from DVD.
Comment 16 Fedora Update System 2012-12-10 16:15:24 EST
Package ibus-1.4.99.20121109-8.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.4.99.20121109-8.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20073/ibus-1.4.99.20121109-8.fc18
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2012-12-14 22:15:20 EST
ibus-1.4.99.20121109-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Kamil Páral 2012-12-16 11:48:36 EST
Can somebody please verify this is fixed with the new version? Thank you!
Comment 19 A S Alam 2012-12-16 21:09:32 EST
(In reply to comment #18)
> Can somebody please verify this is fixed with the new version? Thank you!

yes, I am using with version with KDE and it is working (icon stay and able to select it).
kde-workspace-4.9.4-2.fc18.x86_64
ibus-1.4.99.20121109-8.fc18.x86_64
Comment 20 Mike FABIAN 2012-12-17 03:11:28 EST
Yes, it works for me now.
Comment 21 Kamil Páral 2012-12-17 03:42:24 EST
Thank you.
Comment 22 Fedora Update System 2012-12-25 23:52:35 EST
ibus-1.4.99.20121109-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.