Bug 867484 - ibus icon unresponsive in kde
ibus icon unresponsive in kde
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 11:37 EDT by John Griffiths
Modified: 2012-12-10 05:47 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 05:47:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2012-10-17 11:37:21 EDT
Description of problem:
The ibus icon in the system tray icons under kde is not responsive to mouse clicks, left or right. The configuration or current selection is not displayed as it should be.

Version-Release number of selected component (if applicable):
ibus-1.4.99.20120914-2.fc17.i686


How reproducible:
Always for a user that had KDE as their desktop before Fedora 17 and are using their previous kde environment.

I have had it work once on a fresh kde, but if I used the restart command for ibus, then the mouse clicks would not work.

Steps to Reproduce:
1. Install Fedora 17 with KDE
2. Use KDE as your desktop
3. Try left or right mouse click on the tray icon.
  
Actual results:
Mouse clicks not responsive. Sometimes there will be a flash of a menu but it immediately goes away.

Expected results:
Should respond appropriately for left and right mouse clicks.

Additional info:
Comment 1 fujiwara 2012-10-17 21:43:39 EDT
Fowarding to KDE component.
It seems the issue is happened in case the left/right click menu is GTK+.

The workaround is to use the command line:
% ibus --help
Comment 2 Mike FABIAN 2012-10-24 06:41:10 EDT
*** Bug 869584 has been marked as a duplicate of this bug. ***
Comment 3 Mike FABIAN 2012-10-24 06:44:02 EDT
(In reply to comment #0)

> How reproducible:
> Always for a user that had KDE as their desktop before Fedora 17 and are
> using their previous kde environment.
> 
> I have had it work once on a fresh kde, but if I used the restart command
> for ibus, then the mouse clicks would not work.

I see the same problem in f18 freshly installed from
Fedora-18-Beta-TC6-x86_64-netinst.iso. See:

https://bugzilla.redhat.com/show_bug.cgi?id=869584#c0

Happens *always* for me, I also saw this in earlier betas of f18.
Comment 4 A S Alam 2012-12-01 09:27:09 EST
I am not able to use Ibus with KDE anymore (first installed Gnome and used ibus, then installed KDE and login):

ibus-1.4.99.20121109-2.fc18.x86_64
ibus-qt-1.3.1-10.fc18.x86_64
qt-4.8.3-7.fc18.x86_64
kde-baseapps-4.9.3-1.fc18.x86_64

---
using following to switch locale
ibus engine m17n:pa:jhelum
ibus engine  xkb:us::eng
Comment 5 fujiwara 2012-12-10 05:47:27 EST
I provided a fix not to load libgnomekbd on KDE.
https://admin.fedoraproject.org/updates/ibus-1.4.99.20121109-8.fc17

Note You need to log in before you can comment on or make changes to this bug.