This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 870036

Summary: libreoffice bundles hsqldb
Product: [Fedora] Fedora Reporter: David Tardon <dtardon>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: caolanm, dtardon, erack, ltinkl, mizdebsk, mstahl, sbergman
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 824035 Environment:
Last Closed: 2013-10-08 07:04:45 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 504493    

Description David Tardon 2012-10-25 09:00:57 EDT
+++ This bug was initially created as a clone of Bug #824035 +++

libreoffice seems to bundle at least the following libraries:

1) saxon is bundled in libreoffice-core
Jar file location: /usr/lib64/libreoffice/program/classes/saxon9.jar

2) hsqldb is bundled in libreoffice-base
Jar file location: /usr/lib64/libreoffice/program/classes/hsqldb.jar

--- Additional comment from mizdebsk@redhat.com on 2012-05-22 17:40:16 CEST ---

Created attachment 586065 [details]
list of Java classes provided by libreoffice packages

--- Additional comment from mizdebsk@redhat.com on 2012-05-22 17:41:18 CEST ---

Created attachment 586066 [details]
contents of saxon9.jar

--- Additional comment from mizdebsk@redhat.com on 2012-05-22 17:42:36 CEST ---

Created attachment 586067 [details]
contents of hsqldb.jar

--- Additional comment from caolanm@redhat.com on 2012-05-22 18:07:21 CEST ---

yeah, I know, because the two later version of the above cause trouble.

latest 1.8.X series hsqldb doesn't write databases compatible with older versions, IIRC fred said he might being out a point release with a toggle which would allow that, must ping him about that

latest saxon has removed from the free version the features that some older versions had and which our usage of it relies on :-(, plan there was to hopefully try and remove the use of saxon entirely and replace it, that seems to have gotten stalled upstream however

--- Additional comment from caolanm@redhat.com on 2012-05-24 18:07:47 CEST ---

Pinged fred and said he might get around to releasing a hsqldb-1.8.1.4 which I guess would appear at http://sourceforge.net/projects/hsqldb/files/hsqldb/hsqldb_1_8_1/ that would solve 50% of the problem anyway

--- Additional comment from caolanm@redhat.com on 2012-09-11 12:43:57 CEST ---

for saxon, its required for xslt2 support, but there's been a lot of work (IIUC) to move our xslt filters to xslt1 and use the libxslt transformer, which is now the default. So last step would be to split out the saxon-using transformed into an available-from-elsewhere extension if someone really needs it, and not bundle/include it by default. dtardon's got some hack-in-progress there apparently

--- Additional comment from caolanm@redhat.com on 2012-09-12 12:37:27 CEST ---

reassign to dtardon for the saxon bit anyway
Comment 1 Fedora End Of Life 2013-04-03 10:07:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 2 Caolan McNamara 2013-10-08 07:04:45 EDT
the upstream master plan is to try and write a new java-free hsqldb import converter to firebird