Bug 824035 - libreoffice bundles saxon
libreoffice bundles saxon
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2012-05-22 11:37 EDT by Mikolaj Izdebski
Modified: 2012-11-08 09:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 870036 (view as bug list)
Environment:
Last Closed: 2012-10-28 07:29:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
list of Java classes provided by libreoffice packages (239.16 KB, text/plain)
2012-05-22 11:40 EDT, Mikolaj Izdebski
no flags Details
contents of saxon9.jar (44.58 KB, text/plain)
2012-05-22 11:41 EDT, Mikolaj Izdebski
no flags Details
contents of hsqldb.jar (13.79 KB, text/plain)
2012-05-22 11:42 EDT, Mikolaj Izdebski
no flags Details

  None (edit)
Description Mikolaj Izdebski 2012-05-22 11:37:46 EDT
libreoffice seems to bundle at least the following libraries:

1) saxon is bundled in libreoffice-core
Jar file location: /usr/lib64/libreoffice/program/classes/saxon9.jar

2) hsqldb is bundled in libreoffice-base
Jar file location: /usr/lib64/libreoffice/program/classes/hsqldb.jar
Comment 1 Mikolaj Izdebski 2012-05-22 11:40:16 EDT
Created attachment 586065 [details]
list of Java classes provided by libreoffice packages
Comment 2 Mikolaj Izdebski 2012-05-22 11:41:18 EDT
Created attachment 586066 [details]
contents of saxon9.jar
Comment 3 Mikolaj Izdebski 2012-05-22 11:42:36 EDT
Created attachment 586067 [details]
contents of hsqldb.jar
Comment 4 Caolan McNamara 2012-05-22 12:07:21 EDT
yeah, I know, because the two later version of the above cause trouble.

latest 1.8.X series hsqldb doesn't write databases compatible with older versions, IIRC fred said he might being out a point release with a toggle which would allow that, must ping him about that

latest saxon has removed from the free version the features that some older versions had and which our usage of it relies on :-(, plan there was to hopefully try and remove the use of saxon entirely and replace it, that seems to have gotten stalled upstream however
Comment 5 Caolan McNamara 2012-05-24 12:07:47 EDT
Pinged fred and said he might get around to releasing a hsqldb-1.8.1.4 which I guess would appear at http://sourceforge.net/projects/hsqldb/files/hsqldb/hsqldb_1_8_1/ that would solve 50% of the problem anyway
Comment 6 Caolan McNamara 2012-09-11 06:43:57 EDT
for saxon, its required for xslt2 support, but there's been a lot of work (IIUC) to move our xslt filters to xslt1 and use the libxslt transformer, which is now the default. So last step would be to split out the saxon-using transformed into an available-from-elsewhere extension if someone really needs it, and not bundle/include it by default. dtardon's got some hack-in-progress there apparently
Comment 7 Caolan McNamara 2012-09-12 06:37:27 EDT
reassign to dtardon for the saxon bit anyway
Comment 8 Fedora Update System 2012-11-08 09:49:24 EST
libreoffice-3.6.3.2-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libreoffice-3.6.3.2-6.fc18

Note You need to log in before you can comment on or make changes to this bug.