Bug 870358

Summary: Screen corrupted or system freezes with nouveau on Kernel 3.6.2-1.fc16
Product: [Fedora] Fedora Reporter: quique <quique.costa>
Component: xorg-x11-drv-nouveauAssignee: Ben Skeggs <bskeggs>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 16CC: adi1981.2k5, airlied, ajax, bskeggs, gansalmon, itamar, jonathan, kernel-maint, lalee, madhu.chinakonda, mike.cloaked
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-13 07:51:39 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
rpm -qa, uname -r, lsmod, lspci, normal dmesg
none
pm-suspend.log on F17
none
Xorg.log on F17
none
Xorg.0.log on F17
none
messages on F17 none

Description quique 2012-10-26 04:50:40 EDT
Created attachment 633746 [details]
rpm -qa, uname -r, lsmod,  lspci, normal dmesg

Description of problem:
Recently I updated my F16 from Kernel 3.4.11-1.fc16 to 3.6.2-1.fc16.
Since then and from time to time (but very often) I get corrupted my screen. Sometimes totally and sometimes just some parts of the screen.
When all the screen is corrupted I have to close the session (ctl-Alt-Backspace), start a new session and it works again.
My computer is a LG E500 with a Nvidia G86 (GeForce 8400M G). I'm using the standard nouveau driver. and KDE Desktop
I get a similar result when I try to resume after an hibernation.

Version-Release number of selected component (if applicable):
uname -r
3.6.2-1.fc16.i686
lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G86 [GeForce 8400M G] (rev a1)


How reproducible:
Resume after Hibernation gets always a corrupted screen.
Sometimes ctr-Alt-Backspace works and sometimes not

Steps to Reproduce:
1.Hibernate
2.Resume
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike C 2012-11-07 05:17:46 EST
I have a machine which has periodically been doing this as well - it is a Dell 530S Inspiron with graphics card GeForce 8300 GS - next time this happens I will try to get some diagnostics and capture the .xsession-errors file.

This is happening with kernel 3.6.5-2.fc16.x86_64

However I will be testing the latest kernel from testing in the next day or so.
Comment 2 Mike C 2012-11-07 05:21:51 EST
I forgot to mention that this has happened when running Thunderbird and/or LibreOffice but not at other times - so I don't know if it is a problem with the kernel or nouveau or something else but I will test with the new kernel for a day or so and report back if the problem recurs. However once it happens it really causes a major corruption to the graphics and often there is no way to close down applications using the mouse or keyboard and the only thing that can be done is to forcibly log the session out and log back in - this is also with KDE and standard nouveau like the original report.
Comment 3 Mike C 2012-11-07 05:41:44 EST
One additional comment is that once the screen corruption occurs then moving the mouse around gives a series of colour changes and blocks of corruption along the path that the mouse is moved - but that normal movement into the top right of an application window to click on the x to close the window will no longer work.

I have turned off desktop effects for the moment to see if the problem does not occur when 3d effects are not switched on.
Comment 4 quique 2012-11-07 12:45:45 EST
I have just tested again with Kernel 3.6.5-1.fc17 on F17.
I spent some time walking through the web and with LibreOffice Impress and it worked but as I tried to Hibernate-Awake I got the same result. I did it twice. One time I could close the session and the other I had to power-off the computer.
Comment 5 Mike C 2012-11-07 14:33:07 EST
Maybe there are some differences in the graphics packages for F16 and F17 which might make a difference in whether or not this problem is manifested? Not sure the best way to get some diagnostics apart from pulling the Xorg log and xsession errors log once the problem arises but I bet having some log files will make a big difference to the chance of finding where the problem lies?
Comment 6 quique 2012-11-08 10:02:12 EST
Created attachment 640863 [details]
pm-suspend.log on F17
Comment 7 quique 2012-11-08 10:03:17 EST
Created attachment 640867 [details]
Xorg.log on F17
Comment 8 quique 2012-11-08 10:04:02 EST
Created attachment 640871 [details]
Xorg.0.log on F17
Comment 9 quique 2012-11-08 10:04:40 EST
Created attachment 640872 [details]
messages on F17
Comment 10 quique 2012-11-08 10:06:31 EST
I have added the following files related with a freeze on F17 after an hibernation:
pm-suspend.log, Xorg.log, Xorg.0.log and messages
Comment 11 Mike C 2012-11-08 12:25:20 EST
With desktop effects switched off (my F16 system) I have not had a further occurrence of screen corruption but will keep testing.

I have also installed kernel 3.6.6-1.fc16.x86_64 and will now test with this kernel.
Comment 12 Laurence Lee 2012-12-28 15:39:30 EST
I have also encountered this screen corruption problem in F16 when using the 3.6 series kernels; and the problem does not exist with the 3.4 kernel.

I can confirm the issue as I experienced it in F16 also exists in the F18 Beta:

uname -r && lspci | grep VGA
3.6.11-3.fc18.x86_64
01:00.0 VGA compatible controller: NVIDIA Corporation Device 1251 (rev a1)

It appears some kind of kernel message is no longer being sent to the Nouveau driver to do a full refresh or of the screen buffer.
Comment 13 Adrian "Adi1981" P. 2013-01-02 08:00:20 EST
I have the same issue, it started with kernel 3.5 and still continues. With kernel 3.4.6 all was perfectly fine till some update, which caused that X does not start any more on 3.4.6. 
It seems that it's very similar (or the same) issue as with ati driver fixed here → https://bugzilla.redhat.com/show_bug.cgi?id=846505
Screenshots of corruption are attached to ati bug, so I will not post new ones here.

In my case, usually it starts when using firefox for few minutes, after some time it also affects other applications. From time to time it also leads to complete hung of Xserver, so since I'm unable to boot kernel 3.4.6 (don't have time to check which update broke X on that kernel), my notebook with Fedora 18 became quite unusable.

GPU is Nvidia 8600G M.
Comment 14 Fedora End Of Life 2013-01-16 07:32:47 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Fedora End Of Life 2013-02-13 07:51:43 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.