This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 846505 - Kernel 3.5.0 causes severe graphical glitches in Gnome with ATI Mobility Radeon X1600 not present with 3.4.6
Kernel 3.5.0 causes severe graphical glitches in Gnome with ATI Mobility Rade...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
17
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-07 21:27 EDT by sumstultussedesquoque
Modified: 2012-12-20 11:29 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:29:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Picture of graphical artifacts. (849.75 KB, image/jpeg)
2012-08-07 21:27 EDT, sumstultussedesquoque
no flags Details
Graphical artefacts in XFCE. (386.09 KB, image/png)
2012-08-23 14:19 EDT, benvdh
no flags Details
/var/log messages of 3.5.0-2.fc17.i686.PAE kernel (96.08 KB, text/plain)
2012-08-23 14:21 EDT, benvdh
no flags Details

  None (edit)
Description sumstultussedesquoque 2012-08-07 21:27:28 EDT
Created attachment 602899 [details]
Picture of graphical artifacts.

Description of problem:
Upgrading to kernel 3.5.0 introduced severe graphical artifacts throughout the desktop environment, rendering the comupter wholly unusable.  Booting to the old kernel (3.4.6) works perfectly with no artifacts of any kind.  This is using the default driver included in Fedora, not Catalyst.  No notable error messages appear in the xorg logs, xsession-errors, dmesg, etc. (that I notice, at least).  It should be noted that this may be a general issue with Radeon Mobility cards, as this individual on FedoraForum.org seems to have the same issue:  http://forums.fedoraforum.org/showpost.php?p=1595193

Version-Release number of selected component (if applicable):  3.5.0


How reproducible:  100%


Steps to Reproduce:
1.  Boot to 3.5.0 kernel.
2.  Observe artifacts.
3.  Boot to 3.4.6.
4.  No artifacts.
  
Actual results:
Severe graphics corruption.

Expected results:
No graphical artifacts.

Additional info:
    Relevant lspci:
        01:00.0 VGA compatible controller: ATI Technologies Inc M56P [Radeon Mobility X1600]



Please let me know what additional information I can provide that would be helpful.
Comment 1 Benjamin Bellec 2012-08-09 13:54:57 EDT
I have the same issue. I'm using LXDE so my desktop is fine, but when I play Enemy Territory: QUAKE Wars, after several minutes there is huge rendering problem. The console log says:
"radeon: The kernel rejected CS, see dmesg for more information." many many times! (until I leave the game).
Nothing in dmesg though.
Last time, I was playing normally during 25 minutes and instantly rendering corruption appears.

This happens when I boot on the new 3.5.0-2.fc17.x86_64 kernel. No problem with the previous 3.4 series.

Software:
xorg-x11-drv-ati 6.14.4-6.20120602git930760942.fc17
libdrm 2.4.33-3.fc17
mesa-r600g (git)

Hardware:
01:00.0 VGA compatible controller [0300]: ATI Technologies Inc RV770 [Radeon HD 4850] [1002:9442]
Comment 2 benvdh 2012-08-11 07:10:38 EDT
I've seen similar problems on both KDE and GNOME. In GTK apps it were mainly font-rendering problems, GDM showing up in a weird way, although GDM was functional and the Gnome shell didn't show up.

In KDE it were large rectangles covering large parts of text in Konqueror, although resizing the window or moving seemed to make these go away again (maybe related to: https://bugzilla.redhat.com/show_bug.cgi?id=845639 ?)

On 3.4.6 all these problems disappeared.
Comment 3 benvdh 2012-08-13 03:55:41 EDT
(In reply to comment #2)
> I've seen similar problems on both KDE and GNOME. In GTK apps it were mainly
> font-rendering problems, GDM showing up in a weird way, although GDM was
> functional and the Gnome shell didn't show up.
> 
> In KDE it were large rectangles covering large parts of text in Konqueror,
> although resizing the window or moving seemed to make these go away again
> (maybe related to: https://bugzilla.redhat.com/show_bug.cgi?id=845639 ?)
> 
> On 3.4.6 all these problems disappeared.

In addition to the above: KDM (login) worked flawlessly and rendered correctly even under 3.5 kernels.
Comment 4 wsakumoto 2012-08-19 23:01:58 EDT
I have a HP nc8430 (ati mobility x1600) with F17 with the xorg-x11-drv-ati
driver, and also see the graphical artifacts with kernel 3.5.2 (x86_64).
There are no artifacts with kernel 3.3.4.

From /var/log/messages, maybe drm is really unhappy ... there is a timeout.

                                                                

From 3.5.2 message log:
[1.700710][drm] Initialized drm 1.1.0 20060810
...
[1.771320] [drm] Generation 2 PCI interface, using max accessible memory
[1.771326] radeon 0000:01:00.0: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (256M used)
[1.771330] radeon 0000:01:00.0: GTT: 512M 0x0000000010000000 - 0x000000002FFFFFFF
[1.771356] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[1.771358] [drm] Driver supports precise vblank timestamp query.
[1.771422] radeon 0000:01:00.0: radeon: using MSI.
[1.771451] [drm] radeon: irq initialized.
[1.773739] [drm] Detected VRAM RAM=256M, BAR=256M
[1.773744] [drm] RAM width 128bits DDR
[1.773824] [TTM] Zone  kernel: Available graphics memory: 1025868 kiB
[1.773826] [TTM] Initializing pool allocator
[1.773833] [TTM] Initializing DMA pool allocator
[1.773868] [drm] radeon: 256M of VRAM memory ready
[1.773870] [drm] radeon: 512M of GTT memory ready.
[1.773898] [drm] GART: num cpu pages 131072, num gpu pages 131072
[1.775982] [drm] radeon: 1 quad pipes, 2 z pipes initialized.
[1.965408] Failed to wait MC idle while programming pipes. Bad things might happen.
[1.966592] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
[1.966621] radeon 0000:01:00.0: WB enabled
....


From 3.3.4 message log:
[1.600398] [drm] Initialized drm 1.1.0 20060810
...
[1.617300] [drm] Generation 2 PCI interface, using max accessible memory
[1.617312] radeon 0000:01:00.0: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (
256M used)
[1.617316] radeon 0000:01:00.0: GTT: 512M 0x0000000010000000 - 0x000000002FFFFFFF
[1.617339] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
[1.617341] [drm] Driver supports precise vblank timestamp query.
[1.617467] radeon 0000:01:00.0: radeon: using MSI.
[1.617510] [drm] radeon: irq initialized.
[1.619911] [drm] Detected VRAM RAM=256M, BAR=256M
[1.619915] [drm] RAM width 128bits DDR
[1.621119] [TTM] Zone  kernel: Available graphics memory: 1025974 kiB.
[1.621123] [TTM] Initializing pool allocator.
[1.621129] [TTM] Initializing DMA pool allocator.
[1.621163] [drm] radeon: 256M of VRAM memory ready
[1.621165] [drm] radeon: 512M of GTT memory ready.
[1.621192] [drm] GART: num cpu pages 131072, num gpu pages 131072
[1.622309] [drm] radeon: ib pool ready.
[1.623432] [drm] radeon: 1 quad pipes, 2 z pipes initialized.
[1.624671] [drm] PCIE GART of 512M enabled (table at 0x0000000000040000).
[1.624711] radeon 0000:01:00.0: WB enabled
Comment 5 Jerome Glisse 2012-08-22 12:55:03 EDT
For reference to have all informations that might be usefull

> #:/usr/src/linux-stable ((bb63556...)|BISECTING)# git bisect bad
> bb635567291482a87e4cc46e6683419c1f365ddf is the first bad commit
> commit bb635567291482a87e4cc46e6683419c1f365ddf
> Author: Jerome Glisse <jglisse@redhat.com>
> Date:   Wed May 9 15:34:46 2012 +0200
>
>     drm/radeon: convert fence to uint64_t v4
>    
>     This convert fence to use uint64_t sequence number intention is
>     to use the fact that uin64_t is big enough that we don't need to
>     care about wrap around.
Comment 6 Aaron 2012-08-23 12:21:54 EDT
I have the same issues listed on a Radeon Xpress 1250. (Dell Latitude XT) and stock fedora driver.
Comment 7 Jerome Glisse 2012-08-23 13:01:10 EDT
Which application trigger the issue ? Stock gnome-shell without any modification or customization ? How do you easily trigger the issue ?

Until we can reproduce it's hard to fix.
Comment 8 benvdh 2012-08-23 14:16:19 EDT
(In reply to comment #7)
> Which application trigger the issue ? Stock gnome-shell without any
> modification or customization ? How do you easily trigger the issue ?
> 
> Until we can reproduce it's hard to fix.

For me it were mainly GTK and QT apps that triggered the issue. Framebuffer apps (e.g. links2 -G) and a terminal running in Konsole didn't show any problems. 

I'm running FC17 on a Dell E1505/Inspiron 6400 with a Mobility Radeon X1400. I ran Kernel 3.5.0-2.fc17.i686 to gather some data. I didn't succeed in making a screenshot of GDM, but I have made one of my XFCE desktop afterwards. I'll attach it in a minute. 

Furthermore I couldn't reproduce the poster in Comment 4 spoke about. I did find the following errors/warnings in /var/log/gdm/:0-greeter.log:

Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0.  This shouldn't happen!

(gnome-settings-daemon:1451): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-settings-daemon:1451): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

--------
I'll attach my /var/log/messages from that last session and the screenshot. In case you need other logs or you want me to try other things feel free to ask.
Comment 9 benvdh 2012-08-23 14:19:59 EDT
Created attachment 606677 [details]
Graphical artefacts in XFCE.

I'm using a dual monitor setup so screenshot shows both monitors. On the right you see Konsole running, on the left a gtk based terminal GUI.
Comment 10 benvdh 2012-08-23 14:21:10 EDT
Created attachment 606678 [details]
/var/log messages of 3.5.0-2.fc17.i686.PAE kernel
Comment 11 sumstultussedesquoque 2012-08-23 14:28:14 EDT
(In reply to comment #7)
> Which application trigger the issue ? Stock gnome-shell without any
> modification or customization ? How do you easily trigger the issue ?
> 
> Until we can reproduce it's hard to fix.

In my case, stock gnome-shell is affected (including the login screen), as well as any other graphical programs I've run.  I haven't tried installing a different desktop environment, but from the above, it sounds like the problem persists in XFCE.

Just booting the system is sufficient to trigger the issue in my case; the login screen itself is corrupted 100% of the time (in the 10-20 times that I've tried it), as is the entirety of gnome after logging in.
Comment 12 Daniel Qarras 2012-08-27 04:14:41 EDT
(In reply to comment #7)
> Which application trigger the issue ? Stock gnome-shell without any
> modification or customization ? How do you easily trigger the issue ?
> 
> Until we can reproduce it's hard to fix.

I have the same problem with my ATI Radeon Mobility X700.

Booting without Plymouth shows startup messages normally but once GDM is started, it is garbled 100% time. When logging in the whole desktop / gnome-shell is messy, going to the upper left corned for the favorities menu show the menu but all the icons are messy and I need to click like 20 times before a favorite app is being opened. Zero modification locally except for Plymouth disabled with a kernel parameter.

This is a severe regression, using kernel 3.5 is now impossible and while it's possible to stick with 3.4 on F17 I fear that upgrading to F18 can't be done before this is fixed as the whole desktop is unusable.
Comment 13 Jerome Glisse 2012-08-27 14:30:54 EDT
Does kernel patch:

http://people.freedesktop.org/~glisse/0001-drm-radeon-extra-type-safe-for-fence-
emission.patch

Helps ?
Comment 14 Benjamin Bellec 2012-08-27 16:19:23 EDT
(In reply to comment #7)
> Until we can reproduce it's hard to fix.

Actually I fail to reproduce the bug on ETQW! I don't know why. It's very strange. However, I have on hypothesis:

I compiled r600g with the kernel-headers 3.4. And then upgraded to 3.5 without recompiling r600g. Can this be a source of problem?
Comment 15 Jerome Glisse 2012-08-27 16:26:48 EDT
Also can you test if booting with radeon.no_wb=1 fix the issue ?
Comment 16 wsakumoto 2012-08-28 00:29:34 EDT
I find that the 'Failed to wait MC idle while programming pipes. Bad things..'
line in my Comment #4 does not happen all the time, so it is likely not
relevant.

Every boot with 3.5.2 on a HP nc8430 (x1600) gives a corrupted GDM login window
as well as Gnome3 shell. I also get corruption in a single Xclient and Xserver
on another tty: xinit urvxt -display :4 -- Xorg :4 vt4. The scrolling
text in the xterm is unreadable - horizontal striations that sometimes extend
way past the xterm right boundary. But playing videos (mplayer) windowed or
full-screen is corruption free (hardware fb?).

Booting to 3.5.2 with radeon.no_wb=1 and the stock radeon driver still has
corruption in the GDM login screen. Are there help files on getting and
compiling a test radeon driver (configure/Makefile)?
Comment 17 Daniel Qarras 2012-08-28 04:30:07 EDT
(In reply to comment #15)
> Also can you test if booting with radeon.no_wb=1 fix the issue ?

No, didn't help at all with my ATI Radeon Mobility X700.

Any chances you could provide a kernel package with the patch for testing?
Comment 18 Daniel Qarras 2012-08-30 02:25:56 EDT
(In reply to comment #13)
> Does kernel patch:
> 
> http://people.freedesktop.org/~glisse/0001-drm-radeon-extra-type-safe-for-
> fence-emission.patch
> 
> Helps ?

Corruption still there with this patch, no notable change.
Comment 19 heemeli 2012-08-30 09:47:09 EDT
I have very similar issues as #11 and #12.

Stock F17, with KDE. Kernel 3.5.0-2. Mobility Radeon X700.
Comment 20 Colin Simpson 2012-09-10 09:06:59 EDT
I'm just adding that other people including me are seeing this on NVIDIA nouveau since the 3.5 series all was fine in 3.4. So maybe not a card specific driver issue?

https://bugzilla.redhat.com/show_bug.cgi?id=845965
Comment 21 Daniel Qarras 2012-09-14 11:21:19 EDT
I've now tested kernel-PAE-3.6.0-0.rc2.git2.1.fc18.i686 from Rawhide and the problem persist.

Jerome, any suggestions, seems like this issue affects of lots of people?
Comment 22 Fedora Update System 2012-09-27 12:25:32 EDT
kernel-3.5.4-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.5.4-2.fc17
Comment 23 Fedora Update System 2012-09-28 04:19:16 EDT
Package kernel-3.5.4-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.5.4-2.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14952/kernel-3.5.4-2.fc17
then log in and leave karma (feedback).
Comment 24 Daniel Qarras 2012-09-28 14:54:37 EDT
Thanks a lot, 3.5.4-2.fc17 fixed the issue for me, karma added!
Comment 25 benvdh 2012-09-28 16:12:58 EDT
As I posted in bodhi (Anonymous tester) it solved the graphical problems for me as well.
Comment 26 Fedora Update System 2012-12-20 11:29:49 EST
kernel-3.5.4-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.