Bug 872091

Summary: lid close settings don't work
Product: [Fedora] Fedora Reporter: Samuel Sieb <samuel-rhbugs>
Component: gnome-tweak-toolAssignee: Mohamed El Morabity <pikachu.2014>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: amit.shah, awilliam, michel, pikachu.2014
Target Milestone: ---Keywords: ReleaseNotes
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-20 11:17:41 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Samuel Sieb 2012-11-01 04:04:07 EDT
I set both of the lid close settings to "nothing" and the laptop suspends when I close the lid.  I tried setting it to "blank" and still the same result.

According to https://bugzilla.gnome.org/show_bug.cgi?id=687277 support for those options has been intentionally removed and a workaround is listed.  Very sad, but I guess those options should be removed from gnome-tweak-tool.
Comment 1 Michel Alexandre Salim 2012-11-01 13:55:48 EDT
Thanks for letting me know. The settings in question haven't been removed from gnome-settings-daemon as of 3.6.1, which is why I didn't notice any problem running g-t-t, but this should indeed be fixed.
Comment 2 Michel Alexandre Salim 2012-11-02 03:58:24 EDT
So Fedora (and Arch) backported the feature planned for GNOME 3.8 where GNOME no longer handles lid close behavior.

I've thus submitted the patch against gnome-tweak-tool master, requesting upstream to create a separate GNOME 3.6 branch for stable bugfixes, and built gnome-tweak-tool with the patch for Rawhide.

Can't build for F-18 yet as the mock builders currently have some repository inconsistencies; will try again in a few hours.

https://bugzilla.gnome.org/show_bug.cgi?id=687413
Comment 3 Fedora Update System 2012-11-02 11:21:25 EDT
gnome-tweak-tool-3.6.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-tweak-tool-3.6.1-2.fc18
Comment 4 Fedora Update System 2012-11-02 14:41:43 EDT
Package gnome-tweak-tool-3.6.1-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-tweak-tool-3.6.1-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17510/gnome-tweak-tool-3.6.1-2.fc18
then log in and leave karma (feedback).
Comment 5 Fedora Admin XMLRPC Client 2012-11-13 02:06:18 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Adam Williamson 2012-11-16 21:03:02 EST
this should probably be in the release notes.

Docs team, you will want to see this bug:

https://bugzilla.gnome.org/show_bug.cgi?id=687277

which has discussion of the change, and most pertinently, the new way to disable suspend-on-lid-close (via systemd).
Comment 7 Fedora Update System 2012-12-20 11:17:43 EST
gnome-tweak-tool-3.6.1-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Kamil Páral 2013-01-10 10:45:16 EST
*** Bug 878619 has been marked as a duplicate of this bug. ***