Bug 876506

Summary: <productname> tag inside <ulink> tag disappears from .po-file
Product: [Fedora] Fedora Documentation Reporter: Inna Kabanova <ikabanova>
Component: release-notesAssignee: Release Notes Tracker <relnotes>
Status: CLOSED CURRENTRELEASE QA Contact: Karsten Wade <kwade>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: develCC: ikabanova, me, wb8rcr, zach
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 909728 (view as bug list) Environment:
Last Closed: 2013-02-10 18:57:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 151189, 909728    

Description Inna Kabanova 2012-11-14 10:05:02 UTC
In working on the translation the Fedora 18 Release Notes into Russian I faced the following string (xml-source):

"For more information refer to the <ulink url="http://wiki.linux-nfs.org/wiki/index.php/FedFsUtilsProject"> <productname>FedFS</productname> project page</ulink> and the <ulink url="http://wiki.linux-nfs.org/wiki/index.php/FedFsUtilsDocs"> <productname>FedFS</productname> Documentation page</ulink>."

In po-file it looks like the following:

"For more information refer to the <ulink url=\"http://wiki.linux-nfs.org/wiki/index.php/FedFsUtilsProject\"> project page</ulink> and the <ulink url=\"http://wiki.linux-nfs.org/wiki/index.php/FedFsUtilsDocs\"> Documentation page</ulink>."

So the "<productname>FedFS</productname>" part dissapears from po-file. Thus the source string and the translated string no longer correspond to each other. And in translated document this string remains untranslated (it isn't taken into account during building the document up).

This string is in the "2.5.1. FedFS" section of the Release Notes (File_Systems.xml file, lines 49-50).

Comment 1 Inna Kabanova 2012-11-14 19:29:54 UTC
The same situation is in the Desktop.po file.

Xml-string (line 40):
"<emphasis>Support for <productname>ActiveSync</productname> Accounts</emphasis>: You can use the <application>GNOME</application> <function>online accounts</function> feature to connect your desktop with your online accounts. GNOME already includes a connector for <trademark>Google</trademark> accounts, and <productname>GNOME 3.6</productname> adds a connector for <productname>ActiveSync</productname> (or <productname>Microsoft Exchange</productname>) accounts."

String in po-file:
"<emphasis>Support for Accounts</emphasis>: You can use the "
"<application>GNOME</application> <function>online accounts</function> "
"feature to connect your desktop with your online accounts. GNOME already "
"includes a connector for <trademark>Google</trademark> accounts, and "
"<productname>GNOME 3.6</productname> adds a connector for "
"<productname>ActiveSync</productname> (or <productname>Microsoft "
"Exchange</productname>) accounts."

"<productname>ActiveSync</productname>" part is missed within <emphasis> tag - "<emphasis>Support for Accounts</emphasis>". 

So the result document doesn't include the translation of this string.

Comment 2 Inna Kabanova 2012-11-20 17:02:57 UTC
One more issue from Desktop.po file:

Xml-string (line 70):
"<emphasis>Improved Notification System</emphasis>: <application>GNOME 3.0</application> included a new way for applications to send notifications to users, called <function>Message Tray</function>. <productname>GNOME 3.6</productname> enhances the <function>Message Tray</function> to help users remain focused and know whether notifications are urgent. For more information, refer to the <ulink url="https://live.gnome.org/GnomeShell/Design/Guidelines/MessageTray"><orgname>GNOME</orgname> documentation</ulink>."

String in po-file:
"<emphasis>Improved Notification System</emphasis>: <application>GNOME "
"3.0</application> included a new way for applications to send notifications "
"to users, called <function>Message Tray</function>. <productname>GNOME "
"3.6</productname> enhances the <function>Message Tray</function> to help "
"users remain focused and know whether notifications are urgent. For more "
"information, refer to the"

The "<ulink url="https://live.gnome.org/GnomeShell/Design/Guidelines/MessageTray"><orgname>GNOME</orgname> documentation</ulink>" part is missing whole.

Comment 3 Pete Travis 2012-12-01 21:28:13 UTC
I've changed the source XML in the release notes to keep these strings whole. Thanks for catching this, Inna.

Comment 4 Pete Travis 2013-02-10 18:57:43 UTC
I'm closing this because the markup was changed to prevent the impact of the issue described. Thanks for identifying the problem and driving the fix, Inna. 

I have cloned this bug to create a new one for publican itself, https://bugzilla.redhat.com/show_bug.cgi?id=909728