Bug 876606

Summary: Libreoffice can't open a specific xls file
Product: [Fedora] Fedora Reporter: Pavel Alexeev <pahan>
Component: libreofficeAssignee: Michael Stahl <mstahl>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: caolanm, dtardon, erack, ItSANgo, ltinkl, mstahl, sbergman
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-01 23:37:13 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
Broken xls file
none
backtrace of loading failure none

Description Pavel Alexeev 2012-11-14 10:01:47 EST
Description of problem:
I have: LibreOffice 3.5.7.2 ID build: 350m1(Build:2)

On try open just get Generic error.
Please look at initial bugreport: https://www.aquaclusters.com/app/home/project/public/aquadatastudio/issue/7937

It have also example file.

Version-Release number of selected component (if applicable):
# rpm -qa 'libreoffice*'
libreoffice-calc-3.5.7.2-3.fc17.x86_64
libreoffice-kde-3.5.7.2-3.fc17.x86_64
libreoffice-graphicfilter-3.5.7.2-3.fc17.x86_64
libreoffice-ure-3.5.7.2-3.fc17.x86_64
libreoffice-gdb-debug-support-3.5.7.2-3.fc17.x86_64
libreoffice-opensymbol-fonts-3.5.7.2-3.fc17.noarch
libreoffice-presenter-screen-3.5.7.2-3.fc17.x86_64
libreoffice-ogltrans-3.5.7.2-3.fc17.x86_64
libreoffice-math-3.5.7.2-3.fc17.x86_64
libreoffice-impress-3.5.7.2-3.fc17.x86_64
libreoffice-draw-3.5.7.2-3.fc17.x86_64
libreoffice-langpack-ru-3.5.7.2-3.fc17.x86_64
libreoffice-writer-3.5.7.2-3.fc17.x86_64
libreoffice-pdfimport-3.5.7.2-3.fc17.x86_64
libreoffice-langpack-en-3.5.7.2-3.fc17.x86_64
libreoffice-core-3.5.7.2-3.fc17.x86_64
libreoffice-xsltfilter-3.5.7.2-3.fc17.x86_64
libreoffice-base-3.5.7.2-3.fc17.x86_64

How reproducible:
Always.
Comment 1 Eike Rathke 2012-11-15 08:12:30 EST
@Pavel:
Could you attach the file in question?
Comment 2 Pavel Alexeev 2012-11-17 15:46:30 EST
Created attachment 646969 [details]
Broken xls file

Sure.

Sorry, I had thinking what attachment is public from AquaCluster report.
Comment 3 David Tardon 2012-12-21 07:52:12 EST
Opens fine with my vanilla builds, but fails with Fedora's -> the failure is most probably caused by one of our patches.
Comment 4 David Tardon 2012-12-23 12:10:48 EST
The problem is not caused by any of our patches. The file is misclassified as writer_MS_Works_Document. I am investigating why.
Comment 5 David Tardon 2013-01-02 04:42:29 EST
Created attachment 671339 [details]
backtrace of loading failure

There is a problem loading the stream deep in sot. In the if condition in sot/source/sdstor/stgelem.cxx at line 407, nSize == 0, but nPage1 == -1, so StgEntry::Load returns false. But I have no clue why this apparently is not a problem in my debug build...
Comment 6 Michael Stahl 2013-01-04 13:48:27 EST
this is a 3.5.6 regression from the review patch d5345bfb40d6e33087fd053cc220308a2bc2945e,
the commit for fdo bug 53909 fixes this problem.

i'll add this and preemtively also the other 2 fixes in the upstream
3.6 branch for other regressions from that patch to the f17 package.
Comment 7 Fedora Update System 2013-01-21 05:33:45 EST
libreoffice-3.5.7.2-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.7.2-8.fc17
Comment 8 Pavel Alexeev 2013-01-21 06:37:13 EST
It still does not opened by 3.6.3.2-8.fc18 version of Libreoffice in Fedora 18. Do you plan add patch for F18 branch also?
Comment 9 Eike Rathke 2013-01-21 07:24:56 EST
@Pavel:
F18 is already on 3.6.4.3 that should have it from upstream. Please upgrade and try again.
Comment 10 Fedora Update System 2013-01-22 21:04:03 EST
Package libreoffice-3.5.7.2-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.7.2-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1280/libreoffice-3.5.7.2-8.fc17
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-01-23 01:39:07 EST
libreoffice-3.5.7.2-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.7.2-9.fc17
Comment 12 Fedora Update System 2013-02-01 23:37:15 EST
libreoffice-3.5.7.2-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Pavel Alexeev 2013-02-07 10:56:41 EST
Eike, thank you very much. It works now.