Bug 53909 - RPM_OPT_FLAGS not used during build
Summary: RPM_OPT_FLAGS not used during build
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: tcltk   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 58313 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-21 11:22 UTC by franz.sirl-kernel
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-23 03:26:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description franz.sirl-kernel 2001-09-21 11:22:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4+)
Gecko/20010920

Description of problem:
Even though the correct flags are passed via configure, tcltk doesn't use
them during build.
It seems that for tcltk to use RPM_OPT_FLAGS during build, you have to
change every 'make' in the specfile to 'make CFLAGS="$RPM_OPT_FLAGS"'.


Version-Release number of selected component (if applicable):
tcltk-8.3.3-65


How reproducible:
Always

Steps to Reproduce:
1. rpm -ba tcltk.spec
2. look at the actual compile lines, you don't get the complete current
default rpm flags '-O2 -march=i686'



Additional info:

Comment 1 Jens Petersen 2002-10-23 03:25:50 UTC
Does this cause you any problems?

Comment 2 Jens Petersen 2002-12-10 07:54:41 UTC
The hardcoding makecfg patches are no longer being applied in
tcltk-8.3.5-76 and later.  Closing this for now.

Comment 3 Jens Petersen 2002-12-11 01:17:29 UTC
*** Bug 58313 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.