This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes

Bug 879169

Summary: [ALL_LANG][SAM CLI] Unlocalized strings for ping module
Product: Subscription Asset Manager Reporter: Lijun Li <lijli>
Component: katelloAssignee: Adam Price <adprice>
Status: CLOSED NEXTRELEASE QA Contact: SAM QE List <sam-qe-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.3CC: adprice, agarcia, eng-l10n-bugs, eukim, fvalen, hpeters, noriko, qe-i18n-bugs, sfriedma, tomckay
Target Milestone: rcKeywords: Translation, Triaged
Target Release: 2.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-06-07 14:27:47 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 833466    

Description Lijun Li 2012-11-22 04:15:34 EST
Description of problem:
Unlocalized strings for ping module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin ping -h
Usage:  headpin <options> ping

Options:
  -h, --help    show this help message and exit
                ^^^^^^^^^^^Unlocalized
  -g            grep が使いやすい出力
  -v            詳細な構造化された出力
  -d DELIMITER  grep で認識できる出力内のコラム区切り記号、 -g オプションを付けた場合にのみ動作します
  --noheading   ヘッディングの出力を表示しません。出力を grep する場合に便利です。
[root@i18nsamtest ~]# headpin ping
認証情報が無効であるか、 または認証不能です
[root@i18nsamtest ~]# headpin -u admin -p admi ping
Invalid credentials
^^^^^^^^^^^Unlocalized
[root@i18nsamtest ~]# headpin -u admin -p admin ping
----------------------------------------------------------------------------------------------------------------------------
                                                     Katello ステータス

状態   Service  結果   Duration Message 
      ^^^^^Unlocalized       ^^^^^Unlocalized
                                           
----------------------------------------------------------------------------------------------------------------------------
ok   
candlepin      ok   101ms    
candlepin_auth ok   62ms     
elasticsearch  ok   71ms     
katello_jobs   ok   63ms     

  
Actual results:
Unlocalized strings for ping module

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:44 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Hedda Peters 2012-12-13 01:19:50 EST
Pretty much the same outcome for de-DE.

Currently all languages are at least 95% translated on Zanata, and the remaining untranslated strings are not the unlocalized ones mentioned above. Some of the unlocalized strings mentioned above are translated on Zanata, others are not in our translation files on Zanata yet.
Comment 3 Noriko Mizumoto 2012-12-13 02:04:45 EST
Confirmed for ja-JP.
Also the following partially not localized, and the strings not provided on zanata.
Such as 'Duration Message'.

[root@i18nsamtest ~]# headpin -u admin -p admin ping
------------------------------------------------------------------------------------------------
                                       Katello ステータス

状態   Service        結果   Duration Message 
------------------------------------------------------------------------------------------------
OK   
candlepin      OK   19ms     
candlepin_auth OK   18ms     
elasticsearch  OK   21ms     
katello_jobs   OK   30ms
Comment 4 Lijun Li 2012-12-13 05:34:17 EST
*** Bug 886766 has been marked as a duplicate of this bug. ***
Comment 5 Lijun Li 2012-12-13 06:05:54 EST
*** Bug 886756 has been marked as a duplicate of this bug. ***
Comment 6 Eunju, Kim 2012-12-13 17:45:42 EST
confirmed for ko-KR.
Comment 7 Sam Friedmann 2012-12-13 20:20:40 EST
Confirmed for fr-FR.
Comment 8 Wei Liu 2012-12-13 20:22:38 EST
String "Service", "Duration Message", "Duration" and "no such option" are not found in Zanata.
Comment 9 Tom McKay 2012-12-18 09:11:55 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 11 Bryan Kearney 2013-06-07 14:19:26 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 12 Bryan Kearney 2013-06-07 14:27:47 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.