Bug 879462

Summary: [abrt]: WARNING: at drivers/usb/core/urb.c:311 usb_submit_urb+0x3cf/0x3e0() [uvcvideo]
Product: [Fedora] Fedora Reporter: marroy <olij.2406>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: alanidcv3, alexisbuckens, astronom57, cable_utp, evoke, gansalmon, gerhard.dekker, grivital, ilyes.gouta, itamar, j-23, jan.swaelens, jonathan, j.orti.alcaine, jpeeler, kernel-maint, laurent.pinchart, lfe.2.fe, lists.kho, madhu.chinakonda, princekfrancis, rderooy, smooge, ugrundler, williambader
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Unspecified   
Whiteboard: abrt_hash:c13e4276114c599b880deab4c9c2c70f3a73415c
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-16 21:06:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
usbmon output
none
Fix race of open and suspend in error case none

Description marroy 2012-11-22 23:55:06 EST
Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        BOOT_IMAGE=/vmlinuz-3.6.7-4.fc17.i686 root=/dev/mapper/vg_omarpc-lv_root ro rd.lvm.lv=vg_omarpc/lv_root rd.dm=0 rd.lvm.lv=vg_omarpc/lv_swap quiet SYSFONT=latarcyrheb-sun16 rhgb rd.md=0 rd.luks=0 KEYTABLE=la-latin1 LANG=en_US.UTF-8
kernel:         3.6.7-4.fc17.i686

backtrace:
:WARNING: at drivers/usb/core/urb.c:311 usb_submit_urb+0x3cf/0x3e0()
:Hardware name: HP Pavilion dv4 Notebook PC
:URB f18ce600 submitted while active
:Modules linked in: hidp fuse 8021q garp stp llc fcoe libfcoe libfc scsi_transport_fc scsi_tgt rfcomm bnep be2iscsi iscsi_boot_sysfs ip6t_REJECT bnx2i cnic uio cxgb4i cxgb4 nf_conntrack_ipv6 nf_defrag_ipv6 cxgb3i nf_conntrack_ipv4 nf_defrag_ipv4 xt_state ip6table_filter cxgb3 mdio libcxgbi ip6_tables nf_conntrack ib_iser rdma_cm ib_addr iw_cm ib_cm ib_sa ib_mad ib_core iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi snd_hda_codec_hdmi snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep uvcvideo snd_seq snd_seq_device videobuf2_vmalloc videobuf2_memops videobuf2_core videodev snd_pcm media ir_lirc_codec lirc_dev ir_mce_kbd_decoder arc4 ath9k ath9k_common snd_page_alloc ir_sanyo_decoder btusb ath9k_hw snd_timer bluetooth ir_sony_decoder ir_jvc_decoder snd ir_rc6_decoder kvm r8169 soundcore ath mac80211 sp5100_tco i2c_piix4 ir_rc5_decoder ir_nec_decoder rc_rc6_mce microcode k10temp mii cfg80211 hp_wmi ene_ir hp_accel sparse_keymap rfkill rc_core lis3lv02d input_
:polldev binfmt_misc uinput wmi video radeon i2c_algo_bit drm_kms_helper ttm drm i2c_core
:Pid: 1560, comm: knotify4 Not tainted 3.6.7-4.fc17.i686 #1
:Call Trace:
: [<c043c602>] warn_slowpath_common+0x72/0xa0
: [<c079fc2f>] ? usb_submit_urb+0x3cf/0x3e0
: [<c079fc2f>] ? usb_submit_urb+0x3cf/0x3e0
: [<f7f5a730>] ? uvc_ctrl_cleanup_device+0xf0/0xf0 [uvcvideo]
: [<c043c6d3>] warn_slowpath_fmt+0x33/0x40
: [<c079fc2f>] usb_submit_urb+0x3cf/0x3e0
: [<c053239f>] ? kmem_cache_alloc_trace+0x10f/0x130
: [<c073c8a7>] ? __pm_runtime_resume+0x57/0x70
: [<f7f549b9>] ? uvc_v4l2_open+0x69/0x120 [uvcvideo]
: [<f7f5abfc>] uvc_status_start+0x1c/0x30 [uvcvideo]
: [<f7f549dc>] uvc_v4l2_open+0x8c/0x120 [uvcvideo]
: [<f7ef3658>] v4l2_open+0x108/0x180 [videodev]
: [<c05474b0>] ? chrdev_open+0x60/0x140
: [<c05474d0>] chrdev_open+0x80/0x140
: [<c0541968>] do_dentry_open+0x1b8/0x230
: [<c0547450>] ? cdev_put+0x20/0x20
: [<c0541a12>] finish_open+0x32/0x50
: [<c0550b73>] do_last+0x613/0xbd0
: [<c054de4a>] ? link_path_walk+0x5a/0x750
: [<c05511cd>] path_openat+0x9d/0x3b0
: [<c0673db1>] ? copy_to_user+0x41/0x60
: [<c05516c1>] do_filp_open+0x31/0x80
: [<c055c03c>] ? alloc_fd+0x3c/0xe0
: [<c054cbb0>] ? getname_flags+0x40/0xd0
: [<c0542ac5>] do_sys_open+0xe5/0x1c0
: [<c0542bd2>] sys_open+0x32/0x40
: [<c095bbdf>] sysenter_do_call+0x12/0x28
Comment 1 Jeff Peeler 2012-11-26 09:39:20 EST
Plugged in USB cord for 046d:081d, Logitech Webcam C310.

Package: kernel
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Jan Swaelens 2012-12-04 01:08:18 EST
I was just working, reading some emails and browsing when this happended. Nothing out of the ordenary really.

Package: kernel
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 3 William Bader 2012-12-05 02:37:35 EST
I got this moving a mouse with a browser open.
kernel: 3.6.8-2.fc17.x86_64
$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 05ca:18c0 Ricoh Co., Ltd 
Bus 002 Device 003: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Comment 4 Josh Boyer 2013-01-07 15:36:08 EST
Adding Laurent on CC.
Comment 5 Josh Boyer 2013-01-08 11:05:59 EST
If you have a way to recreate this somewhat reliably, can you please try and collect the output of a usbmon trace during the problem time and attach it here?
Comment 6 Jeff Peeler 2013-01-08 17:05:09 EST
Created attachment 675111 [details]
usbmon output

I seem to be able to reproduce this at will, so let me know if anything else would be helpful.
Comment 7 Laurent Pinchart 2013-01-10 05:48:55 EST
Created attachment 676238 [details]
Fix race of open and suspend in error case

(In reply to comment #6)
> Created attachment 675111 [details]
> usbmon output
> 
> I seem to be able to reproduce this at will, so let me know if anything else
> would be helpful.

Jeff, could you please test this patch and see if it fixes your problem ?
Comment 8 Josh Boyer 2013-01-10 09:30:18 EST
(In reply to comment #7)
> Created attachment 676238 [details]
> Fix race of open and suspend in error case
> 
> (In reply to comment #6)
> > Created attachment 675111 [details]
> > usbmon output
> > 
> > I seem to be able to reproduce this at will, so let me know if anything else
> > would be helpful.
> 
> Jeff, could you please test this patch and see if it fixes your problem ?

http://koji.fedoraproject.org/koji/taskinfo?taskID=4855169

is a scratch build that contains that patch backported to the F17 kernel.  Please give it a shot when it finishes building and let us know the results.
Comment 9 Josh Boyer 2013-01-10 15:25:20 EST
*** Bug 894139 has been marked as a duplicate of this bug. ***
Comment 10 William Bader 2013-01-11 08:21:29 EST
I got this again for the first time in a few weeks.  I had chrome open and had just opened gmail.  I have an unpatched F17 kernel 3.6.11-1.fc17.x86_64 . I can't reproduce it, so I probably couldn't prove anything by testing the patched kernel, but I can confirm that it still happens with the current version of the unpatched kernel.
Comment 11 Jeff Peeler 2013-01-15 12:42:16 EST
Sorry for the delay, but I've now tested the scratch build. I can't reproduce the issue any longer.
Comment 12 Laurent Pinchart 2013-01-21 06:11:17 EST
(In reply to comment #11)
> Sorry for the delay, but I've now tested the scratch build. I can't
> reproduce the issue any longer.

Thank you.

I've sent a pull request through the Linux media tree for v3.9.
Comment 13 William Bader 2013-01-29 08:40:53 EST
Moved the mouse with chrome open.

Package: kernel
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 William Bader 2013-01-29 08:43:38 EST
I thought that it was fixed, but it just happened on an unpatched 3.7.3-101.fc17.x86_64.
Comment 15 William Bader 2013-02-23 01:43:13 EST
I opened gmail with chrome.

Package: kernel
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 16 Prince Francis 2013-02-25 23:28:05 EST
I just started the system, then it happened.

Package: kernel
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 Martin Kho 2013-03-04 08:24:07 EST
Hi,

Get this warning with kernel 3.7.9-104.fc17.x86_64 everytime the system starts.  (abrt catches it). Previous kernel - 3.7.9-101.fc17.x86_64 - runs without error.

Martin Kho
Comment 18 Mikhail 2013-03-11 05:17:25 EDT
Error message appeared right after reboot. 

Package: kernel
Architecture: x86_64
OS Release: Fedora release 17 (Beefy Miracle)
Comment 19 Josh Boyer 2013-03-11 16:29:15 EDT
Sigh.  I've added the patch to the F17/F18 kernels now.  My apologies for taking so long.
Comment 20 Fedora Update System 2013-03-14 18:52:54 EDT
kernel-3.8.3-101.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.8.3-101.fc17
Comment 21 Fedora Update System 2013-03-14 22:56:58 EDT
kernel-3.8.3-201.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.8.3-201.fc18
Comment 22 Martin Kho 2013-03-15 11:55:13 EDT
Hi Josh,

I updated to kernel-3.8.3-101.fc17, but stille get this warning. Or is mine another issue?

Martin Kho


[   63.013953] WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3b4/0x3d0()
[   63.013956] Hardware name: System Product Name
[   63.013958] URB ffff8801354ceb40 submitted while active
[   63.013959] Modules linked in: bnep bluetooth rfkill ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 nf_defrag_ipv4 ip6_tables xt_state nf_conntrack snd_hda_codec_via snd_hda_intel snd_hda_codec snd_usb_audio snd_usbmidi_lib coretemp snd_hwdep kvm_intel snd_rawmidi snd_seq snd_seq_device kvm snd_pcm ppdev iTCO_wdt uvcvideo iTCO_vendor_support videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media microcode snd_page_alloc usblp snd_timer parport_pc lpc_ich parport snd mfd_core i2c_i801 asus_atk0110 soundcore r8169 mii uinput nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core
[   63.014042] Pid: 861, comm: knotify4 Not tainted 3.8.3-101.fc17.x86_64 #1
[   63.014045] Call Trace:
[   63.014053]  [<ffffffff8105e63f>] warn_slowpath_common+0x7f/0xc0
[   63.014057]  [<ffffffff8105e736>] warn_slowpath_fmt+0x46/0x50
[   63.014062]  [<ffffffff81184e8f>] ? kmem_cache_alloc_trace+0x1cf/0x220
[   63.014066]  [<ffffffff81463c34>] usb_submit_urb+0x3b4/0x3d0
[   63.014076]  [<ffffffffa026e121>] uvc_status_start+0x21/0x30 [uvcvideo]
[   63.014081]  [<ffffffffa0266fe2>] uvc_v4l2_open+0xb2/0x160 [uvcvideo]
[   63.014089]  [<ffffffffa0230535>] v4l2_open+0xd5/0x130 [videodev]
[   63.014095]  [<ffffffff811a192b>] chrdev_open+0x9b/0x180
[   63.014098]  [<ffffffff8119b573>] do_dentry_open+0x203/0x290
[   63.014102]  [<ffffffff811a1890>] ? cdev_put+0x30/0x30
[   63.014105]  [<ffffffff8119b635>] finish_open+0x35/0x50
[   63.014109]  [<ffffffff811aba4e>] do_last+0x6de/0xe00
[   63.014113]  [<ffffffff811a8578>] ? inode_permission+0x18/0x50
[   63.014116]  [<ffffffff811a8627>] ? link_path_walk+0x77/0x870
[   63.014122]  [<ffffffff8129e6ba>] ? selinux_file_alloc_security+0x4a/0x80
[   63.014125]  [<ffffffff811ac22c>] path_openat+0xbc/0x4d0
[   63.014129]  [<ffffffff8129dcd5>] ? selinux_inode_getattr+0x45/0x50
[   63.014133]  [<ffffffff811ac901>] do_filp_open+0x41/0xa0
[   63.014137]  [<ffffffff811b9012>] ? __alloc_fd+0x42/0x110
[   63.014141]  [<ffffffff8119c944>] do_sys_open+0xf4/0x1e0
[   63.014144]  [<ffffffff8119ca51>] sys_open+0x21/0x30
[   63.014149]  [<ffffffff81654cd9>] system_call_fastpath+0x16/0x1b
[   63.014151] ---[ end trace 7e48f4e2fdbe473c ]---
Comment 23 Fedora Update System 2013-03-15 21:20:06 EDT
Package kernel-3.8.3-201.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.8.3-201.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3893/kernel-3.8.3-201.fc18
then log in and leave karma (feedback).
Comment 24 Martin Kho 2013-03-16 08:26:56 EDT
Hi,

Hum ... It seems my hardware is bad. Moved the webcam to another port and the warning is gone. It's sitting now near my mouse (both devices are usb 2.0) instead of near my usb 1.1 printer. Some sort of interference?

Sorry for the noise :-(

Martin Kho
Comment 25 Fedora Update System 2013-03-16 21:06:23 EDT
kernel-3.8.3-201.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2013-03-21 20:11:39 EDT
kernel-3.8.3-103.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Jan Swaelens 2013-03-26 07:06:09 EDT
Just had it again on 3.8.4-202.fc18 - it was a while ago though.
Comment 28 Martin Kho 2013-03-26 07:47:17 EDT
Hi,
 
Yeah, I see it happening everytime when I switch back from Fedora 19 to Fedora 17.

Fedora 19: kernel-3.9.0-0.rc4.git0.2.fc20 (use no-debug repo)

Fedora 17: kernel-3.8.3-103.fc17.x86_64

After rebooting a second time Fedora 17 is happy again.

Very weird :-(

Martin Kho
Comment 29 Martin Kho 2013-03-27 16:41:35 EDT
Hi,

I've looked at code from some older kernels ( e.g. [1] ) and saw that the 'wrong' code that triggers the current issue was already there. Why did the warning just showed up after the update to kernel 3.7.9-104.fc17.x86_64 and later kernels and not in earlier kernels?

Hope that someone can shed some light on this.

Martin Kho

[1] https://git.kernel.org/cgit/linux/kernel/git/stable/linux-stable.git/tree/drivers/media/video/uvc/uvc_v4l2.c?id=refs/tags/v3.0.70 ( go to line 507 )
Comment 30 William Bader 2013-06-12 11:40:15 EDT
I just got this crash again.
The bug is not fixed.
Can you reopen this bug report?
"uname -a" shows
Linux laptop 3.8.13-100.fc17.x86_64 #1 SMP Mon May 13 13:36:17 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
The retrace server https://retrace.fedoraproject.org/faf/reports/26184/ shows 5 reports with 0:3.8.11-100.fc17 and 11 reports with 0:3.8.13-100.fc17 so I am not the only one who still has this problem on a recent kernel.
William