Bug 880029

Summary: Portal Login button label is not localized
Product: Red Hat Enterprise Virtualization Manager Reporter: Yuko Katabami <ykatabam>
Component: ovirt-engine-webadmin-portalAssignee: Daniel Erez <derez>
Status: CLOSED CURRENTRELEASE QA Contact: Pavel Stehlik <pstehlik>
Severity: unspecified Docs Contact:
Priority: high    
Version: 3.1.0CC: acathrow, dyasny, ecohen, eng-i18n-bugs, iheim, italkohe, lijli, Rhev-m-bugs, ykaul
Target Milestone: ---Keywords: i18n, Translation, ZStream
Target Release: 3.2.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: ux
Fixed In Version: sf1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 883915 (view as bug list) Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 915537    
Attachments:
Description Flags
unlocalized "Login" button on login window (Admin Portal)
none
unlocalized "Login" button on login window (User Portal)
none
Login button localized in sf1 build none

Description Yuko Katabami 2012-11-25 22:34:03 EST
Description of problem:
Sorry for late reporting.
We just found that portal Login button label is not localized.

Version-Release number of selected component (if applicable): 3.1


How reproducible:always


Steps to Reproduce:
1. Open login screen of Web Admin Portal and User Portal
2. Select any language other than English
3. Label of "Login" button remains unlocalized
  
Actual results:
Unlocalized

Expected results:
Should be localized to each language

Additional info:
In Zanata, there are two stings of "Login" with resource ID "loginButtonLabel" and one with "storageIscsiPopupLoginButtonLabel". They are all translated.
Comment 1 Einav Cohen 2012-11-26 07:39:05 EST
Hi Yuko, 

see, for example, attachment 628884 [details]
[was taken by me as part of opening Bug 867428]
you can see there that the "Login" button text is localized, at least in the admin portal.

Is there a chance that you are referring only to the user portal login page (https://[server]/UserPortal) 
and not to the admin portal login page (https://[server]/webadmin)?
Comment 2 Yuko Katabami 2012-11-26 07:47:06 EST
Created attachment 651939 [details]
unlocalized "Login" button on login window (Admin Portal)
Comment 3 Yuko Katabami 2012-11-26 07:47:55 EST
Created attachment 651940 [details]
unlocalized "Login" button on login window (User Portal)
Comment 11 Lijun Li 2012-12-25 04:31:44 EST
Verified. It's fixed on RHEVM3.2 sf1 build.
[root@dhcp-8-215 ~]# rpm -q rhevm
rhevm-3.2.0-1.el6ev.noarch
Please see the attached screenshot.

Thanks,
Robert
Comment 12 Lijun Li 2012-12-25 04:35:50 EST
Created attachment 668813 [details]
Login button localized in sf1 build
Comment 13 Itamar Heim 2013-06-11 05:52:13 EDT
3.2 has been released
Comment 14 Itamar Heim 2013-06-11 05:52:29 EDT
3.2 has been released
Comment 15 Itamar Heim 2013-06-11 05:59:03 EDT
3.2 has been released