This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 880089

Summary: [ALL_LANG][SAM CLI] Unlocalized strings for provider module
Product: Subscription Asset Manager Reporter: Lijun Li <lijli>
Component: katelloAssignee: Adam Price <adprice>
Status: CLOSED NEXTRELEASE QA Contact: SAM QE List <sam-qe-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.3CC: adprice, agarcia, eng-l10n-bugs, eukim, hpeters, noriko, qe-i18n-bugs, sfriedma, tomckay
Target Milestone: rcKeywords: Translation, Triaged
Target Release: 2.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-06-07 14:28:55 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 833466    

Description Lijun Li 2012-11-26 03:24:11 EST
Description of problem:
Unlocalized strings for provider module

Version-Release number of selected component (if applicable):
Subscription Asset Manager Version: 1.2.5-1h.el6_3

How reproducible:
100%

Steps to Reproduce:
# headpin provider -h
Usage:  headpin <options> provider <command>
Supported Commands:
	delete_manifest delete an imported manifest
        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin provider import_manifest --name='Red Hat' --file= --org=test
File  does not exist
^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin provider import_manifest --name='Red Hat' --file=/root/manifest.zip --org=test
マニフェストをインポートしManifest imported 
^(above strings should be removed)^^^^Unlocalized  

# headpin -u admin -p admin provider import_manifest --name='Red Hat' --file=/root/manifest.zip --org=test
マニフェストをインポートしています、 お待ちください...Import is the same as existing data
                                            ^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin provider info --name="Red Hat" --org=
Couldn't find organization 'providers'
^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin provider info --name="Red Hat" --org=test -g
----------------------------------------------------------------------------------
                                 プロバイダー情報

Id Name    Type    Url                    Org Id Description 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
----------------------------------------------------------------------------------
21 Red Hat Red Hat https://cdn.redhat.com 21     None        


# headpin -u admin -p admin provider list --org=test
----------------------------------------------------------------------------------
                                プロバイダーの一覧

Id Name    Type    Url                    Description 
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized
----------------------------------------------------------------------------------
21 Red Hat Red Hat https://cdn.redhat.com None        

# headpin -u admin -p admin provider delete_manifest --name='Red Hat' --org=test
Manifest deleted                     
^^^^^^^^^^^^Unlocalized

# headpin -u admin -p admin provider delete_manifest --name='Red Hat' --org=test
Deleting manifest, please wait... No import found for owner test
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^Unlocalized

 
Actual results:
Unlocalized strings for provider module.

Expected results:
All the strings should be localized.

Additional info:
Comment 1 Adam Price 2012-12-11 14:44:55 EST
Most column names are not localized. I will add them to localization, but it depends on if the translators get to them in time.

Most error messages that were coming from the server were being sent as English, so the CLI has no control over that. We are actively working on getting the error messages and validation error messages translated.
Comment 2 Noriko Mizumoto 2012-12-13 20:14:29 EST
confirmed for ja_JP
Comment 3 Lijun Li 2012-12-13 22:40:32 EST
*** Bug 887082 has been marked as a duplicate of this bug. ***
Comment 4 Lijun Li 2012-12-13 22:41:28 EST
*** Bug 887084 has been marked as a duplicate of this bug. ***
Comment 5 Lijun Li 2012-12-13 22:42:18 EST
*** Bug 887089 has been marked as a duplicate of this bug. ***
Comment 6 Eunju, Kim 2012-12-13 23:43:29 EST
confirmed for ko_KR
Comment 7 Sam Friedmann 2012-12-13 23:54:25 EST
Confirmed for fr-FR.
Comment 8 Hedda Peters 2012-12-13 23:56:16 EST
Similar result for de-DE, some of the above mentioned strings are localized though.
Comment 9 Tom McKay 2012-12-18 09:12:19 EST
Mass moving i18n BZs to CFSE where they are also present
Comment 11 Bryan Kearney 2013-06-07 14:20:27 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 12 Bryan Kearney 2013-06-07 14:28:55 EDT
We will be doing a new round of translations for the 1.3 drop. Closing out these bugs so that the beta starts with a clean slate.