Bug 887089 - Test case failure: SAM CLI: provider
Test case failure: SAM CLI: provider
Status: CLOSED DUPLICATE of bug 880089
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-13 21:25 EST by Angela Garcia
Modified: 2012-12-13 22:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Not all messages are localized Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 22:42:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Angela Garcia 2012-12-13 21:25:22 EST
Not all messages are localized 

Filed from caserun (INSERT URL HERE)

Version-Release number of selected component (if applicable):
SAM-20121130.n.0

Steps to Reproduce: 

# headpin provider -h

  * import_manifest

# headpin provider import_manifest -h

# headpin -u admin -p admin provider import_manifest --name= --file=
File  does not exist

# headpin -u admin -p admin provider import_manifest --name=test --file=/home/
testqa/Downloads/manifest.zip (the path to the manifest file)
Could not find provider [ test ] within organization [ Starbucks ]

# headpin -u admin -p admin provider import_manifest --name="Red Hat" --file=/
home/testqa/Downloads/manifest.zip
Importing manifest, please wait... This distributor has already been imported
by another owner

# headpin -u admin -p admin provider import_manifest --name="Red Hat" --file=/
home/testqa/Downloads/manifest.zip --org=ACME_Corporation
Importing manifest, please wait... Import is older then existing data, please
try with --force option to import manifest.

# headpin -u admin -p admin provider import_manifest --name="Red Hat" --file=/
home/testqa/Downloads/manifest.zip --org=ACME_Corporation --force
Manifest imported                    

# headpin -u admin -p admin provider import_manifest --name="Red Hat" --file=/
home/testqa/Downloads/manifest.zip --org=test
Manifest imported                    

  * Info

# headpin provider info -h

# headpin -u admin -p admin provider info --name="Red Hat"

# headpin -u admin -p admin provider info --name="Red Hat" --org=
Couldn't find organization 'providers'

headpin -u admin -p admin provider info --name="Red Hat" --org=??
Couldn't find organization '??'

# headpin -u admin -p admin provider info --name="Red Hat" --org=test

# headpin -u admin -p admin provider info --name="Red Hat" --org=test -g

# headpin -u admin -p admin provider info --name="Red Hat" --org=test -v

# headpin -u admin -p admin provider info --name="Red Hat" --org=test
--noheading

# headpin -u admin -p admin provider info --name="Red Hat" --org=test -g -v -d
DELIMITER --noheading

  * List

# headpin provider list -h

# headpin -u admin -p admin provider list

# headpin -u admin -p admin provider list --org=test

# headpin -u admin -p admin provider list --org=test -g

# headpin -u admin -p admin provider list --org=test -v

# headpin -u admin -p admin provider list --org=test --noheading

# headpin -u admin -p admin provider list --org=test -g -v -d DELIMITER
--noheading

  * delete_manifest

# headpin provider delete_manifest -h

# headpin -u admin -p admin provider delete_manifest --name='Red Hat' --org=
ACME_Corporation
Manifest deleted                    




Actual results: 
#FIXME

Expected results:
Messages are localized.
Comment 1 Lijun Li 2012-12-13 22:42:18 EST

*** This bug has been marked as a duplicate of bug 880089 ***

Note You need to log in before you can comment on or make changes to this bug.