Bug 880373

Summary: Fedora 16 -> 17 Ugradee via DVD failes when encountering an unmountable CIFS fielsystem inf fstab
Product: [Fedora] Fedora Reporter: Bill Klingler <wklingler>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 17CC: anaconda-maint-list, dennis, g.kaviyarasu, jonathan, Juno.Krahn, mkolman, sbueno, vanmeeuwen+fedora, wklingler
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-03-16 01:08:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bill Klingler 2012-11-26 20:29:58 UTC
Description of problem:
Fedora Upgrade via DVD from 16 to 17 fails.  After some analysis, I found that my system had a CIFS file system in its fstab that was not mountable at the time of the upgrade. 

When I commented out the CIFS filesystem(s) from the fstab and rerun the upgrade it worked fine.


Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1- Add a CIFS file system in the /etc/fstab that is not mountable:
e.g.:
//192.168.8.33/v-drive  /v      cifs    username=vpi-us/linux,password=something   1 1

2 - When you run the upgrade it will hang/fail.
  
Actual results:
Failed Upgrade

Expected results:
Successful Upgrade

Additional info:

This may be related to Bug 826738

Comment 1 Juno Krahn 2013-03-08 17:42:32 UTC
This also happens when an ISO file is specified as the device, mounted with the "loop" option. Also, I was unable to submit the bug with the built-in bug reporting system, because the reporter triggers a new exception, apparently while gathering information about the system state.

Comment 2 Brian Lane 2013-03-16 01:08:34 UTC
We now ignore unknown fstab entries.