Bug 880423

Summary: rubberband 1.8.1 is FTBFS on ARM
Product: [Fedora] Fedora Reporter: Peter Robinson <pbrobinson>
Component: rubberbandAssignee: Michel Alexandre Salim <michel>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: michel
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-18 06:30:03 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 245418    

Description Peter Robinson 2012-11-26 19:07:35 EST
Looks like it is an issue with assembler

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1267286

src/dsp/FFT.cpp: In destructor 'virtual RubberBand::FFTs::D_FFTW::~D_FFTW()':
src/dsp/FFT.cpp:1571:18: warning: variable 'save' set but not used [-Wunused-but-set-variable]
g++ -DHAVE_LIBSAMPLERATE -DHAVE_FFTW3 -DFFTW_DOUBLE_ONLY -DNO_THREAD_CHECKS -DUSE_PTHREADS -DNO_TIMING -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -march=armv5te -mfloat-abi=soft -fPIC -Wall         -Irubberband -I. -Isrc    -c -o src/system/Allocators.o src/system/Allocators.cpp
g++ -DHAVE_LIBSAMPLERATE -DHAVE_FFTW3 -DFFTW_DOUBLE_ONLY -DNO_THREAD_CHECKS -DUSE_PTHREADS -DNO_TIMING -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -march=armv5te -mfloat-abi=soft -fPIC -Wall         -Irubberband -I. -Isrc    -c -o src/system/sysutils.o src/system/sysutils.cpp
{standard input}: Assembler messages:
{standard input}:225: Error: selected processor does not support ARM mode `fmrx r3,fpscr'
{standard input}:228: Error: selected processor does not support ARM mode `fmxr fpscr,r3'
make: *** [src/system/sysutils.o] Error 1
Comment 1 Peter Robinson 2013-02-18 06:30:03 EST
The issue appears to be on armv5 only, we've dropped that for F19 so marking this fixed rawhide.