This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 880423 - rubberband 1.8.1 is FTBFS on ARM
rubberband 1.8.1 is FTBFS on ARM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rubberband (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-11-26 19:07 EST by Peter Robinson
Modified: 2013-02-18 06:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-18 06:30:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-11-26 19:07:35 EST
Looks like it is an issue with assembler

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=1267286

src/dsp/FFT.cpp: In destructor 'virtual RubberBand::FFTs::D_FFTW::~D_FFTW()':
src/dsp/FFT.cpp:1571:18: warning: variable 'save' set but not used [-Wunused-but-set-variable]
g++ -DHAVE_LIBSAMPLERATE -DHAVE_FFTW3 -DFFTW_DOUBLE_ONLY -DNO_THREAD_CHECKS -DUSE_PTHREADS -DNO_TIMING -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -march=armv5te -mfloat-abi=soft -fPIC -Wall         -Irubberband -I. -Isrc    -c -o src/system/Allocators.o src/system/Allocators.cpp
g++ -DHAVE_LIBSAMPLERATE -DHAVE_FFTW3 -DFFTW_DOUBLE_ONLY -DNO_THREAD_CHECKS -DUSE_PTHREADS -DNO_TIMING -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4  -march=armv5te -mfloat-abi=soft -fPIC -Wall         -Irubberband -I. -Isrc    -c -o src/system/sysutils.o src/system/sysutils.cpp
{standard input}: Assembler messages:
{standard input}:225: Error: selected processor does not support ARM mode `fmrx r3,fpscr'
{standard input}:228: Error: selected processor does not support ARM mode `fmxr fpscr,r3'
make: *** [src/system/sysutils.o] Error 1
Comment 1 Peter Robinson 2013-02-18 06:30:03 EST
The issue appears to be on armv5 only, we've dropped that for F19 so marking this fixed rawhide.

Note You need to log in before you can comment on or make changes to this bug.