Bug 881955

Summary: Always write '1' for resource agent booleans
Product: Red Hat Enterprise Linux 6 Reporter: Ryan McCabe <rmccabe>
Component: luciAssignee: Ryan McCabe <rmccabe>
Status: CLOSED ERRATA QA Contact: Cluster QE <mspqa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.3CC: cluster-maint, rsteiger
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: luci-0.26.0-29.el6 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-21 08:23:01 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 822502    

Description Ryan McCabe 2012-11-29 21:02:26 UTC
The resource agents are inconsistent in what values they accept for true/false for boolean inputs. They accept some combination "1"/"on"/"yes"/"true" (and their inverses). All accept 1/0, however, so always use those values.

This is fixed in upstream commit

commit dbf80eeb659641c0f254456ef7ac830038e5f589
Author: Ryan McCabe <rmccabe@redhat.com>
Date:   Thu Nov 29 15:33:24 2012 -0500

    luci: Audit of resource agent checkbox input
    
    Always write '1' instead of 'on' for enabled checkboxes. The resource
    agents are inconsistent in what values they accept for true and false
    inputs. All accept 1/0, though, so be consistent in using that.
    
    Signed-off-by: Ryan McCabe <rmccabe@redhat.com>

Comment 7 errata-xmlrpc 2013-02-21 08:23:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0309.html