Bug 885378

Summary: Install to existing encrypted LV fails (AttributeError: 'NoneType' object has no attribute 'name')
Product: [Fedora] Fedora Reporter: Ian Pilcher <ipilcher>
Component: anacondaAssignee: Anaconda Maintenance Team <anaconda-maint-list>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: anaconda-maint-list, awilliam, g.kaviyarasu, jonathan, jsmith.fedora, kparal, kwizart, robatino, sbueno, vanmeeuwen+fedora
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:8c340e865e53203cf0adc0534becf585bb8ba08900e8139b0f40c6f158c00f44 AcceptedBlocker
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-20 00:34:42 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 752661    
Attachments:
Description Flags
File: anaconda-tb
none
File: product
none
File: type
none
File: storage.log
none
File: version
none
File: environ
none
File: executable
none
File: anaconda.log
none
File: syslog
none
File: hashmarkername
none
File: packaging.log
none
File: cmdline_file
none
File: release
none
File: program.log none

Description Ian Pilcher 2012-12-08 18:18:58 EST
Description of problem:
Use existing LUKS-encrypted LV as F18 root filesystem

Version-Release number of selected component:
anaconda-18.37

Additional info:
libreport version: 2.0.18
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.9-4.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.37 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1042, in _save_right_side
:    if self._device_container_name != old_container.name:
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2435, in on_apply_clicked
:    self._save_right_side(self._current_selector)
:AttributeError: 'NoneType' object has no attribute 'name'
Comment 1 Ian Pilcher 2012-12-08 18:19:01 EST
Created attachment 660127 [details]
File: anaconda-tb
Comment 2 Ian Pilcher 2012-12-08 18:19:03 EST
Created attachment 660128 [details]
File: product
Comment 3 Ian Pilcher 2012-12-08 18:19:04 EST
Created attachment 660129 [details]
File: type
Comment 4 Ian Pilcher 2012-12-08 18:19:06 EST
Created attachment 660130 [details]
File: storage.log
Comment 5 Ian Pilcher 2012-12-08 18:19:07 EST
Created attachment 660131 [details]
File: version
Comment 6 Ian Pilcher 2012-12-08 18:19:09 EST
Created attachment 660132 [details]
File: environ
Comment 7 Ian Pilcher 2012-12-08 18:19:10 EST
Created attachment 660133 [details]
File: executable
Comment 8 Ian Pilcher 2012-12-08 18:19:12 EST
Created attachment 660134 [details]
File: anaconda.log
Comment 9 Ian Pilcher 2012-12-08 18:19:13 EST
Created attachment 660135 [details]
File: syslog
Comment 10 Ian Pilcher 2012-12-08 18:19:15 EST
Created attachment 660136 [details]
File: hashmarkername
Comment 11 Ian Pilcher 2012-12-08 18:19:16 EST
Created attachment 660137 [details]
File: packaging.log
Comment 12 Ian Pilcher 2012-12-08 18:19:18 EST
Created attachment 660138 [details]
File: cmdline_file
Comment 13 Ian Pilcher 2012-12-08 18:19:19 EST
Created attachment 660139 [details]
File: release
Comment 14 Ian Pilcher 2012-12-08 18:19:21 EST
Created attachment 660140 [details]
File: program.log
Comment 15 Jared Smith 2012-12-08 22:24:21 EST
I'll let the Anaconda devs look at this more closely, but right off the top of my head I'd say it looks similar to 882722.
Comment 16 Ian Pilcher 2012-12-08 22:41:05 EST
(In reply to comment #15)
> I'll let the Anaconda devs look at this more closely, but right off the top
> of my head I'd say it looks similar to 882722.

This was "smoke 5" (anaconda 18.36), which should have the fix for that bug. Also, I only see it when trying to create or reuse an *encrypted* LV.
Comment 17 Kamil Páral 2012-12-10 05:26:48 EST
Proposing as blocker:
 The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above 
https://fedoraproject.org/wiki/Fedora_18_Final_Release_Criteria

Ian, can you put more detail in how to reproduce this? What is the simplest approach to hit this?
Comment 18 Ian Pilcher 2012-12-10 09:14:32 EST
(In reply to comment #17)
> Ian, can you put more detail in how to reproduce this? What is the simplest
> approach to hit this?

1.  Create KVM guest with 8GB virtual disk.
2.  Boot guest from Fedora 18 "smoke 5" install DVD (x86_64).
3.  When anaconda reaches "Welcome to Fedora 18" screen, switch to VT2 and create partitions.
4.  Use fdisk to create partitions -- vda1 (500MB, type 83), vda2 (remainder of disk, type 8e).
5.  cat /proc/partitions to verify that new partitions have been recognized by kernel.
6.  mkfs.ext4 -L /boot /dev/vda1
7.  pvcreate /dev/vda2
8.  vgcreate vg_f18_luks /dev/vda2
9.  lvcreate -L 1G -n lv_swap vg_f18_luks
10. mkswap /dev/vg_f18_luks/lv_swap
11. lvcreate -L 6G -n lv_root vg_f18_luks
12. cryptsetup luksFormat /dev/vg_f18_luks/lv_root
13. cryptsetup luksOpen /dev/vg_f18_luks/lv_root root
14. mkfs.ext4 -L / /dev/mapper/root
15. cryptsetup remove root
16. Reboot to restart the installation
17. At "Welcome to Fedora 18" screen, click on "Continue".
18. Click on "I accept my fate"
19. Click on "Installation destination"
20. On the "Installation Destination" screen, ensure that the the virtio disk is selected and click on "Full disk summary and options..."
21. Select the virtio disk, click on "Do not install bootloader", and click on "Close"  (I'm not sure if steps 20-21 are required, but it's what I was doing when I saw the issue.)
22. Click on "Continue"
23. On the "Installation Options" popup, select "I don't need help; let me customize disk partitioning" and click on "Reclaim space"
24. Click on the plus symbol next to "Unknown" and select "vg_f18_luks-lv_root"
25. Enter the LUKS passphrase in the right-hand pane and click on "Unlock"
26. Enter a / in the "Mount Point:" field and click on the plus symbol next to "Customize..."
27. Select the "Reformat" check-box next to the file system type and click on "Apply Changes"
Comment 19 Ian Pilcher 2012-12-10 09:21:44 EST
(In reply to comment #18)
> 20. On the "Installation Destination" screen, ensure that the the virtio
> disk is selected and click on "Full disk summary and options..."
> 21. Select the virtio disk, click on "Do not install bootloader", and click
> on "Close"  (I'm not sure if steps 20-21 are required, but it's what I was
> doing when I saw the issue.)

Just tested without these steps, and still hit the traceback.
Comment 20 Adam Williamson 2012-12-10 12:29:43 EST
Discussed at 2012-12-10 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-10/f18final-blocker-review-3.2012-12-10-17.13.log.txt . Accepted as a blocker per criterion "The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above".
Comment 21 Fedora Update System 2012-12-18 20:34:00 EST
anaconda-18.37.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.37.4-1.fc18
Comment 22 Kamil Páral 2012-12-19 11:56:08 EST
Ian, could you please try again with anaconda-18.37.4-1.fc18? It's included here:
http://dl.fedoraproject.org/pub/alt/qa/20121218_f18-smoke8/

Thank you very much.
Comment 23 Fedora Update System 2012-12-19 17:40:36 EST
Package anaconda-18.37.4-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.37.4-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20677/anaconda-18.37.4-1.fc18
then log in and leave karma (feedback).
Comment 24 Ian Pilcher 2012-12-19 19:48:06 EST
(In reply to comment #22)
> Ian, could you please try again with anaconda-18.37.4-1.fc18? It's included
> here:
> http://dl.fedoraproject.org/pub/alt/qa/20121218_f18-smoke8/

Looks good.  I'm now able to install to an existing encrypted LV or create a new encrypted LV.
Comment 25 Adam Williamson 2012-12-19 20:04:08 EST
Thanks, setting VERIFIED.
Comment 26 Fedora Update System 2012-12-20 00:34:46 EST
anaconda-18.37.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Chris Lumens 2013-01-07 12:30:49 EST
*** Bug 889610 has been marked as a duplicate of this bug. ***