Bug 889610 - AttributeError: 'NoneType' object has no attribute 'name'
AttributeError: 'NoneType' object has no attribute 'name'
Status: CLOSED DUPLICATE of bug 885378
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:80d681a6324812ea6cf5ad09719...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-21 16:03 EST by Nicolas Chauvet (kwizart)
Modified: 2013-01-07 12:30 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 12:30:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (667.16 KB, text/plain)
2012-12-21 16:03 EST, Nicolas Chauvet (kwizart)
no flags Details

  None (edit)
Description Nicolas Chauvet (kwizart) 2012-12-21 16:03:38 EST
Description of problem:
Reworked the partition layout using existing luks with LVM
The following was filed automatically by anaconda:
anaconda 18.37.3 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1042, in _save_right_side
    if self._device_container_name != old_container.name:
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2171, in on_page_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 119, in _onExpanded
    cb(obj.get_child())
AttributeError: 'NoneType' object has no attribute 'name'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2018-TC3\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.6.10-4.fc18.x86_64
other involved packages: 
package:        anaconda-18.37.3
product:        Fedora
release:        Cannot get release name.
type:           libreport
version:        18-TC3
Comment 1 Nicolas Chauvet (kwizart) 2012-12-21 16:03:48 EST
Created attachment 667434 [details]
File: anaconda-tb
Comment 2 Chris Lumens 2013-01-07 11:38:58 EST
Can you please retest with a more recent tree and let us know if you continue to see this problem?  Thanks.
Comment 3 Nicolas Chauvet (kwizart) 2013-01-07 12:22:39 EST
Actually I've successfully installed my workstation with 18-TC4.
That been said, I'm not sure if I have experienced exactly the same code path.
Comment 4 Chris Lumens 2013-01-07 12:30:49 EST
Looks like we already fixed this one.

*** This bug has been marked as a duplicate of bug 885378 ***

Note You need to log in before you can comment on or make changes to this bug.