Bug 887345

Summary: large delay in Qt/KDE apps when trying to print
Product: [Fedora] Fedora Reporter: Rex Dieter <rdieter>
Component: qtAssignee: Than Ngo <than>
Status: CLOSED NOTABUG QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: itamar, jreznik, kevin, ltinkl, rdieter, rnovacek, smparrish, than
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-12-14 21:04:00 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 846845    

Description Rex Dieter 2012-12-14 17:38:33 UTC
Just noticed today while doing some testing for kde-print-manager, that whenever I attempt to print from any Qt/KDE application, like
arora
konqueror
okular

there's a large delay of some minutes after clicking "print" for anything visible to happen.


This may or may not be related to my testing adding
ServerName=...
to /etc/cups/client.conf
and/or having a 'cups' and a local cups server available or not.  (i've tried every combination I can think of so far, to no avail or help)

Comment 1 Rex Dieter 2012-12-14 18:37:32 UTC
Confirmed this seems to be f18 specific, my few f17 boxes tested (with relatively close versions of both qt/cups as f18) seem unaffected.

Also, tried disabling firewall just in case (which was a chore in itself, no thanks to firewalld), but no change.

Comment 2 Rex Dieter 2012-12-14 21:04:00 UTC
Ugh, rogue bad printer starting with "A..." on our network was causing issues.