Bug 887986

Summary: RFE: Configurable hardware models for disk/nic based manual user input
Product: Red Hat OpenStack Reporter: Alvaro Lopez Ortega <aortega>
Component: python-django-horizonAssignee: Julie Pichon <jpichon>
Status: CLOSED ERRATA QA Contact: Ido Ovadia <iovadia>
Severity: low Docs Contact:
Priority: medium    
Version: 1.0 (Essex)CC: ajeain, aortega, athomas, berrange, bsettle, jpichon, markmc, mrunge, oblaut, rbalakri, sclewis
Target Milestone: Upstream M2Keywords: FutureFeature, Triaged
Target Release: 6.0 (Juno)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/horizon/+spec/manage-image-custom-properties
Whiteboard: upstream_milestone_juno-2 upstream_definition_approved upstream_status_implemented
Fixed In Version: python-django-horizon-2014.2-4.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 887968 Environment:
Last Closed: 2015-02-09 09:53:44 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On: 887968, 990578    
Bug Blocks: 865345    

Description Alvaro Lopez Ortega 2012-12-17 13:36:44 EST
+++ This bug was initially created as a clone of Bug #887968 +++

This bug is a clone of bug # 865345.  That bug will be focused on using tools like libguestfs/libosinfo to select the proper drivers for each guest in an automated fashion.

This bug will be a simpler method, providing users the ability to manually select driver types on a per guest basis via API calls/parameters

Users should be able to choose between virtio for NIC/disk and options like e1000/rtl and IDE/SCSI

Not sure if other options should be exposed in addition to those, so add'l comments welcome on those lists.
Comment 2 Julie Pichon 2013-03-08 09:45:04 EST
What changes do we want for this in Horizon?
Comment 4 Daniel Berrange 2013-03-15 08:32:06 EDT
I don't really know what Horizon provides in terms of UI for uploading disk images yet. If it already has UI for setting arbitrary glance metadata properties, then no work is required.  If not, then either we need some kind of generic UI for setting arbitrary properties, or we create specific UI tailored towards each individual property we care about. I don't really have an opinion on the right approach here.
Comment 5 Matthias Runge 2013-03-15 08:46:21 EDT
There is no UI to upload disk images yet.

we have a UI to set the name (for reference), disk format, image location (to be copied from), minimum RAM and minimum disk and a checkbox to specify, if this is a public image.
Comment 6 Daniel Berrange 2013-03-15 08:48:52 EDT
Well I guess you could add further UI to set the  disk bus, cdrom bus & nic model then.
Comment 7 Matthias Runge 2013-03-15 09:24:00 EDT
Is there some info about what has been added?
Comment 10 Julie Pichon 2014-05-28 04:48:21 EDT
Currently being worked on upstream.
Comment 12 Ido Ovadia 2014-11-05 05:41:51 EST
No Metadata/property is avaliable on Horizon. User can only create new one
Comment 13 Julie Pichon 2014-11-10 11:59:53 EST
It looks like this blueprint was overridden during the same Juno cycle by https://blueprints.launchpad.net/horizon/+spec/glaance-metadata-flavors , see https://review.openstack.org/#/c/104956/ which includes in the review message "This patch also removes Edit Image Custom Properties screen as new widget provides the same functionality." That other blueprint seems to be tracked in BZ in bug 1125093 so we probably should close this one and track the testing over there instead.
Comment 17 errata-xmlrpc 2015-02-09 09:53:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0154.html