This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 888062

Summary: No handlers could be found for logger "keystoneclient.v2_0.client"
Product: Red Hat OpenStack Reporter: Russell Bryant <rbryant>
Component: python-keystoneclientAssignee: Alan Pevec <apevec>
Status: CLOSED CURRENTRELEASE QA Contact: Yaniv Kaul <ykaul>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.1CC: dprince, jhenner, jkt, mmagr
Target Milestone: snapshot3Keywords: Triaged
Target Release: 2.1   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-keystoneclient-0.2.0-1.el6ost Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-02-19 06:39:32 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:

Description Russell Bryant 2012-12-17 18:02:58 EST
While running through the Folsom getting started guide, this message is emitted from the keystone client application.  The first command from the guide that demonstrates this problem is:

[root@rhel ~(keystone_admin)]# keystone user-list
No handlers could be found for logger "keystoneclient.v2_0.client"
+----------------------------------+-------+---------+-------+
|                id                |  name | enabled | email |
+----------------------------------+-------+---------+-------+
| 12ab8ebd87bc496c93744bcabb40300f | admin |   True  |       |
+----------------------------------+-------+---------+-------+

It occurs with many other commands, as well.

Even if this message may technically be just an eye-sore, it will be alarming for users since it looks like an error has occurred.  It should be fixed so that this never comes up and causes false alarm.
Comment 2 Alan Pevec 2012-12-18 07:44:26 EST
Related upstream review https://review.openstack.org/#/c/18129/
Comment 3 Alan Pevec 2012-12-18 12:39:04 EST
*** Bug 888244 has been marked as a duplicate of this bug. ***
Comment 4 Dan Prince 2012-12-20 15:42:38 EST
*** Bug 889308 has been marked as a duplicate of this bug. ***
Comment 5 Yaniv Kaul 2012-12-25 02:19:12 EST
Runs fine for me - how do I reproduce this?
[root@ykaul-os-horizon ~]# source ~/keystonerc_admin 
[root@ykaul-os-horizon ~(keystone_admin)]$ keystone user-list
+----------------------------------+--------+---------+------------------+
|                id                |  name  | enabled |      email       |
+----------------------------------+--------+---------+------------------+
| 6d3e685e0fd34060bc9e47bda8111abc | cinder |   True  | cinder@localhost |
| 9fd9b8a4af3941f7aaa8d4ee1876d409 |  nova  |   True  |  nova@localhost  |
| d4817354f0474935bbc5b4e6ca5a5862 | glance |   True  | glance@localhost |
| de5640ce59c84367b78bfd97cf07eb6d | admin  |   True  |  test@test.com   |
| fe51e484199e43b7b452df12035e1730 | ykaul  |   True  | ykaul@redhat.com |
+----------------------------------+--------+---------+------------------+
Comment 6 Jaroslav Henner 2013-02-11 09:09:23 EST
I accidentaly reproduced this with old puddle:

[folsom-rhel6.xxx] out: No handlers could be found for logger "keystoneclient.v2_0.client"
[folsom-rhel6.xxx] out: Authorization Failed: Unable to communicate with identity service: Unable to find the server at external_server_value. (HTTP 400)

It happens when OS_AUTH_URL is wrong:
cat keystonerc_admin_bad 
export OS_USERNAME=admin
export OS_TENANT_NAME=admin
export OS_PASSWORD=verybadpass
export OS_AUTH_URL=http://EXTERNAL_SERVER_VALUE:35357/v2.0/
export PS1="[\u@\h \W(keystone_admin)]$ "

and trying something like
keystone tenant-create --name=demo
Comment 8 Jaroslav Henner 2013-02-19 06:39:32 EST
[root@folsom-rhel6 ~(keystone_admin_bad)]$ keystone tenant-create --name=testik 
Authorization Failed: Unable to communicate with identity service: Unable to find the server at asdf. (HTTP 400)

I think it has been fixed already.