Bug 888244 - Missing log handler
Missing log handler
Status: CLOSED DUPLICATE of bug 888062
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone (Show other bugs)
2.0 (Folsom)
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Adam Young
Yaniv Kaul
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-18 06:46 EST by Martin Magr
Modified: 2013-07-03 22:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-18 12:39:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Magr 2012-12-18 06:46:32 EST
Description of problem:
When you go through user guide [1] and I noticed that there's probably missing logging handler during listing keystone users:

[para@virtual-rhel-beta ~(keystone_admin)]$ keystone user-list
No handlers could be found for logger "keystoneclient.v2_0.client"
+----------------------------------+-------+---------+-------+
|                id                |  name | enabled | email |
+----------------------------------+-------+---------+-------+
| 9faa54c7daaa4f2cbbf8917dbe7967f4 | admin |   True  |       |
+----------------------------------+-------+---------+-------+

Version-Release number of selected component (if applicable):
[para@virtual-rhel-beta ~(keystone_admin)]$ rpm -qa *keystone
openstack-keystone-2012.2.1-1.el6ost.noarch
python-keystone-2012.2.1-1.el6ost.noarch

How reproducible:
Always, see above description

Steps to Reproduce:
1. Follow https://access.redhat.com/knowledge/docs/en-US/Red_Hat_OpenStack_Preview/2/html/Getting_Started_Guide/ch03s02.html

  
Actual results:
Logging warning.

Expected results:
No warning.

Additional info:
None
Comment 2 Martin Magr 2012-12-18 06:55:38 EST
Note that this is probably global, because it is happening also when creating endpoint:

[para@virtual-rhel-beta ~(keystone_admin)]$ keystone endpoint-create --region RegionOne --service_id 712b22b824ce4ff1aa77ad49da1ce74d --publicurl 'http://127.0.0.1:5000/v2.0' --adminurl 'http://127.0.0.1:35357/v2.0' --internalurl 'http://127.0.0.1:5000/v2.0'
No handlers could be found for logger "keystoneclient.v2_0.client"
+-------------+----------------------------------+
|   Property  |              Value               |
+-------------+----------------------------------+
|   adminurl  |   http://127.0.0.1:35357/v2.0    |
|      id     | a7013460372d4bb1adeb562904bd6760 |
| internalurl |    http://127.0.0.1:5000/v2.0    |
|  publicurl  |    http://127.0.0.1:5000/v2.0    |
|    region   |            RegionOne             |
|  service_id | 712b22b824ce4ff1aa77ad49da1ce74d |
+-------------+----------------------------------+
Comment 3 Alan Pevec 2012-12-18 12:39:04 EST

*** This bug has been marked as a duplicate of bug 888062 ***

Note You need to log in before you can comment on or make changes to this bug.