Bug 888071

Summary: warning: %postun(libvirt-client-0.10.2.2-2.fc18.x86_64) scriptlet failed, exit status 1
Product: [Fedora] Fedora Reporter: Cole Robinson <crobinso>
Component: libvirtAssignee: Libvirt Maintainers <libvirt-maint>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 18CC: berrange, clalancette, itamar, jforbes, joshua, jyang, laine, libvirt-maint, veillard, virt-maint
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-06 15:12:53 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Cole Robinson 2012-12-17 18:33:18 EST
$ sudo rpm -e --nodeps libvirt-client
/sbin/ldconfig: relative path `0' used to build cache
warning: %postun(libvirt-client-0.10.2.2-2.fc18.x86_64) scriptlet failed, exit status 1

Some info here:
http://en.opensuse.org/openSUSE:Packaging_scriptlet_snippets

Fix is:

diff --git a/libvirt.spec b/libvirt.spec
index ccf1d97..f9ff5f3 100644
--- a/libvirt.spec
+++ b/libvirt.spec
@@ -1588,8 +1588,9 @@ fi
 /sbin/chkconfig --add libvirt-guests
 %endif
 
-%postun client -p /sbin/ldconfig
+%postun client
 
+/sbin/ldconfig
 %if %{with_systemd}
 %if %{with_systemd_macros}
 %systemd_postun_with_restart libvirt-guests.service
Comment 2 Peter Krempa 2012-12-18 02:41:06 EST
*** Bug 888143 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2012-12-18 10:17:38 EST
libvirt-0.10.2.2-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libvirt-0.10.2.2-3.fc18
Comment 4 Fedora Update System 2012-12-20 00:37:49 EST
libvirt-0.10.2.2-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.