Bug 890121

Summary: Lots of device properties are different in the 'info qtree' output - RHEL6.0 host VS RHEL6.4 host (-M rhel6.0.0) - Non-default devices
Product: Red Hat Enterprise Linux 6 Reporter: Qunfang Zhang <qzhang>
Component: qemu-kvmAssignee: Eduardo Habkost <ehabkost>
Status: CLOSED NOTABUG QA Contact: Virtualization Bugs <virt-bugs>
Severity: high Docs Contact:
Priority: medium    
Version: 6.4CC: acathrow, amit.shah, areis, armbru, bsarathy, dyasny, juzhang, michen, mkenneth, rhod, shuang, virt-maint
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-05-21 11:28:03 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
'info qtree' output on rhel6.0 host with *non-default* parameters
none
'info qtree' output on rhel6.4 host (-M rhel6.0.0) with *non-default* paramters
none
rhel6.0.0 diff (generated from the data in the ODT file)
none
rhel6.1.0 diff (generated from the data in the ODT file)
none
rhel6.2.0 diff (generated from the data in the ODT file)
none
rhel6.3.0 diff (generated from the data in the ODT file) none

Description Qunfang Zhang 2012-12-25 03:51:15 EST
Description of problem:
This bug is similar with bug 889995 but for different devices. In this bug I listed the non-default devices like usb device,virtio-serial, virtio balloon, qxl vga type, etc. 
Create separate bugs because tracking all devices in one bug maybe a little muddle,huge and hard to set the priority. 
Of course any suggestions or method to track multiple devices issue are welcomed. 

Version-Release number of selected component (if applicable):
RHEL6.4 host:
kernel2.6.32-348.el6.x86_64
qemu-kvm-0.12.1.2-2.346.el6.x86_64

RHEL6.0-z host:
kernel-2.6.32-71.40.1.el6.x86_64
qemu-kvm-0.12.1.2-2.113.el6_0.8.x86_64

How reproducible:
Always


Steps to Reproduce:
1. Boot a guest on rhel6.0 host and attach as more devices as possible that 6.0 supported.
# /usr/libexec/qemu-kvm -S -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name rhel6.1-64 -uuid 69f4aa4b-a575-348e-934b-0c27f138c735  -monitor stdio -rtc base=utc -no-shutdown -boot order=nc,menu=on -drive file=/home/disk.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0  -drive file=/home/boot.iso,id=drive-cdrom,format=raw,if=none,werror=stop,rerror=stop,media=cdrom -device ide-drive,drive=drive-cdrom,id=cdrom -netdev tap,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:8a:36:ae,bus=pci.0,addr=0x3 -netdev tap,id=hostnet1 -device e1000,netdev=hostnet1,id=net1,mac=52:54:00:8a:36:20,bus=pci.0,addr=0x4 -netdev tap,id=hostnet2 -device virtio-net-pci,netdev=hostnet2,id=net2,mac=52:54:00:8a:36:20,bus=pci.0,addr=0x5 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device AC97,id=sound0,bus=pci.0,addr=0x6 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x8 -chardev socket,id=channel0,host=127.0.0.1,port=12345,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=channel0,id=channel0,name=com.redhat.rhevm.vdsm -k en-us -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=input0  -device usb-kbd,id=kbd -device usb-mouse,id=mouse  -drive file=/home/disk-2.qcow2,if=none,id=drive-virtio0,format=qcow2,cache=none,rerror=stop,werror=stop -device virtio-blk-pci,bus=pci.0,addr=0xa,drive=drive-virtio0,id=virtio0  -drive file=/home/floppy.img,if=none,id=drive-fdc0-0-0,readonly=on,format=raw -global isa-fdc.driveA=drive-fdc0-0-0 -vnc :10 -vga std -watchdog i6300esb -watchdog-action pause 

2. On 6.0 host:
(qemu)info qtree

3. Boot guest on rhel6.4 host with the same command line as step 1 but append "-M rhel6.0.0".

4. (qemu)info qtree

5. Compare the output on step 2 and step 4. 
  
Actual results:
Lot's of properties are different, some properties showing up on 6.4 host but not on 6.0 host.
Some property values are changed on 6.4 host.
Here only highlight some of them, for detail please check attachment. 
(Blue front means "properties exists on 6.4 but not on 6.0;
 Red front means "property value changed on rhel6.4 host")

Highlight:
(1) "dev-prop: indirect_desc = on" for virtio devices on rhel6.4 host with -M rhel6.0.0, but on rhel6.0 host, it is "dev-prop: indirect_desc = off"

(2) with -vga qxl frontend, lot's of properties changed or new properties showing up on rhel6.4 host. That make migration between 6.0<->6.4 failed.

(3) Lots of properties value changed for virtio-net-pci driver and some new properties showing up on 6.4 host, for detail please check the attachment.



Expected results:


Additional info:
Comment 1 Qunfang Zhang 2012-12-25 03:54:44 EST
Hi, Markus and Amit
I did not set "blocker?" for this bug and please help assess the issue and feel free to modify if need. Comments are welcomed to help identify the severity of each devices described in the attachment
Comment 2 Qunfang Zhang 2012-12-25 03:55:35 EST
Created attachment 668783 [details]
'info qtree' output on rhel6.0 host with *non-default* parameters
Comment 3 Qunfang Zhang 2012-12-25 03:56:56 EST
Created attachment 668784 [details]
'info qtree' output on rhel6.4 host (-M rhel6.0.0) with  *non-default* paramters
Comment 4 Qunfang Zhang 2012-12-25 04:07:12 EST
For virtio serial device, "dev-prop-int: guest_connected: 1" displays on rhel6.0 host.  while "dev-prop-int: guest_connected: 0" displays on rhel6.4 host with -M rhel6.0.0.
Comment 6 Eduardo Habkost 2012-12-26 12:08:16 EST
*** Bug 890130 has been marked as a duplicate of this bug. ***
Comment 7 Eduardo Habkost 2012-12-26 12:08:18 EST
*** Bug 890144 has been marked as a duplicate of this bug. ***
Comment 8 Eduardo Habkost 2012-12-26 12:08:19 EST
*** Bug 890149 has been marked as a duplicate of this bug. ***
Comment 10 Eduardo Habkost 2013-01-10 08:54:15 EST
Created attachment 676325 [details]
rhel6.0.0 diff (generated from the data in the ODT file)
Comment 11 Eduardo Habkost 2013-01-10 08:54:40 EST
Created attachment 676326 [details]
rhel6.1.0 diff (generated from the data in the ODT file)
Comment 12 Eduardo Habkost 2013-01-10 08:55:05 EST
Created attachment 676327 [details]
rhel6.2.0 diff (generated from the data in the ODT file)
Comment 13 Eduardo Habkost 2013-01-10 08:55:30 EST
Created attachment 676328 [details]
rhel6.3.0 diff (generated from the data in the ODT file)