Bug 890144 - Lots of device properties are different in the 'info qtree' output - RHEL6.2 host VS RHEL6.4 host (-M rhel6.2.0) - Non-default devices
Lots of device properties are different in the 'info qtree' output - RHEL6.2 ...
Status: CLOSED DUPLICATE of bug 890121
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
Depends On:
  Show dependency treegraph
Reported: 2012-12-25 04:49 EST by Qunfang Zhang
Modified: 2012-12-26 12:08 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-12-26 12:08:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
'info qtree' output on rhel6.2 host with *non-default* parameters (17.04 KB, application/vnd.oasis.opendocument.text)
2012-12-25 04:51 EST, Qunfang Zhang
no flags Details
'info qtree' output on rhel6.4 host (-M rhel6.2.0) with *non-default* paramters (17.14 KB, application/vnd.oasis.opendocument.text)
2012-12-25 04:52 EST, Qunfang Zhang
no flags Details

  None (edit)
Description Qunfang Zhang 2012-12-25 04:49:19 EST
Description of problem:
This bug is similar with bug 890117 but for different devices. In this bug I listed the non-default devices like usb device,virtio-serial, virtio balloon, qxl vga type, etc. 
Create separate bugs because tracking all devices in one bug maybe a little muddle,huge and hard to set the priority. 
Of course any suggestions or method to track multiple devices issue are welcomed. 

Version-Release number of selected component (if applicable):
RHEL6.4 host:

RHEL6.2-z host:

How reproducible:

Steps to Reproduce:
1. Boot a guest on rhel6.2 host and attach as more devices as possible that 6.2 supported.

# /usr/libexec/qemu-kvm -S -enable-kvm -m 1024 -smp 1,sockets=1,cores=1,threads=1 -name rhel6.1-64 -uuid 69f4aa4b-a575-348e-934b-0c27f138c735  -device sga -monitor stdio -rtc base=utc -no-shutdown -boot order=nc,menu=on -drive file=/home/disk.qcow2,if=none,id=drive-ide0-0-0,format=qcow2,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0  -drive file=/home/boot.iso,id=drive-cdrom,format=raw,if=none,werror=stop,rerror=stop,media=cdrom -device ide-drive,drive=drive-cdrom,id=cdrom -netdev tap,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=52:54:00:8a:36:ae,bus=pci.0,addr=0x3 -netdev tap,id=hostnet1 -device e1000,netdev=hostnet1,id=net1,mac=52:54:00:8a:36:20,bus=pci.0,addr=0x4 -netdev tap,id=hostnet2 -device virtio-net-pci,netdev=hostnet2,id=net2,mac=52:54:00:8a:36:20,bus=pci.0,addr=0x5 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -device intel-hda,id=sound0,bus=pci.0,addr=0x6 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x8 -chardev socket,id=channel0,host=,port=12345,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=channel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0 -k en-us -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device usb-tablet,id=input0 -device  usb-hub,bus=usb.0,port=2,id=hub -device usb-storage,bus=usb.0,port=2.4,drive=drive-usb-2-0,id=usb-2-0,removable=on  -drive file=/home/usb.qcow2,if=none,id=drive-usb-2-0,media=disk,format=qcow2,cache=none,werror=stop,rerror=stop,aio=threads -device usb-kbd,id=kbd,port=2.1 -device usb-mouse,id=mouse,port=2.2 -device usb-ehci,id=ehci,bus=pci.0,addr=0x9 -device usb-storage,drive=drive-usb-0-0,id=usb-0-0,removable=on,bus=ehci.0,port=1  -drive  file=/home/usb-2.qcow2,if=none,id=drive-usb-0-0,media=disk,format=qcow2,cache=none,werror=stop,rerror=stop,aio=native -drive file=/home/disk-2.qcow2,if=none,id=drive-virtio0,format=qcow2,cache=none,rerror=stop,werror=stop -device virtio-blk-pci,bus=pci.0,addr=0xa,drive=drive-virtio0,id=virtio0  -drive file=/home/floppy.img,if=none,id=drive-fdc0-0-0,readonly=on,format=raw -global isa-fdc.driveA=drive-fdc0-0-0 -vnc :10 -vga std -watchdog i6300esb -watchdog-action pause 

2. On rhel6.2-z host:
(qemu) info qtree

3. Boot guest on rhel6.4 host with the command line in step 1 but append "-M rhel6.2.0"

4. On rhel6.4 host:
(qemu)info qtree

5. Compare the output on step 2 and step 4.

Actual results:
Lot's of properties are different, some properties showing up on 6.4 host but not on 6.2 host.
Some property values are changed on 6.4 host.
Here only highlight some of them, for detail please check attachment. 
(*Blue* front means "properties exists on 6.4 but not on 6.2;
 *Red* front means "property value changed on rhel6.4 host")

(1)virtio block device:
On rhel6.4 host with -M rhel6.2.0:  "dev-prop: ioeventfd = off"
On rhel6.2 host: dev-prop: ioeventfd = on

(2) For virtio serial devices:
On rhel6.4 host:
spicevmc serialport:
  dev-prop-int: guest_connected: 0 
  dev-prop-int: host_connected: 0 
another serial port for transferring data:
 dev-prop-int: guest_connected: 0 
 dev-prop-int: host_connected: 0 

But on rhel6.2 host:
spicevmc serialport:
  dev-prop-int: guest_connected: 1
  dev-prop-int: host_connected: 1
another serial port for transferring data:
 dev-prop-int: guest_connected: 1 
 dev-prop-int: host_connected: 0 
(3)Please check attachment for rhel6.4 host, lot's of properties showing up on rhel6.4 host, I marked them with blue front.

Expected results:

Additional info:
Comment 1 Qunfang Zhang 2012-12-25 04:51:14 EST
Created attachment 668827 [details]
'info qtree' output on rhel6.2 host with *non-default* parameters
Comment 3 Qunfang Zhang 2012-12-25 04:52:11 EST
Created attachment 668828 [details]
'info qtree' output on rhel6.4 host (-M rhel6.2.0) with  *non-default* paramters
Comment 4 Eduardo Habkost 2012-12-26 12:08:18 EST
Unifying bugs. See bug 889995 comment #8.

*** This bug has been marked as a duplicate of bug 890121 ***

Note You need to log in before you can comment on or make changes to this bug.