This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours

Bug 890308

Summary: Gnuplot linking readline and license problem
Product: [Fedora] Fedora Reporter: mejiko <kame55-itasenpara123>
Component: gnuplotAssignee: Frantisek Kluknavsky <fkluknav>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 17CC: fkluknav, pertusus, pschiffe
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-01-13 23:23:50 EST Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 182235    

Description mejiko 2012-12-26 05:10:26 EST
Hello.

gnuplot linked readline. readline is licensed under GPL. 
gnuplot license is GPL incompatible.

bug #134972 (See: https://bugzilla.redhat.com/show_bug.cgi?id=134922#c4) conclusion is:

"This package is dual (GPL and Gnuplot License) license, Its GPL compatible."

but *ALL* gnuplot source code file is not dual (Gnuplot license and GPL) license. I think that gnuplot is not GPL compatible (violate GPL) and non-redistributable. because This *ALL* gnuplot source code file is not dual (Gnuplot license and GPL) license. 

"Licensed under GPL or Gnuplot license source code + Licensed under Gnuplot license only source code + linking readline (licensed under GPL) => license incompatible (Gnuplot vs GPL)"

Suggests:

1. replace readline to editline.
2. Dropping readline.
3. Remove Fedora repos.


and this package is not compliant gnuplot license (Section 2, 3, and 4). See debian bug number 404270. 

thanks.


Reference:

http://git.overlays.gentoo.org/gitweb/?p=proj/sci.git;a=blob;f=sci-visualization/gnuplot/files/gnuplot-4.5.9999-gentoo-version.patch;h=3630a1a4dec949470de7fbedf08518b90127eec5

http://xpisar.wz.cz/ebuilds/portage/sci-visualization/gnuplot/files/gnuplot-gentoo-version.patch

http://sources2.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sci-visualization/gnuplot/ChangeLog?revision=1.195&view=markup
Comment 1 mejiko 2012-12-26 05:11:25 EST
Blocking FE-Legal, This is license problem.
Comment 2 Fedora Update System 2013-01-04 14:59:14 EST
gnuplot-4.6.1-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnuplot-4.6.1-4.fc18
Comment 3 Fedora Update System 2013-01-05 16:55:51 EST
Package gnuplot-4.6.1-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnuplot-4.6.1-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-0307/gnuplot-4.6.1-4.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-01-13 23:23:53 EST
gnuplot-4.6.1-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.